Starting Solaar kills Logitech MX Master 3 mouse wheel after upgrade to OpenSUSE 15.4


After upgrade to OpenSUSE 15.4 the mouse wheel on my Logitech MX Master 3 doesn’t work anymore if I start Solaar. It works before start but not after, even if I quit Solaar. It starts working again if I unplug the receiver abd plug it in again. I have tried reinstalling Solaar but that didn’t help.

I have Solaar 1.1.0 from the Main Repositoy (OSS).


Solved it. Apparently the Scroll Wheel Resolution must be turned on, meaning high resolution. Otherwise the scroll wheel doesn’t work. With high resolution the wheel behaves like in Solaar 1.0.4 (OpenSUSE 15.3) with the low resolution setting.

I’m glad you have solved it. I’m using a fairly basic logitech mouse (an M325). I usually don’t install solaar, because it doesn’t seem particularly useful.

Want it mostly for the battery indicator.

Depended on the DE you are using, the battery indicator is a builtin feature. As example under KDE Plasma the mouse battery is shown together with the laptop battery in the taskbar.

I’m using KDE, which shows the logitech battery info in its power manager applet. It is not perfect. It currently says that it is 55%. And that’s the reading I get with a new battery. So the calibration is off. More important, it will pop up a warning when the battery is running low.

This is good to know because I have had Solaar installed in Linux Mint, but haven’t yet in openSUSE Tumbleweed. I generally don’t need it for anything, but the battery indicator is useful especially for my K860 Ergonomic keyboard. I’ve always liked Logitech’s hardware.