SQX dissabled by bios

Hello,
After I updated system this evening, I got message: “SQX disabled by BIOS” and system can not boot. Now I boot from installing usb-stick and some of previous installations. Is there any way to fix this problem? I use Leap 15.4
Thank you for answering my questions.

Did you check the obvious and tried to enable Intel Software Guard Extension (SGX) in your BIOS?

I unfortunately dont know how to do it. I have some Gigabyte MB. If there is any way to read MB model, please tell me.

On most Gigabyte motherboards you need to press “Del” when you startup your system to enter BIOS settings…

This is clear - i did it before, so I know. Meanwhile I searched how to enable this on my Motherboard. And found it. So, would it be some damage if I enable this? Would I get it back the way I changed it? In Serbia we say: “Caution is mother of wisdom”. So I want to be sure. I know you will understand.

Is there any way to escape this SGX issue?

I have the same problem after today’s update.
However, I can boot with the previous kernel.
Does it have to be that way? I don’t like messing around in the BIOS.

Could it be that the reason for the hanging has nothing to do with this message?
See: Bug 1209436 – I915 hangs on Kernel vmlinuz-5.14.21-150400.24.49

This is easy to test. If your system starts after changing the BIOS setting, it is related. If your system still not starts after changing the setting, it is not related. And you can revert the setting as every other setting in the BIOS too…

If your symptoms are the same as in the bugreport, it is most likely this problem. But based on the lack of provided infos here in this thread…nobody can say for sure…

I think this kernel just hangs and whatever the last message was stays displayed.
I don’t think the error is related to that.
I can’t say anything more because there’s nothing more to see.
Nothing works, not even Alt+Ctrl+Del.

I have the same problem after the last update. I enabled SGX in bios and it still won’t boot.

If it cold help: when I get back in previous kernel, message also appears, but about few moments, but computer enters graphics mode. It is something I saw before, but not make problem with that because computer could enter graphic mode. Now it can not enter. I mention that I did not touch anything before last kernel updating.

And, please, don’t think that I am spammer; just want to say how I fixed this problem: I add graphic independent card, system finished startup and drivers in kernel were activated (if I can say this way), so everything works. I think it is important just to start up for the first time. Now I can choose between processor’s graphic card or indipendent graphic card. Inedpendent card I added is three years old card (so, model is 3+ years old - no need to be new model).

I believe this could help.

I’m still not able to boot my system. I have to choose an older version.

This seems like a bug with the recent update. How to go about reporting this?

Good news. With the most recent update package, this problem is resolved.

1 Like

WOW! I’m really happy because of that! Thanks to all developers! :slight_smile: