Spectacle fade screen, how to get rid?

on my leap 15.4 with KDE Argon 23.04.01 and spectacle Version 23.04.1 when I click on rectangular region the screen


:

is


that is very difficult to read it.
is there a way to get rid of this fading and have the normal screen only with the selection rectangle as in the past??

Are you sure it is related to spectacle and not to your Plasma systemsettings? Check “semi-transparency of inactive windows” or smt like that in systemsettings…
Spectacle Version 23.04.1 on Tumbleweed does not have such a problem.

Additionally some context would help: wayland or X11 session?
Any messages in a terminal?

manythanks, my session should be x11
pla@pla4-TW:~> loginctl show-session loginctl|grep pla|awk '{print $1}' -p Type
Type=x11
pla@pla4-TW:~>

may be it is my systemsettings but I don’t know where I have to look.
looking for semitransparency the only thing I foundis in systemsettings-desktop effects
I removed the related settings

and launched spectacle but nothing changed

I am not sure that this is a complete description of what you do.

When I start Spectacle (by hitting the PrintScrn key) and then choose Rectangle Region at top-right andf then click Take a new Screenshot my cursor changes into a + and I can then click a corner of what I region I want to select. The whole screen then gets a grey haze over it (but stays readable) and when I move the cursor a rectangular area without the haze is formed to denote what the rectangle is.

So there is a “fog” over the screen, but it is not unreadable.

And there is a Configure button and that shows in the General tab some option for the Rectangular Region. Did you try to play with it?

manythanks, my version is a bit different, (the version 21.12.3 on leap 15.4 on my son’e laptop is the same of your and works perfectly like your)
in my version the fog and the rectangle is like in the picture I posted, in your version is ok.
I played with configure button but without success

I have indeed Version 21.12.3.
And as I updated 2023-05-16 I assume that is the current version of openSUSE LEAP 15.4.

my is KDE Argon 23.04.01 and spectacle Version 23.04.01

Did you already try the basics like testing with a fresh user?

I know vaguely that such things like “Argon” exist, but have no idea if that is an official openSUSE version (from the standard repos. When not, then maybe contact the maintainers?

not, tried now, not with fresh user but with another already existentit, works very better, how can I reset spectacle or settings as the working user??

Well, look for a file with a name inclusing the string spectacle inside ~/.config and ~/.local

Here:

enk@boven:~> find .config -name '*spectacle*'
.config/spectaclerc
.config/kde.org/spectacle.conf
henk@boven:~>

like this?

> pla@pla4-TW:~> find .config -name '*spectacle*'
> .config/spectaclerc
> .config/kde.org/spectacle.conf
> pla@pla4-TW:~> find .local -name '*spectacle*'
> .local/share/icons/Breeze-openSUSE Dark Icons/apps/48/spectacle.svg
> .........................a lot about icons...............................
> .local/share/RecentDocuments/spectacle-Screenshot_20230520_164306.png[2].desktop
> .local/share/RecentDocuments/web_spectacle-faded-P_20230520_152723.jpg.desktop
> .local/share/plasma_icons/org.kde.spectacle.desktop
> .local/share/plasma_icons/org.kde.spectacle (1).desktop
> pla@pla4-TW:~> 

I renamed
.config/spectaclerc
.config/kde.org/spectacle.conf
launched spectacle
.config/spectaclerc >>>>has been recreated
.config/kde.org/spectacle.conf >>>this not
but the fading behaviour doesn’t change

sorry but quote as [/code] in this unconfortable software is hard and difficult

I can confirm your Problem.

My system is

Operating System: openSUSE Tumbleweed 20230520
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
Kernel Version: 6.3.2-1-default (64-bit)
Graphics Platform: X11
Graphics Processor: Mesa Intel® HD Graphics 630
# zypper se -si spectacle
Loading repository data...
Reading installed packages...

S  | Name           | Type    | Version     | Arch   | Repository
---+----------------+---------+-------------+--------+------------------------
i+ | spectacle      | package | 23.04.1-1.1 | x86_64 | openSUSE Tumbleweed Oss
i+ | spectacle-lang | package | 23.04.1-1.1 | noarch | openSUSE Tumbleweed Oss
#

So far I have found no solution to the problem but a workaround:

I disable the compositor:

systemsettings5Display and MonitorCompositor disable Compositing: Enable on startup

This gives me back the old behavior of the spectacle selection area (bright on dimmed background).

The following two sites were quite helpful to me:

Discourse new user guide
Markdown reference

Especially the second one helped me to work out how to format my posts.

There is a bug for this. 469022 – Selected area bleaches text

I’m having the same issue with nvidia prime-select “offload”.

The wrappers script forcing spectacle onto nvidia works for me: Reddit - Dive into anything (Original at 469022 – Selected area bleaches text)

Using XMG Neo 15 M19 (Tongfang GK5CQ7Z - it has many resellers) (Optimus) with Mesa Intel(R) UHD Graphics 630 and DGPU NVIDIA GeForce 2060 with G06 driver from the nvidia repo.

PS: Tumbleweed (up to date). I noticed the thread is tagged “leap”.

I’m currently observing this as well on tumbleweed (20230807) with an intel cpu / gpu (i7-7700T). Turning the compositor off fixes it.

Device-1: Intel HD Graphics 630 driver: i915 v: kernel
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2 driver: X:
loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915 resolution:
1: 1920x1080~60Hz 2: 1920x1080~60Hz
API: OpenGL v: 4.6 Mesa 23.1.5 renderer: Mesa Intel HD Graphics 630 (KBL GT2)

Kernel: 6.4.8-1-default

As referenced before by @jonzn4suse on May 23rd “469022 - Selected area bleaches text”

The most recent post (2023-07-16 15:13:37 UTC) states:

I just noticed that if Spectacle is set to use last-used capture mode when opened
(Rectangular Region for me), the screen is not bleached.

This works for me as well.

2 Likes

I wanted to keep this to myself, but cannot. Go edit an image with gwenview and then click on Annotate. I was happily surprised. ;-))