Spacebar opens the first file that has the search word

Hi,
I experience unusual behavior of spacebar in specific applications. When I open a folder in an application using Ctrl+O (or open folder icon), open search bar using Ctrl+F and type the file name, pressing space bar automatically selects the first file that has the search word in the file. For example, if the folder has files “test file 1”, “test file 2” and “test file 3”, typing “test” in the search bar and hitting the spacebar automatically selects “test file 1”. So, I am unable to select and open either “test file 2” or “test file 3”. A short video showing this behavior is given below
https://www.dropbox.com/s/wf8hanp5vp9mcts/testing-2020-04-08_11.57.16?dl=0

This behavior is observed in the following applications in my computer
Libreoffice 6.3
Evince
Gnumeric
Zim wiki
Abiword

One thing (I think) is common among the applications is they are GNOME/GTK based. I do not see this behavior in KDE applications. Your help in resolving this issue is greatly appreciated.

I can confirm such behaviour for LibreOffice and Evince on Gnome (didn’t check the others), but apparently the space bar just opens the file currently selected, not necessarily the first in the search list.
So when you entered the first search word, scroll down the list with the arrow keys and when the file you want is highlighted press the space bar.

In the Help for Gnome such shortcut is described as:

SPACE Activate a focused item such as a button, check box, or list item.

You are right, spacebar opens the file currently selected. Is there a way to disable this “SPACE: Activate a focused item such as a button, check box, or list item.” feature in KDE ? If not, how do I enter a space in search bar of GNOME/GTK applications ?

Unconfirm this behaviour with KDE.

You mean you don’t see the behavior in GNOME/GTK applications (Libreoffice, Evince, etc. ) running in KDE ?

Yes, exactly.

The issue seems to be present in my KDE running GNOME/GTK applications. According to the GNOME document (https://help.gnome.org/users/gnome-help/stable/keyboard-nav.html.en) Space bar activates a focused item such as a button, check box, or list item, which seems to be the case in my KDE. Do you have any suggestions for resolving this issue in my system ?