Sound, VLC setup

FWIW, info only

After clean install of 64bit version sound worked ok.

after initialization of sound cards via yast-sound
the additional package was needed


vlc did not play encrypted film-dvds before install of


should not these packages be included as dependencies?


You’ll find the need to change vendor to Packman necessary to acquire and run multimedia codecs which are not completely free. Unlike some other distros, SUSE/openSUSE takes a very strict stance on any apps and libraries that are not completely free.

Find the number your Packman repo is by displaying your repos as follows

zypper lr

Noting the number of your Packman repo,

zypper dup --from *Packman_repo_number* 

Now, whenever a package exists both in OSS and Packman, Packman packages will be given a priority.

Your problem should be solved.



thx for the reply

the alsa install is a mix, (maybe a partial update of repos)

alsa, alsa-plugins, alsa-plugins-pulse, alsa-plugins-pulse-32bit
are version 1.0.29-10.1 from

alsa-oss, alsa-oss-32bit are version 1.0.28-5.2 also from
URL: |

alsa-utils is version 1.0.29-9.1 from

alsa-firmware is version 1.0.29-3.2 also from

all of the vlc packages are version 2.2.2-2.1 from
(so no cross source)

libdvdcss2-1.2.13-5.2.x86_64 is from URL:

all are latest updates per <2016Feb29><22:21>