Sound stopped working

Hi everyone,

after my system has been running fine for a while, I stopped getting sound from my laptop’s speakers at some point (obviously I must have done something to cause this, but I have no idea what it might have been). I still had sound on my headphones, though. When I tried to fix this, I managed to make it such that my headphones now don’t work anymore as well…
I’ve been mostly following steps as given here:

When configuring my soundcard with YaST, I can hear a test sound, so it’s not a hardware issue. Once the configuration is finished, I don’t get any sound, though…

I wasn’t able to find my codecs or anything else that might be helpful, so far.

Please find the result of here:

Also, here’s the output of speaker-test -c2 -l5 -twav:

speaker-test 1.0.28

Wiedergabe-Gerät ist default
Stream-Parameter sind 48000 Hz, S16_LE, 2 Kanäle
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4259:(_snd_config_evaluate) function snd_func_card_driver returned error: Datei oder Verzeichnis nicht gefunden
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4259:(_snd_config_evaluate) function snd_func_concat returned error: Datei oder Verzeichnis nicht gefunden
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4259:(_snd_config_evaluate) function snd_func_refer returned error: Datei oder Verzeichnis nicht gefunden
ALSA lib conf.c:4738:(snd_config_expand) Evaluate error: Datei oder Verzeichnis nicht gefunden
ALSA lib pcm.c:2259:(snd_pcm_open_noupdate) Unknown PCM sysdefault
Fehler beim Öffnen des Gerätes: -2, Datei oder Verzeichnis nicht gefunden

“Datei oder Verzeichnis nicht gefunden” is German for “Could not find file or directory”

I’d usually try to solve stuff on my own (and learn a lot by doing so), but this is beyond me and I need my sound to be working for video conferences, so I’d highly appreciate any help on the matter.


And the openSUSE version is …?
And the desktop used is …?

I thought it was all in the link provided ( but you’re right, the desktop environment is missing.
I’m using KDE 4.14.5 on openSUSE 13.2.

Does not look like pulse audio is running

Do you see more then one sound device in Yast? Is pulse audio selected on in Yast?

if Pulse is working install pavolcontrol. Helps in connection audio input to output.

In KDE-Configure Desktop-multimedia be sure the sound works there/

There’s only one sound card visible in yast. I’ve removed and redid the configuration several times now.
pulse-audio support is enabled, according to yast.
pavucontrol is installed and I can visually see that sound should be playing when I play a youtube video or a test sound in KDE-configurations Desktop-Multimedia (where pulse is selected as audio stream).

Interestingly, my laptop’s “Volume up/ Volume down” buttons don’t seem to do anything anymore.

Thanks for the inputs so far, but I really can’t get a grip on this still…

be sure that the output selected is the real device. Be sure the volumes are not muted and reasonable volume level

If you have a HDMI out put select try another

Is this Intel sound and an Intel GPU??

Okay, so today - after rebooting - I had sound on my headphones again.

Is this Intel sound and an Intel GPU??


Be sure the volumes are not muted and reasonable volume level

After having tried many less obvious things, I finally found the “Other>Volume” section in YaST and indeed… the speaker volume was set to zero, while headphones were up.

It seems to be working so far.
Thanks gogalthorp and also hcvv for the inputs!

I really do wonder, however, what might have caused the sound settings to change. After all, I’ve never knowingly messed with it and it was all right up until recently…

Anyway, thanks again!

I have seen volume go to zero after some updates. but that was several versions ago.

This makes sense - after a clean reboot. Looking at the script output, there were suspicious entries errors in the dmesg, including a segfault. It reads like some thermal / acpi app was loaded, causing this.

[12238.968247] thinkpad_acpi: EC reports that Thermal Table has changed
[13223.032982] thinkpad_acpi: EC reports that Thermal Table has changed
[13360.251214] plugin-containe[9405]: segfault at 0 ip 00007fd70aafa24b sp 00007fff71f35860 error 4 in[7fd70a1a2000 3d23000]

So, the speaker volume kept reverting back to zero after boot.
I ended up editing


as described here: .
This seems to work, so far.

Thanks for the input but I don’t know enough to make sense of what you pointed out…

I have the same annoying problem on my opensuse 13.2 notebook.

No audio after boot. Never. Sometimes audio via headphones, but not always. Audio buttons have no effect on audio (but they graphically show changing level).

I can fix that with pavucontrol, but I’d expect sound to work always the way I left it.

Sometimes it works to kill and restart my kde session with 2 x Ctrl-Alt-Backspace.

I tried editing analog-output.conf as described in the fizcarraldo blog. Did not help.

Sometimes kde mixer shows a dummy audio device, sometimes hdmi and internal audio.

I have no idea where to go on debugging this mess. Too much noise on the internet. dmesg | grep audio shows no problems.

What is the place where the sound system writes its log?

What is the proper way to save and restore sound settings?

How does opensuse setup the sound system? Where can I tweak this? Documents I found are too much on the surface of things or dont seem to match.

I have always found that Yast is the place to make the settings. If you show more then one sound device try changing the order

Thanks. I used yast to make the basic setup. But settings are not permanent in the way I described above.

I’ve read there are a few layers saving / restoring the mixer state, alsactl invoked via udev, Pulse audio, and kmix.

A possible fix would be to clean up the config. Goto run level 3 once, login as root, kill all pending PA processes. Then adjust via “alsamixer -c0”, and run “alsactl store”. This resets the mixer restored via alsactl.

For Pulseaudio, remove ~/.pulse ~/.config/pulse directories if they exist (they may not).

If the above does not work try using “pavucontrol” application again.