Sound problem

Hi i have a hp tx 2001 au tablet pc.
And i have installed open suse 11.0, my question is …

when i plug in my headphone (earpiece) the sound is not directed to the headphones, it still plays through the inbuilt laptop speakers.

Please help me!

means headphones, external speakers not working at all!

That may, or may not, be solveable. To solve it (if it is solveable) we need a lot more information on your PC software and hardware audio configuration.

Please open a konsole / gnome-terminal and copy and paste the following diagnostic script command into that (with your PC connected to the internet):

wget && su -c 'bash ./tsalsa' 

when prompted for a password, enter your root password. Please try to accurately enter the number of jacks/plugs when asked (for example, my PC has 3 i/o jacks/plugs for audio on the back). That diagnostic script will give you a URL when it is complete. Please post that URL here.

Then, please copy and paste the following one line at a time into a gnome-terminal / konsole and paste here the output:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

… with the information from that, its possible a recommendation can be given to solve your problem.

i will be adding the logs within 1 day.
Thanks i am trying your solution.

OK, great! Looking forward to your post.

Its possible we can solve this problem by an appropriate edit to your /etc/modprobe.d/sound file. But the information I asked for will confirm if that is the correct approach.

Note in this thread below, a Ubuntu user solved this problem on an HP TX 2000 (close to the 2001) with a change to the Ubuntu alsa-base file. In openSUSE we use the “sound” file instead of the “alsa-base” file, but with Linux being Linux, the same principles apply:
HOWTO: HP Pavilion tx2000 series running Ubuntu 8.04

tsalsa.txt - (beta)

linux-7ggr:~ # rpm -qa | grep alsa
linux-7ggr:~ # rpm -qa | grep pulse
linux-7ggr:~ # rpm -q libasound2
linux-7ggr:~ # uname -a
Linux linux-7ggr #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux
linux-7ggr:~ # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

wRyD.wz5BfPca1c7:MCP51 High Definition Audio

alias snd-card-0 snd-hda-intel

Thanks. I see a 64-bit openSUSE-11.0 with the original (not updated) kernel. Your audio codec on your HP TX 2001 is an ALC-861VD.

From the ALSA-Configuration.txt file for 1.0.16 of alsa I note this:

	  3stack	3-jack
	  3stack-dig	3-jack with SPDIF OUT
	  6stack-dig	6-jack with SPDIF OUT
	  3stack-660	3-jack (for ALC660VD)
	  3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
	  lenovo	Lenovo 3000 C200
	  dallas	Dallas laptops
	  hp		HP TX1000
	  auto		auto-config reading BIOS (default) 

Also, as I noted earlier, on this thread:
HOWTO: HP Pavilion tx2000 series running Ubuntu 8.04
for the HP TX2000 series, a Ubuntu user noted using the option model=hp worked for them.

I also recall reading a post by a user noting a “glitch” with openSUSE-11 is that the ‘auto-config reading BIOS’ does not always work as well as it did in 10.3 for alsa. Hence it often helps to manually apply the appropriate code in the boot file for sound.

So that all supports trying the following … Please update your /etc/modprobe.d/sound file, adding an extra line, such that it is now the following:

options snd slots=snd-hda-intel
options snd-hda-intel model=hp
# wRyD.wz5BfPca1c7:MCP51 High Definition Audio
alias snd-card-0 snd-hda-intel

Please save that file, then restart your alsa by typing the following in a konsole/gnome-terminal with root permissions:
rcalsasound restart
and then test your sound. Do you have the needed feature?

There is a chance the above will not work, and you may have to update your alsa. I say that as I note this on the alsa web site searching for the ALC861:
Search results for ALC861 - AlsaProject

If that update is needed there are rpms that you can install. There is a wiki here explaining the 6 zypper commands to send How to update Alsa on openSUSE , but I can walk you through those commands when and if the time comes.

Good luck!

hou la!!!
well thanks a lot, it worked.
changing the model to hp did the job for me!

I have a HP tx2032la (the latinamerican model) and it works for me too. Thank you both!

That very simple solution worked for me as well. Thanks!!!

Using opensuse 11.0 in HP Pavilion tx2010eo (european/scandnavian model).

Exactly the same solution for me too! Thanks!

Thank you, it work for me but using yast.
Edit->MCP51 HDA->model=hp