sound problem in open suse..

I have just installed opensuse 10.3 on my dell inspiron 1420 with intel core-2-duo processor…the problem is that no sound is coming at all…even system sounds cannot be heard although the sound card is running normally in win-xp…I tried installing alsafirmware with no result…please do help…:(…my sound card is Intel HD audio…sigmatel…

Are you aware of the multimedia forum inside these openSUSE forums??
And did you read the sticky there?

Welcome to our forum, and thankyou for participating.

Try working your way through the openSUSE audio troubleshooting guide:
openSUSE AudioTroubleshooting -

If that does not work for you, please provide us more information (for example, which openSUSE version are you using?). … Anyway, please paste here:
a. the output URL(s) generated by running the two diagnostic scripts in the audio troubleshooting guide: Scripts_to_run_to_obtain_detailed_information

b. the output of typing the following commands in a terminal/xterm/konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

You know this maybe too obvious for some, but it took me a while to figure out that open Suse 11 has two volume controls. One for Pulse audio and the normal one. My audio volume was really low even though the pulse audio control was maxed out, however the other one was not. You might want to check both.
Both are listed on the more applications tab. One is called Pulse Volume control and the other probably is Volume Control (under the system tag).

I have same problem.

My logout of diagnostic script general pastebin - anton - post number 1054934

$ rpm -qa | grep alsa

$ rpm -qa | grep pulse

$ rpm -q libasound2

$ uname -a
Linux jonny #1 SMP 2008-06-07 01:55:22 +0200 i686 athlon i386 GNU/Linux

$ cat /etc/modprobe.d/sound
options snd slots=snd-intel8x0

8otl.jtzrzmcShZC:CK804 AC’97 Audio Controller

alias snd-card-0 snd-intel8x0

$ speaker-test -c2 -Ddefault -twav

speaker-test 1.0.16

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 1048576
Period size range from 64 to 262144
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
*** PULSEAUDIO: Unable to create stream.
Unable to set hw params for playback: Error Input/output
Setting of hwparams failed: Error Input/output

$ pulseaudio -D
W: core-util.c: setpriority():Permission denied
E: main.c: daemon startup failed.

Help me, please. I spend two days in battle with that problem and no results.

Any one can’t help me?

the audio trouble shooting guide was of no use…i am using opensuse version 10.3
the output to the commands is as follows…
saurav:~ # rpm -qa | grep alsa
saurav:~ # rpm -qa | grep pulse
saurav:~ # rpm -q libasound2
saurav:~ # uname -a
Linux saurav #1 SMP 2007/09/21 22:29:00 UTC x86_64 x86_64 x86_64 GNU/Linux
saurav:~ # cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
saurav:~ #

please help me out,

@maharaj123_456, try it with this as /etc/modprobe.d/sound :

options snd slots=snd-hda-intel

u1Nb.Tpl9SMkJSdD:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

aurav:~ # zypper install alsa alsa-driver-kmp-default alsa-utils alsa-tools alsa-firmware libasound2

  • Reading repository ‘openSUSE-10.3-DVD 10.3’ cache
  • Reading installed packages [100%]

skipping package ‘alsa’ (already installed)
package ‘alsa-driver-kmp-default’ not found
skipping package ‘alsa-utils’ (already installed)
skipping package ‘alsa-tools’ (already installed)
skipping package ‘alsa-firmware’ (already installed)
skipping package ‘libasound2’ (already installed)
Nothing to do.

there might be a bug as well in the opensuse 10.3 i am using…when i open YAST-hardware-sounds. …i see that
82801H(ICH8 Family) HD Audio Controller is not configured…whenever i try to configure it by clicking on edit, it gives an error in configuring the sound card driver and the desktop menubar below vanishes everytime i do this…please help…

For me this looks like a problem with your install DVD:

package ‘alsa-driver-kmp-default’ not found

Have you tried using the online Repositorys to install this package?
AFAIK, it contains the main Kernelmodules for alsa, so you need it to get sound working.

I even tried to close the sound drive and again open it…but it gave the following…
rcalsasound restart
Shutting down sound driver done
Starting sound driver: hda-intelWARNING: Error inserting snd (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_hda_intel (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)

I just got back from a business trip.

You could try switching OFF the external amp in your mixer. Why is that ON?

Also, are you using digitial audio? Because if you are, I note that is switched OFF.

Finally, if tuning your mixer settings does not work, I recommend you remove all those pulse audio applications. Then reboot your PC and try again.

Can you please try that again and after that post the output of the command “dmesg” here?

Thats because the above is wrong. You must have found the audio troubleshooting guide too difficult to follow.

A couple of things, … I asked for the output of the diagnostic scripts. You did not provide that. Why? Do you have difficulty there?

Again, please go to the URL below, and run the audio diagnostic scripts, and post here the URL they provide.
SDB:AudioTroubleshooting - openSUSE

If you can’t make “heads or tails” how to run those scripts (despite my best efforts to explain) then maybe try this … copy and paste the following into a terminal/xterm/konsole and press < enter > :

wget -O && bash 

Now, reference the zypper command! Thats wrong! Thats not what the audio troubleshoot guide says to do. The guide states to send 3 commands, not just one command. And the commands MUST be sent in the sequence provided. Please read that section of the guide again. … specifically, this URL here: … Alsa-update - openSUSE … If you have a problem there, then please post. Thanks!

i did send the first and the third zypper commands…but it gave an error and to check whether the url is accessible or not…

Did your PC have internet access when you tried those commands? Also, ensure you copy and paste them, as opposed to re-type.

And note the 1st command is:

 zypper ar multimedia 

don’t forget to include the multimedia, and there is a space between “10.3/” and “multimedia”.

Thanks, this helped.

What i miss if deleted pulseaudio?

I take it then, you have sound? If so, congratulations!

You potential miss an irritating lag between video and audio caused by the additional layer of pulse audio. :rolleyes:

… In truth, pulse audio is supposed to add extra features and better audio control. For example, it is supposed to add the capability to control the volume independent between two applications running at the same time, and both accessing/playing sound at the same time. … I have not tested nor trialled that capability.

[SOLVED] OpenSUSE 10.3 Sound problem <SOLVED> - Linux Forums](

May be this help.:slight_smile: