Sound not working at all

Hello,

A few months ago I bought an Asus Zenbook 14 OLED and ever since then it doesn’t have sound at all. I’m currently on Tumbleweed and have tried:

  • Deleting the sound card configuration from YaST then re-adding and configuring it.
  • Following this wiki page
  • Switching between PulseAudio and PipeWire
  • Installing the sof-firmware package
  • Adding
options snd-hda-intel model=asus-zenbook

in

/etc/modprobe.d/50-sound.conf

as suggested in this thread.

  • Checking if audio is muted in Alsamixer (it’s not)
  • Trying different Linux distros (Ubuntu, Fedora, Manjaro).

Here’s some system information:

 
sudo lspci | grep -i audio
0000:00:1f.3 Multimedia **audio** controller: Intel Corporation Alder Lake PCH-P High Definition **Audio** Controller (rev 01)


uname -r
5.19.10-1-default

This bug has also been confirmed in Launchpad.

I tried booting windows from an external SSD and sounds works just fine there, however it never works on any Linux distro. I’ve tried just about everything and can’t seem to get it working.
Any help will be appreciated since having a mute laptop is no fun :(.

Let me know if I should provide any additional information and thanks in advance!

In this instance it would probably be better to file a bug report at: https://bugzilla.opensuse.org/enter_bug.cgi?product=openSUSE%20Tumbleweed against the “Sound” component, same login credentials as used for the forum.

Welcome to the openSUSE forums, and it makes a pleasant change to see a well presented summary of a problem.

Thanks, I’ll make sure to file a bug report. Meanwhile, if anybody has a potential solution to this problem I’d love to hear it :).

Hi and welcome to the Forum :slight_smile:
The default for Tumbleweed is pipewire so any pulseaudio fixes may cause issues. You should not need to use YaST either for configuration, again may cause issues…

What does the output from the following show;


inxi -A

wpctl status

Also see https://en.opensuse.org/openSUSE:Pipewire

Thanks and here’s the output:

inxi -A:

**Audio:**
  **Device-1:** Intel Alder Lake PCH-P High Definition Audio 
    **driver:** sof-audio-pci-intel-tgl 
  **Sound Server-1:** ALSA **v:** k5.19.10-1-default **running:** yes 
  **Sound Server-2:** PipeWire **v:** 0.3.58 **running:** yes

wpctl status:

PipeWire 'pipewire-0' [0.3.58, user@zenbook, cookie:3048338008] 
 └─ Clients: 
        31. xdg-desktop-portal                  [0.3.58, user@zenbook, pid:2610] 
        32. WirePlumber                         [0.3.58, user@zenbook, pid:2704] 
        33. WirePlumber [export]                [0.3.58, user@zenbook, pid:2704] 
        70. Plasma PA                           [0.3.58, user@zenbook, pid:2916] 
        72. libcanberra                         [0.3.58, user@zenbook, pid:2916] 
        73. QPulse                              [0.3.58, user@zenbook, pid:2914] 
        81. Firefox                             [0.3.58, user@zenbook, pid:13772] 
        82. Chromium input                      [0.3.58, user@zenbook, pid:134] 
        83. Chromium input                      [0.3.58, user@zenbook, pid:144] 
        84. Firefox                             [0.3.58, user@zenbook, pid:13772] 
        89. WEBRTC VoiceEngine                  [0.3.58, user@zenbook, pid:102] 
        90. wpctl                               [0.3.58, user@zenbook, pid:16630] 
        91. WEBRTC VoiceEngine                  [0.3.58, user@zenbook, pid:101] 

Audio 
 ├─ Devices: 
 │      39. Alder Lake PCH-P High Definition Audio Controller [alsa] 
 │   
 ├─ Sinks: 
 │      44. Alder Lake PCH-P High Definition Audio Controller HDMI / DisplayPort 3 Output [vol: 1.00] 
 │      45. Alder Lake PCH-P High Definition Audio Controller HDMI / DisplayPort 2 Output [vol: 1.00] 
 │      46. Alder Lake PCH-P High Definition Audio Controller HDMI / DisplayPort 1 Output [vol: 1.00] 
 │  *   47. Alder Lake PCH-P High Definition Audio Controller Speaker + Headphones [vol: 0.85] 
 │   
 ├─ Sink endpoints: 
 │   
 ├─ Sources: 
 │  *   48. Alder Lake PCH-P High Definition Audio Controller Headphones Stereo Microphone [vol: 0.74] 
 │      49. Alder Lake PCH-P High Definition Audio Controller Digital Microphone [vol: 0.74] 
 │   
 ├─ Source endpoints: 
 │   
 └─ Streams: 

Video 
 ├─ Devices: 
 │      40. USB2.0 HD UVC WebCam                [v4l2] 
 │      41. USB2.0 HD UVC WebCam                [v4l2] 
 │   
 ├─ Sinks: 
 │   
 ├─ Sink endpoints: 
 │   
 ├─ Sources: 
 │  *   42. USB2.0 HD UVC WebCam (V4L2)         
 │   
 ├─ Source endpoints: 
 │   
 └─ Streams: 

Settings 
 └─ Default Configured Node Names: 
         1. Audio/Source  alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__source



Does anyone have insight on this? Sound still doesn’t work many months later…

I also have this problem (although my sound card is much older - intel skylake)… I have quite similar output as yours, though. My laptop is Asus Zenbook UX303U.

I had sound when using Arch, then an update ruined it, then I was able to make it work again - but I’m not sure how… it stopped working after a few hours again, and I wasn’t able to reproduce that success again… Couldn’t make OpenSuse have sound, Fedora and pop_os! too…

Did you ever follow up with a bug report?

Yes, I created a bug report and the problem has been “fixed” in updates. The problem is that in order for this to be effective, Asus need to release an update to their BIOS to include the ACPI parameters/arguments.

I contacted their support but they’re not willing to do so and saying they only support windows.

Is it confirmed you have the ALC294 bug?

Link to report for other readers of this thread:
https://bugzilla.opensuse.org/show_bug.cgi?id=1203922

The symptoms are the same, although my sound card is older… It’s

Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d70] (rev 21)
	Subsystem: ASUSTeK Computer Inc. Device [1043:1b1d]

Seems to be a recurring theme in Asus laptops… My headphones and mic are working, but no speakers…

Certainly not good at all. I really need the sound of the speakers to be working under Linux.

I hope there is a solution that doesn’t involve Asus having to update the bios for this to work.