Sound issue KDE 4.2

11.1, KDE 4.2

Fresh install, sometimes I have sound other times i do not. I have to restart usually to get sound, but fresh boots are often soundless. AT times i have system (startup) sounds & not Media player & browser sounds… I am really stumped. I dont know where to begin.

You should begin with the troubleshooter:
SDB:AudioTroubleshooting - openSUSE

Actually, the audio troubleshooting guide SDB:AudioTroubleshooting - openSUSE is for basic sound problems, and not intended to help users who change their desktop from the basic version that comes with openSUSE (ie there could be desktop specific aspects associated with KDE 4.2 causing your problems), although there are tidbits in the troubleshooting guide that are useful to learn. I never update my desktop from the basic version that comes with openSUSE for reasons such as sound can then become flakey (I have other reasons as well).

I suspect you are referring to the start up sound (when your desktop starts). … that is definitely NOT covered by the troubleshooting guide …

Do you get sound from a basic speaker test:
speaker-test -c2 -l5 -twav

Have you updated your multimedia ? (as the basic multimedia that comes with openSUSE is crippled for proprietary codecs) . If you have not done anything to sort your multimedia codecs, then take a read of this post: openSUSE Forums - View Single Post - sorting multimedia after an install

Not the startup sounds…When it starts, I either hear it, or I dont. If I hear it, sound is fine. If I do not hear it, I get no sound until I reboot. The test worked fine.

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
0 - Front Left
1 - Front Right
Time per period = 2.857459
0 - Front Left
1 - Front Right
Time per period = 3.007955
0 - Front Left
1 - Front Right
Time per period = 3.007992
0 - Front Left
1 - Front Right
Time per period = 3.007868
0 - Front Left
1 - Front Right
Time per period = 3.007895

What I was trying to understand was, when you do not hear the startup sound, does the speaker-test still work? If it does, then you only have a start-up sound problem, and not an overall sound problem.

Even IF the speaker test does not work for you (after the start up sound not working), I suspect it unlikely a reboot it necessary. Simply restart the alsa sound driver manually.

Usually that can be done by:
su -c ‘rcalsasound restart’
and enter root password when prompted, restart your mixer, and then test your sound with the speaker test.

BUT do NOT restart alsa sound driver, and do NO reboot, unless you confirm with the speaker test that your sound is no longer working.

Okay, test passed, I had startup sound. But mp3 will not play & youtube/pandora have no sound. I ran

su -c ‘rcalsasound restart’

Still, I have no sound.

Did the speaker-test work? Not being able to play mp3 could be a codec issue as could not playing youtube. Running ‘rcalsasound restart’ will NOT help if this is a codec issue. Do mp3 and youtube ever work for you with KDE 4.2. ?

This is the advice I normally give users who have KDE-4.1.3. … not sure if it will help you with KDE-4.2, but its possible parts of it might: openSUSE Forums - View Single Post - set up your multimedia

Mp3 works when i reboot it. I can use this:

su -c ‘rcalsasound restart’

and get results about 70% of the time. If its successful, I can play movie in VLC, play a musicd CD, or youtube…

Is this a bug that will possibly be fixed? Or will I have to restart audio from here on out?

Its likely there is a bug somewhere, but the bug may be in application (such as firefox) and not in openSUSE. Its possible an application that was playing sound, refuses to let go the sound device, and your audio configuration is not set up to share audio. What you could do, is check to see what application has seized your sound device, and not allowing you access when your sound does not work.

When your sound is functioning (possibly immediately after a good boot with functional sound), I recommend you run in a gnome-terminal or konsole:lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*to get a flavour as to what a good setup looks like (the above will tell you what devices are using your sound). Record that output.

Then with firefox or vlc playing asound successfully, again repeat that line to see what it looks like then:lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*Record that output.

Then when your problem reappears with no sound, re-run it a 3rd time. lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

and compare the earlier outputs with this current output.