**** sound from Realtek ALC269VB - Sound Enhancement on Linux

I know that this question has been asked many a times. Is there a way to improve the quality of sound on Linux.

I’m an audiophile and I don’t want to boot into Windoze everytime I want to listen to music. And I’m using a laptop (sytem #1) so won’t be able to add another soundcard like soundblaster and I use headphones (AKG K420) to listen the music.

From https://en.opensuse.org/SDB:Intel-HDA_sound_problems

akash@akash:~> head -n 1 /proc/asound/card0/codec#0
Codec: Realtek ALC269VB

I added


to /etc/modprobe.d/50-sound.conf

Still sound ****.

Then I installed pulseaudio-equalizer sound still still ****

The sound is totally flat. On windoze I’ve Dolby Home Theater v4 which obviosly won’t be available on linux. The realtek driver has purpose of popping notification “You Plugged in A Headphone” everytime I plugin a headphone and for choosing whether you want studio type sound output (with high sampling rate) or CD Audio type sound output (low samling rate). Hence I expect that installing the realtek hd audio driver available from realtek site will not help.

Is there any other method to improve sound. Are there any opensource plugins available.



output can be found on http://paste.opensuse.org/5c01d12b (’/usr/sbin/alsa-info.sh > upload output’ didnot display a website)

I can’t really help with the actual problem but maybe take a look at OSS.

No, not the old OSS, but OSS v4 which is alive and kicking. http://www.opensound.com/ I’m not really sure about how easy it is to setup in OpenSUSE but I did it in Kubuntu/Xubuntu 10.04 & 12.04 and it was great, and not very hard to install.

Nowadays I don’t listen music from the computer so I don’t bother.

Now these are some interesting read https://lizards.opensuse.org/2015/01/16/linux-audio-library-smackdown-part1-portaudio/ https://lizards.opensuse.org/2015/01/27/linux-audio-library-smackdown-part2-pulseaudio/

Might not be relevant but, im using an external usb DAC from LogiLink.
Pretty cheap and does the trick, makes mp3s sound good…flac sounds awesome.

Just tought you should know…one audioholic to another :slight_smile:



Yes I agree, the best way to get a better sound is to use a USB DAC. The driver can only do so much, when hardware is what it is. I just didn’t suggest it earlier because you have to spend money to do that :slight_smile:

Also, the better sound OP describes having in Windows, is it due to a better driver or an effect added to the sound?

Better sound is of course subjective, but myself I wouldn’t say additional effects sounding good, I also turn them off whenever possible.

I note from /usr/src/linux-3.11.10-25/Documentation/sound/alsa/ inside HD-Audio-Models.txt

  laptop-amic        Laptops with analog-mic input
  laptop-dmic        Laptops with digital-mic input
  alc269-dmic        Enable ALC269(VA) digital mic workaround
  alc271-dmic        Enable ALC271X digital mic workaround
  inv-dmic        Inverted internal mic workaround
  lenovo-dock       Enables docking station I/O for some Lenovos
  dell-headset-multi    Headset jack, which can also be used as mic-in
  dell-headset-dock    Headset jack (without mic-in), and also dock I/O

Is laptop-dmic the only option model you tried ? Note one should only try one at a time.

Your mic boost is at 0. That makes it VERY difficult to record audio. Also your headphones are muted.

I’m surprised you get any sound from your headphones in that state.


**Simple mixer control 'Headphone',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Front Left: Playback 0 **[0%]** -65.25dB] **[off]**
  Front Right: Playback 0 **[0%]** -65.25dB] **[off]**
**Simple mixer control 'Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 **0%]** [0.00dB]
  Front Right: 0 **[0%]** [0.00dB]

I also see iec958 is off, but since that is for digital audio I assume it not relevant.

Since you mention both headphones and mic, I confess puzzlement as to what was the initial state before you added the model option, and whether you are trying to improve headphone sound or speaker sound on the laptop.

Apologies if you stated the above and I missed it. I just came back from a business trip with very long hours (and little sleep) and am currently suffering from a head cold.

Good luck and best wishes in improving your audio.

At that particular time I wasn’t listening to music.

So, I again generated alsa-info, this time listening to music through headphones http://pastebin.ca/2915411
I came to know about pulse-daemon.conf and changed following settings and rebooted the system. Rest of the settings are set to default

resample-method = src-sinc-best-quality
default-sample-format = float32le

Still no significant improvement in sound.

  1. What other changes could I have made in the pulse-daemon.conf. Did I do anything wrong.
  2. Is their a similar conf for alsa

OK got some interesting link
They describe how to configure pulse-daemon.conf for audiophiles

Thanks. For the future, if giving someone else configuration information, it really helps if one has the appropriate hardware connected and in use.

I note:

**Simple mixer control 'Master',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 65 [75%] -16.50dB] [on]
**Simple mixer control 'Headphone',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
**Simple mixer control 'Speaker',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Front Left: Playback 0 [0%] -65.25dB] [on]
  Front Right: Playback 0 [0%] -65.25dB] [on]
**Simple mixer control 'PCM',0**
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]

In the above speaker is at 0%. I assume that is because you are not using the speakers. Master volume is at 75% - good - its not maxed out. PCM and headphone at 100% - not so good. That could cause some distortion. Still, i assume even at 80% you have the identical problem of poor quality sound on your headset.

Please note your description of the sound come out on the forum as **** . I assume that is because you used a word censored by the forum software. Unfortunately, that means I have no idea as to what sort of noise you are hearing and that makes it very difficult to give you any suggestions. I fully appreciate your frustration and feel sorry for your difficulty - but we are volunteers on this forum and not paid employees. We did not build the hardware, nor write the drivers. I supect the manufacturer of the headphones also provides no GNU/Linux support. If you can be more descriptive of the sound in a manner that uses polite words (that the forum software does not censor) it may be easier for anyone trying to give a suggestion.

As I do not own your hardware, nor do I have your hardware to play with, I can’t answer those questions.

Its possible it could be an inapporpriate frequency. Not so likely, but possible. Note thou if you start messing with that, you could affect the sound out of your laptop’s speakers.

**** means extremly bad :expressionless:
Ok the problem with the sound.
The sound from the headphones is flat and shallow. There is no depth in it. The bandwidth of sound seems to less as compared to that while on windoze

Even if I turn off my dolby home theater effect on windoze, it is still better than on linux.

I’m no sound engineer, how do I explain what type of sound am I getting.
Next time I’m buying a laptop I will see, if it has got sound enhancement it better be available in linux and that laptop doesnot has realtek codec.

Some people say that realtek intel hda codec is bad / noisy - I don’t think so. If it was so, why is it so good on windoze.
my audio codec alc269vb

I’m just wondering what you are trying to listen? If you are listening MP3 with 128 kb it will sound bad in any audio chip around the world >:). Stereo wav 16 bit sounds bad also. Dolby surround that you are using in Windows is making up with you audio. Downsampiling from wery high quality audio to something like 44100 KHz will sound bad or **** like you like to say.
First you have to determine applications you are using and audio sources that you are using then will see if there anything that could be done… you should read something like http://r3dux.org/tag/audiophile/ to see which output you are having. Using Pulseaudio or not is not going to solve your problems… Flat sound is more habit of audio that is highly compressed with low bitrate.
If you want to have more HIFI output you should use 96 KHz or 192 KHz modes as your sound device allows it even 48 KHz will sound better that 44.1 KHZ (and now you can nuke me). Also used application should make something like S16 to FLOAT32 to S16 conversions…

I did following changes in /etc/pulse/daemon.conf

daemonize = yes
resample-method = src-sinc-best-quality
default-sample-format = s24le
default-sample-rate = 96000

Other settings are left to be default

ALC269VB has support for 24bit so I choose s24le. I’m still confused about le/re/be
After making these changes the sound is more acceptable. I’ve not configured alsa yet. So, next I’m going to do that.

But how do I verify the change in sound output?
On windoze I updated the realtek drivers and dolby software and the sound output is not same anymore. It has started making out with sound. Literally :wink:
So I’ve stopped complaining about absence of Dolby Enhancement on Linux.