sound crackling and popping

i get crackling and popping in my sound. i cant figure out how to get rid of the crackling. i dont have a sound card. i didnt need a card im using my i7 CPU and p8z77 v deluxe motherboard for sound

in my file 50-sound.conf

options snd slots=snd-hda-intel

u1Nb.ol2_+rEHIw7:Intel Corporation

alias snd-card-0 snd-hda-intelfile

su@linux-4902:~> head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC898

==> /proc/asound/card0/codec#3 <==
Codec: Intel PantherPoint HDMI

[CODEsu@linux-4902:~> speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.26

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 262144
Period size range from 32 to 131072
Using max buffer size 262144
Periods = 4
was set period_size = 65536
was set buffer_size = 262144
0 - Front Left
1 - Front Right
Time per period = 5.480887
0 - Front Left
1 - Front Right
Time per period = 5.466056
0 - Front Left
1 - Front Right
Time per period = 5.465691
0 - Front Left
1 - Front Right
Time per period = 5.466483
0 - Front Left
1 - Front Right
Time per period = 5.465817]

su@linux-4902:~> cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k3.7.10-1.4-desktop.

su@linux-4902:~> cat /proc/asound/modules
0 snd_hda_intel

su@linux-4902:~> cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7c30000 irq 80

So I have never thought much of Realtek Sound chipsets and normally buy and install a Creative sound card if I have that option (not a Laptop) else you could look at installing their driver.

They do show to have Linux support: Realtek

Other things to look at include: PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums


For even more info on using pavucontrol, have a look at this blog by oldcpu: Pulseaudio Basics for openSUSE with pavucontrol


For Sound Testing and such: S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.11 - Blogs - openSUSE Forums


I have a bash script for testing sound you can find here: S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.15 - Blogs - openSUSE Forums


If you have issues in playing video in openSUSE, then for Multimedia Setup in openSUSE 12.3, please have a look here: openSUSE 12.3 Multi-media and Restricted Format Installation Guide

Thank You,

I downloaded the realtek drivers and looked at the install directions but no luck. How do i install them? i downloaded the drivers extracted the folder to my desktop and opened a terminal in that folder and thats it, how do i install them?

Installing the realtek drivers is a drastic measure, and very difficult if not impossible to undue once done. Hence IMHO this should be only a last resort. Did you try other measures wrt pulse audio? For example the newer implementation of PulseAudio sound server uses a timer-based audio scheduling instead of the traditional interrupt-driven approach.

Timer-based scheduling may expose issues in some ALSA drivers. On the other hand, other drivers might be glitchy without it on, so check to see what works on your system.

To turn timer-based scheduling off add tsched=0 in /etc/pulse/

load-module module-udev-detect tsched=0

Then restart the PulseAudio server:

pulseaudio -k
pulseaudio --start

(or resart if those pulse audio commands do not restart the pulseaudio server).

Do the reverse to enable timer-based scheduling, if not already enabled by default.

And test your audio.

Also, try not to have PCM/Master volume at maximum, as that can cause sound crackling and popping.

Or you could try to turn off PulseAudio and see if that helps. (or turn it on if it already is turned off)

Enter YaST->Hardware->Sound, click on “Other” in the bottom-right and select “PulseAudio Configuration”.

i typed in the code you suggested and it didnt work, i got these results

linux-r94p:/home/suse1 # load-module module-udev-detect tsched=0
If 'load-module' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf load-module
linux-r94p:/home/suse1 #  cnf load-module
load-module: command not found                            
linux-r94p:/home/suse1 # 

turning down thePCM/Master didnt stop the crackling popping.
also i tired turning off pulseaudio and that didnt work either.

I don’t think you understood my post. I quote:

“add tsched=0 in /etc/pulse/” does not mean send it in at terminal as a command. Please note that /etc/pulse/ is a file to edit.

I don’t know how to send it in a terminal. Possibly something like:

pactl load-module module-udev-detect tsched=0

and do NOT restart pulse, but thats pure speculation on my part. Rather just follow my quoted post instruction.

where in the file do I add add tsched=0 at the very top beginning or at the end of all the writing?

Its easier to see if you quote the salient points in my post (I highlighted in red above to make more clear).

Open /etc/pulse/ Search for a line with “load-module module-udev-detect” in the line. Add “tsched=0” at the end of that line.

i get document can not be saved. how do i overwrite the file and add tsched=0

This is a system configuration file that needs to be changed. The GNU/Linux policy is that system configuration files typically require the user have root permissions when changing.

If you advise as to which desktop you are using (KDE, or Gnome or ? ) I can recommend the command to obtain root permissions with an appropriate editor.

The capability to change configuration files (via root permissions) is pretty fundamental to GNU/Linux maintenance, so this is definitely something you should learn IMHO.

im using kde

Then you can use the editor ‘kwrite’. Launch it with root permissions from a terminal/konsole with the command:

kdesu kwrite /etc/pulse/

enter root password when prompted for a password, …

make your changes (carefully), save, and close the kwrite program.

added tsched=0 to the line and my sound is still choppy

I have a EVGA X79 Classified MB using an intel audio chip. I’ve been getting the very annoying clipping. I don’t notice it until I watch a video. I just did the change listed below and it has made a HUGE difference. Thank you!!

  •  		 			lol! 		

I tried that. I added tsched=0 in /etc/pulse/

when I tried the code below nothing happened

pulseaudio -k
pulseaudio --start

Well I’m assuming you used vi or similar text editor to make the changes permanent in the file. Did you reboot just to be sure? It absolutely made a huge difference for me. Mine used to crackle/drop out about every second… now it is rock solid.

I did reboot after I changed the file.

when I say nothing happen after I typed in code

pulseaudio -k
pulseaudio --start

my server doesnt restart, I got some error message or in terminal it said failed

Hmm… I wonder if your issue is slightly different. Did you have this problem with an earlier version of suse? Is it a straight stock install?

Maybe we need to figure out what kind of hardware you have, and then if this problem started with a new version of Suse etc. For me, it was apparently the timing issue with the interupts etc. I’m watching movie glitch free.

I will try to describe what I was experiencing to see if it is the same thing. I never noticed it for normal stuff… I can’t say I ever noticed it while watching TV on TVTime. But when watching a movie on local disk or server disc, I would get a sound clip. It would drop just a tiny snippet of sound. It kind of sounds like a pop, or click, but I’m pretty sure it is actually losing just a couple of milliseconds of sound. Does this sound like your issue?