Sony Vaio Z12 owners thread

Hi all,
I invite here everyone who owns Vaio Z12 laptops to share there experience and talk about successes and or problems whey encountered with this articular laptop running our favorite distro.

Wel i start i guess. I have received my Vaio just about 3 days ago. Very nice looking machine i must say, looks way better in real life then on countless review videos or pictures i saw it beforehand.
Very light. thin, mine came with standard battery so it slides to my bag with ease.

I was very undecided at first, to be honest, about which laptop to buy. Choices i had were:
Lenovo x201s (my favorite actually) with following specs:
i7 640LM
8G memory
128 SSD
integrated Intel graphics
and gorgeous 12.1" mate screen with 1440x900

Other option was Sony Vaio Z12, which i have chosen eventually. With following specs:
i7 620M
also 8G memory
and also 128G SSD
and insane 13.1" fullHD (yes! 1920x1080) mate screen

Why Z12? Well, after a lot of thinking i got to the point were i sought that it would be nice to have on a laptop a stereo speakers (even if they are crappy laptop speakers), webcam (even if i never use it) and that insane high res screen on which i wouldn’t be able to read anything cause everything would be so small.

I have tried several dstros on this laptop:

  • Fedora
    Neither 13 nore 14alpha where able to even boot on this thing. Yes, weird, i know…Eventually i have succeeded installing F13 on it but never could get native resolution.

  • SUSE 11.3 (currently running)
    Got installed and booted straight from first time with native resolution!!

  • Ubuntu 10.10.
    Friend asked me if it was possible to run ubuntu on it. He was intended to buy same laptop. My findings where following: Ubuntu 10.10 live CD boots just fine. But after installation, which goes seamlessly, system won’t boot. And it doesn’t matter if i use intel raid0 or not (you can turn it off in raid menu just right after bios splash screen).

So far i can say this:

  • WiFi (as expected, intel wifi is fine under linux these days)
  • fullHD screen (which is awesome and surprisingly readable by the way)
  • sound (loud enough for youtube and such, definitely not for music lovers, get yourself a dissent headphones)
  • Desktop effects (intel graphics driven) not as snappy as i have expected to be honest.
    And not working:
  • Switchable graphics not working. That leads to useless so highly anticipated HDMI port
  • touchpad not working, which makes this super light and portable laptop almost pointless.
  • suspend - future that i very actively use (used to use :wink: ) not working, kind of crippling my mobility experience here.

Yet to discover if works:

  • external monitor (1920x1280) in various setups
  • WWAN (3G connection)

Possible upgrades:

  • 500G hybrid HDD insted of CDROM

I found out that raid0 setup Sony has advertised so much is actually software raid. And by the way now i kind of think that raid0 on SSDs kind of overrated.
Keyboard is not as fine as on Thinkpads by far. Keys are small and far apart (to my feeling that is).
So why i bought Vaio? I don’t know, maybe because i am a specs junky? rotfl!

Update on the touchpad status. I got it work by loading (ot should i say unloading) i8042 plug and play module during the boot by just adding to kernel line flag -i8042.nopnp. Although, i have to admit i do not have any idea what i8042 module does. I did unload some plug and play module but which? And how come that touch pad started working after that? Was there any conflict in modules?
Please someone enlighten me, it’s killing me!!! What i just do that made this touchpad work?

I have the same computer and I followed your suggestions to install OpenSuse. I’m at a very beginner level, so please, can you explain me step by step how to add that line to the kernel in order to solve the touchpad problem??

Thank you very much!!


vi /boot/grub/menu.lst

Go to the line where kernel is defined and at the end of the line add i8042.nopnp.
It should look something like this:

##YaST - generic_mbr
gfxmenu (hd0,0)/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.3 - 2.6.34
    root (hd0,0)
    **kernel /vmlinuz-2.6.34******* splash=silent quiet showopts vga=0x31a i8042.nopnp**
    initrd /initrd-

Hmm my graphics are completely messed up. Did you modify anything before installing Opensuse 11.3?

HOW TO (beta): Sony Vaio S - vpcz122gx (and likely others) with nvidia

  1. Install as you normally would using the opensuse dvd. When the automatic setup detects your ssd configuration choose YES. This will setup your drives in a raid0 configuration. Later during the installation when asked to confirm the install be certain to ENABLE booting from mbr.

After you have installed the OS you will notice that your screen colors are horrible. This is where the setup process gets interesting.

  1. Physically move the video switch to STAMINA and your Reboot. When given the opportunity enter NOMODESET (in lowercase) in your boot options. This will allow you to work normally, but at a reduced resolution.

  2. Follow this link and complete the instructions under GRAPHIC SWITCH.

Linux on Vaio VPC-Z

WARNING! Patching your bios is risky and may turn your laptop into a fancy paper weight!
Do not attempt to patch your bios if any of the instructions from the above link report errors!

  1. Add the following repository to your repositories list and update your kernel to 2.6.36. At this point if you have done so already make sure you install the base development and kernel development packages from yast patterns. You may also compile your own kernel from

Index of /repositories/Kernel:/HEAD/openSUSE_11.3

  1. When you have completed the bios patch physically move the video switch to SPEED and reboot.

Now your screen should display its full resolution and it should be using the nouveau driver. The problem with this setup is that the screen will not return if it happens to sleep. It will remain black and blank until you force the laptop to reboot. In order to avoid this problem I opted to install the proprietary nvidia driver with a few tweaks (may not be necessary. Skip to 9 if you like the nouveau driver, however this method is not tested.).

  1. Begin the process of BLACKLISTING the nouveau driver with the following command.

sudo echo “blacklist nouveau” >> /etc/modprobe.d/50-blacklist.conf

In addition to blacklisting you must also edit in YAST > SYSTEM > /ETC/SYSCONFIG EDITOR > SYSTEM > KERNEL > NO_KMS_IN_INITRD and enter YES (lowercase) in the settings box.

Now, download the latest driver from if you have not done so already and note where it is saved.

  1. Reboot and when given the option enter NOMODESET again (the nouveau driver is a horrible never dying thing that just keeps coming back).

  2. After you return to your desktop open a terminal, and as root, enter init 3. Find and install the nvidia driver with sh NVIDIA*.run -q and once complete reboot.

  3. Again we run into the problem of the screen going black and unusable during sleep/resume/hibernate.

In order to fix this you must add a custom script to your /usr/lib/pm-utils/sleep.d/ folder. Create a text file as root called 01sony-vaio and save it within the sleep.d folder and copy and save the following code into it:

light up laptop screen for vaio VPCZ11Z9E

if x$DISPLAY = x ]; then
export DISPLAY=:0
export XAUTHORITY="/home/$user/.Xauthority"
/usr/bin/xrandr --output default --off
/usr/bin/xrandr --output default --auto
case “$1” in
thaw|resume) resume_lapscreen ;;
*) exit 0 ;;

As root you must chmod +x the file as well. This should allow your laptop to wake up from suspend.

  1. Next, you should begin tweaking your system, now that it is running smoothly. Edit, as root, /etc/fstab and enter the following options after ‘defaults’ for both your home and / partitions.


  1. … not yet ready. But you should now have a stable system with all the necessities. Be aware that screen brightness does not work at all right now. Also be wary of Kernel updates as they will botch your video and possibly other things.

Argh… forgot to mention that you need to add i8042.reset i8042.nomux i8042.nopnp i8042.noloop to your boot options, as root, in /boot/grub/menu.lst

Otherwise your touchpad and keyboard will not work properly. Kind of a big step to forget… sorry!

I’ve read, that it is possible to unlock bios on sony vaio z, and after that switch graphic cards. That’s great! My Z is old one: VGN-Z550N. Is there any way to unlock its BIOS?

Step 3 from my list above describes how to do it for a vpcz1. I don’t know how it works with older models, or where to get the patch files.

Thank you very much for such a fast reply!

I have successfully made it (new bios), but the result was the same and I installed my previous.
Can I tell a short story why I am looking for a solution?

It started with install of Win7 (I needed one on my Z550N). I installed all new drivers, and… what’s for, as usually say… who asked me to do… but I upgraded bios (as on site). I hoped there will be something new. Yes new…

Before bios update I booted OpenSuse with parameter

acpi_osi="!Windows 2006"

and was able to use intel and NVIDIA, everything was perfect.

But after BIOS update, when I try to boot kernet with such parameter (on speed mode, green light starting on boot, means NVIDIA works) only I can get is a screen full of vertical stripes of various colors… No image at all.

If only I could installed my usual bios)

Maybe somebosy knows what I can do to make NVIDIA work? =) Still love linux, do not want any other OS =)

It would help to know the release notes from the latest bios update.

  1. Add the following repository to your repositories list and update your kernel to 2.6.36. At this point if you have done so already make sure you install the base development and kernel development packages from yast patterns. You may also compile your own kernel from

Index of /repositories/Kernel:/HEAD/openSUSE_11.3

I have a sony vaio vpcz1190x laptop. After I upgraded my kernel to 2.6.37_rc3 from the repository the intel graphics works so I can just boot into the laptop by default, I dont need the additional parameters to get my keyboard or touch pad working. However currently the only issue with the kernel is that sound does not work, I have already seen a few bugs reported on the kernel to fix this issue, I will wait to see if an update to the kernel fixes the sound issue and will update here.

Meanwhile yes for the Nvidia card to work on this kernel, instead of enabling the NVIDIA repository I just custom compiled the driver and installed it.

Thank you for these instructions, which I followed on a VPCZ12X9E with openSuse 11.3.
As proposed, I downloaded and installed the NVIDIA driver (
I had to delete the option “discard” in /etc/fstab, because the mount command failed with the message that discard is unknown.
I had to retain the boot option x11failsafe, to get the X-server starting, which is probably not what we want.
The current boot options are
splash=silent showopts nomodeset x11failsafe vga=0x317 i8042.reset i8042.nomux i8042.nopnp i8042.noloop
The touchpad works!
The screen resolution in kde system settings is reported as 1024x768 with no further options.

Any ideas for getting the X-Server running properly?

By your saying “getting the X-Sever running properly?” what do you mean ? Do you mean at a resolution better than 1024x768 ? And if so, what resolution are you trying to achieve ?

There is a very useful log file /var/log/Xorg.0.log that contains lots of information on X when it runs that can be useful to share. Post the content of that file in SUSE Paste and then post here the URL/web-site address linked to where the contents of that file is located. Thus other’s can check that file for any errors.

I have finally gotten the sound also working with the kernel patch level 2.6.37 rc7. The only issue I see currently is that sometimes the intel graphics output just shows a blank screen, but if I restart a couple of times it is working again. I will open a separate thread on that and post the final resolution on that here. By the way I see no such issue with the nVidia output.

Some things i’ve done since my original post should solve your “discard” problem. The default raid setup proposed by yast during setup does not support the discard option, which is needed to truly optimize your ssd. So, you need to setup dmraid manually during the initial install. You need a boot partition plus a root and home partition, and swap (if you want one). What I did is make 3 equal size partitions (I have dual ssd not quad) on each ssd. 100mb for boot (on first ssd), 100mb swap (on second) 10gig root on both, and whatever is left on both set as home partitions. Then when you setup raid0 everything will work happily.

If you are running the 2.6.37rc kernel then you shouldn’t need all the boot options I described in my original post. That problem was supposed to be fixed in the latest kernel.

I haven’t tried the latest kernel yet (waiting for it to be released), but it looks as if the bios patch i described is still very useful. If you patched your bios and set the video options to static with the switch on speed, then boot with the nomodeset option. Once you get the nvidia driver installed it should work on the best resolution.

Couple of month later…opensuse 11.4.

  • Hacked BIOS in order to be able to use one video card at the time. Now when switch is in “Stamina” mode Intel VGA is driving force and i915 is loaded to run the show. If i want to use HDMI output i do have to reboot my laptop with graphics switch in “Speed” stand and, obviously, i have to have Nvidia drivers installed.
    In both modes graphics perform as i expected to: HDMI works, VGA works, dual screen setup would it be TV or my 1920x1200 monitor on either VGA or HDMI works just fine. I didn’t tried yet triple screen setup (laptop screen + screen on HDMI and on VGA), but then again, i never had any urges to do so.
    Bluetooth works.
    Hibernation works in both speed and stamina modes.
    Monitor brightness special keys work only while i915 is loaded, that is when laptop is started in Stamina mode. With Nvidia loaded i see brightens indicator while pressing keys, but actual brightness never changes.
    I never bothered to find out if i can get “vaio” keys to work.
    Well…it is a fully functional laptop …

Everything works but the built-in microphone…

If you think the digital mic might be an openSUSE configuration problem, if you start a new thread we can try to help you to get the built-in microphone to work. They tend to be digital microphones, and can be tricky dependant on the internal wiring of the laptop. Some times they even require a functional webcam driver to work (which is a bit bizarre).

If you think the digital mic is a problem that exists across multiple Linux distribution and might be an alsa driver configuration issue, then you could write a bug report on this. I understand from previous posts that writing bug reports is not exactly your favourite activity , but in the case of sound, the person who will try to resolve the bug report is a good guy. For openSUSE the SuSE-GmbH sound packager is also an alsa driver developer, and if anyone can resolve this problem and fix it for all Linux distributions, it is him. In that case if you decide to try, there is guidance for raising bug reports here: openSUSE:Submitting bug reports - openSUSE Raise the bug report against openSUSE component “sound” (to get the alsa developers attention) and attach to your bug report the /tmp/alsa-info.txt file you get from running the command:

/usr/sbin/ --no-upload 

Note the alsa developer will not read a forum thread, so the bug report needs to contain all salient information.

Then every couple of days or so, check in on the bug report, and look for a response. Likely the alsa developer will ask that you try some tests.

To login to the bugzilla you can use your openSUSE forum username and password. Be certain to clear the “NEED INFO” flag when you answer a question of the alsa developer.

As noted, he is very good, and any fix he makes for openSUSE gets sent upstream in a timely manner to benefit all Linux distributions.