sony laptop inbuilt webcam

I want to make my inbuilt webcam work on suse 11.2
Please advice.

Thanks and Best Regards

We need WAY more information abot your hardware. For starters, tell us what Sony laptop you have.

Open a console and type

sudo /usr/sbin/hwinfo --usb

In the output, find the part which deals with the webcam and post the content of that paragraph.


My built-in webcam on a ‘Sony Laptop’ (too vague?) worked without any problems out of box :slight_smile:

Hi there,
My laptop is an old sony vaio VGN-CR32G/B
There is no information for camera in the output of sudo /usr/sbin/hwinfo --usb
I also ran the below. There is no output
hwinfo --camera

on second thoughts, the below paragraph might be related to webcam from the output hwinfo --usb. But I am not sure.

11: USB 00.0: 0000 Unclassified device
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_5ca_1839_noserial_if0
Unique ID: 2UT6.kDtW1p6CMlF
Parent ID: k4bc.cO89g+iefn1
SysFS ID: /devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3:1.0
SysFS BusID: 1-3:1.0
Hardware Class: unknown
Model: “Ricoh Unclassified device”
Hotplug: USB
Vendor: usb 0x05ca “Ricoh Co., Ltd”
Device: usb 0x1839
Revision: “1.00”
Speed: 480 Mbps
Module Alias: “usb:v05CAp1839d0100dcEFdsc02dp01ic0Eisc01ip00”
Driver Info #0:
Driver Status: uvcvideo is active
Driver Activation Cmd: “modprobe uvcvideo”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #4 (Hub)

I note it is a 05ca:1839 webcam. I did a search on that and found various Ubuntu users struggling with this webcam. With what you provided above, and also from those Ubuntu sites I noted that this is a Ricoh webcam and it needs the Linux driver r5u870.

What I can’t figure out is if this webcam should be supported ‘out of the box’ with openSUSE, via a kernel module. I did read that the Ricoh webcam is a kernel module, and that it is compiled for a specific kernel version for the kernels prior to 2.6.24 and by DKMS for the kernels since 2.6.26. openSUSE-11.3 has a 2.6.34 kernel.

I note "Driver Status: uvcvideo is active " in what you posted, which suggests this webcam should work with the uvcvideo driver.

What applications did you try ? May I suggest you download from the Packman packager site ‘wxcam’ and give it a try (that works with my uvc compatible webcam).

There are specifically packaged rpms for the r5u870 Linux driver in the build service, but before going that route I recommend you try some different applications , as the webcam may be working now.

… some more information on this driver (in the rpm on the build service):

The r5u870 driver provides Linux support for webcams found in a some Sony and a few HP laptops (see Supported Devices for more information) that use the OEM Ricoh cameras.

This version of the r5u870 has been modified and is maintained by Alexander Hixon.
The original device driver was written by Sam Revitch, and was originally available on his website, which is currently inaccessible:
As such, most of the code is his.

There are a few differences between the original and this version, specifically, we:

  • Properly implements V4L1 query ioctl functions.

While version 1 has been obsoleted, it is still necessary to support it as a number
of applications still use it, including GStreamer’s v4lsrc element.

  • Support for VGP-VCC6, VGP-VCC7, and VGP-VCC8, and several other new webcams including supplied microcode.
  • Can compile against Linux kernels 2.6.24 or later.

05ca:1810 HP Pavilion Webcam - UVC
05ca:1812 HP Pavilion Webcam - UVC_NOFW (for Pavilion DV6502AU)
05ca:1830 Sony Visual Communication Camera VGP-VCC2 (for VAIO SZ)
05ca:1832 Sony Visual Communication Camera VGP-VCC3 (for VAIO UX)
05ca:1833 Sony Visual Communication Camera VGP-VCC2 (for VAIO AR1)
05ca:1834 Sony Visual Communication Camera VGP-VCC2 (for VAIO AR2)
05ca:1835 Sony Visual Communication Camera VGP-VCC5 (for VAIO SZ)
05ca:1836 Sony Visual Communication Camera VGP-VCC4 (for VAIO FE)
05ca:1837 Sony Visual Communication Camera VGP-VCC4 (for VAIO FZ)
**05ca:1839 Sony Visual Communication Camera VGP-VCC6 (for VAIO CR)
**05ca:183a Sony Visual Communication Camera VGP-VCC7 (for VAIO SZ/TZ11)
05ca:183b Sony Visual Communication Camera VGP-VCC8 (for VAIO FZ)
05ca:1841 Fujitsu F01 - UVC
05ca:1870 HP Pavilion Webcam / HP Webcam 1000

The package will now be continued on Debian/Ubuntu Driver for Ricoh R5U870 Webcam

I was looking at the thread again and noted you have openSUSE-11.2. 11.2 has the 2.6.31 kernel so I also suspect the r5u870 driver is in this kernel, but you need to check that.

That being the case, the build service link I gave you is wrong (I gave it for 11.3) and the proper links is this one here for rpms for the r5u870 driver from the build service.

Still, I recommend you try wxcam before you try installing any additional build service kernel modules for a driver.

If this is a uvc compatible webcam, I have found the guvcview application works nicely! (unfortuately it has code in it which makes it not legally acceptable for packagers to package it as an rpm, and one must instead custom compile it, which is something that is well beyond something that new users can do).

Some images of gucview (of course I am using a different webcam from yours)](

Gucview works with my webcam because it is UVC compatible.](

@oldcpu thanks
I have tried wxcam just now. It throws an error msg like below. I will try to find out the driver then. How can I check if the driver is there in the kernel…

Cannot open /dev/video0.
Please check if your system has the correct driver for your webcam, or change the webcam device in settings->preferences.

Well, I would be lying if I made out that I know a lot about this, because in truth I do not.

I do believe you can see what kernel modules are loaded by typing:


or possibly

less /proc/modules

and scroll thru the loaded modules and what I think < not sure > might be their loaded addresses (warning Will Robinson: wild speculation here).

I suspect you might also be able to see what webcam kernel modules come with your kernel version and are on your hard drive (but not loaded) by looking at with a file manager the directory:


… again - Warning Will Robinson - Wild speculation here …

When I looked there, I did not see the r5u870 module which I speculate is the kernel module for your webcam. again - Warning Will Robinson …

Hence if it is not loaded and if not on your hard drive, then you need to pick an appropriate rpm from the build service: Search Results

Now you can download a “.src” rpm and rebuild that with the approrpiate

rpmbuild --rebuild <rpm-being-rebuilt.rpm>

… or you could download a r5u870-kmp-your-kernel rpm and install that.

In both above cases reboot (to load module). Test. Note you MUST be exact in picking an rpm that is for your kernel version.

You can tell your kernel version by typing:

uname -a

… anyway, apologies for the Will Robinson warnings, but I am no expert in this … and if I provided too little or too much information, please excuse me as I don’t really know your experience level and as you can see mine is not so great.

… actually, my memory is faulty, it is supposed to be "Danger, Will Robinson, Danger … and some humour to put it in perspective: :smiley: :smiley:

When you finally manage to get the driver (ie the kernel module) installed and then loaded, wxcam should give you something like this:](
… note one must get the resolution correct. I find if wxcam has the wrong resolution, one gets a solid green screen. … I’ve also got some sort of off colour tinge to the wxcam videos that I have not yet been able to filter out. Fortunately gucview works much better.

I have got the driver. Now it looks like the below

11: USB 00.0: 0000 Unclassified device
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_5ca_1839_noserial_if0
Unique ID: 2UT6.kDtW1p6CMlF
Parent ID: k4bc.cO89g+iefn1
SysFS ID: /devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3:1.0
SysFS BusID: 1-3:1.0
Hardware Class: unknown
Model: “Ricoh Unclassified device”
Hotplug: USB
Vendor: usb 0x05ca “Ricoh Co., Ltd”
Device: usb 0x1839
Revision: “1.00”
Speed: 480 Mbps
Module Alias: “usb:v05CAp1839d0100dcEFdsc02dp01ic0Eisc01ip00”
Driver Info #0:
Driver Status: r5u870 is active
Driver Activation Cmd: “modprobe r5u870”
Driver Info #1:
Driver Status: uvcvideo is active
Driver Activation Cmd: “modprobe uvcvideo”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #4 (Hub)

But when I start wxcam. It still says “Cannot open /dev/video0”

You “have got the driver”. What does that mean? Exactly what driver have you “got”? Did you build it yourself? What version? Where did you get it from?

That output does not help me. Maybe it helps you ?

Did you try any webcam applications OTHER than wxcam?

What is the output of:

su -
lsmod | grep uvc
lsmod | grep r5u870

my memory has failed me, and its possible root permissions are not needed for that command. I simply can not recall and I am not at a Linux PC currently.

Also, what is the output of:

rpm -qa '*kmp*' 

@oldcpu, I got it from the link you gave me. I checked correct kernel and version and checked for 32bit.
here are the outputs

humayun@linux-9ikl:~/Download> lsmod | grep r5u870
r5u870 26436 0
usbcam 47808 1 r5u870
humayun@linux-9ikl:~/Download> lsmod | grep uvc
uvcvideo 66124 0
videodev 39168 2 usbcam,uvcvideo
v4l1_compat 16004 2 uvcvideo,videodev
humayun@linux-9ikl:~/Download> rpm -qa ‘kmp

I tried kopete also. when I go to configure Kopete. I can’t select any device from the dropdown menu.
I have also just installed cheese. and it says “No camera found!”

There was more than 1 version on that link. How can I tell which one you went for ?

What happens if you try as root:

modprobe -r r5u870
modprobe -r uvcvideo
modprobe r5u870

(that 1st modprobe may not be necessary … I’m speculating here).

Nothing happens. It just returns to the cursor again.

Sorry that I can’t help more.

I’m currently on vacation in a different continent (in an Airport waiting for my flight to board). You could try surfing on r5u870 to see what you can learn.

After you run the three modprobe command you should return to the
cursor (that means all is good). If you run lsmod command do you see
the driver present ( r5u870)?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 7 days 1:40, 7 users, load average: 1.66, 0.80, 0.52
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.12


lsmod| grep r5u870
r5u870 26436 0
usbcam 47808 1 r5u870