Sony DRU 510a not recognised by Burning software


I have a Sony DRU-510a external USB DVD +/-RW +/-R drive and it’s been recognised by my system when I look at Hardware Info in YAST. The problem is when I try to burn an ISO using Brasero it never thinks there is a blank disk in the drive. It just keeps telling me to put a blank disk in.

I’m running OpenSuse 11.1.

Anybody an ideas please?

Thanks very much.

Have you tried running Brasero as root? If you try it as root and it works, then you have a permissions issue and need to add your user to the appropriate group ( I think it is disc, but you should check to make sure) for access to the drive for burning purposes.

open your terminal of choice and:
sudo brasero

There was also a bug in openSUSE-11.1, which I am not 100% certain was fixed by subsequent updates, where accessing cd/dvd devices did not work well because of a permissions issue.

Try this:

YAST » Security and Users » User and Group Management » “select your user” » Edit » Details » Groups » check “cdrom” and “disk” and then click on “ACCEPT”.

Then exit YaST, restart your PC and see if that helps.

I note I no longer have those groups selected for permissions and my CD/DVD reader now works, so I believe the permissions issue was later fixed by a subsequent update.

Thanks oldcpu. I’ve tried that and nothing is any different. Refuses to recognise that there is a blank disk in the drive and enable the OK button.

Any other ideas?

Thanks. I tried running as root and it didn’t make any difference.

Any other ideas please?

You are certain the disk is blank ?

… my apologies for asking , but I’ve made that mistake before myself.

Hehe, yes. I was going to add in the post that I’d tried another disk off the top of the brand new set of disks I bought this week.

I’m confused. This drive worked on Ubuntu. Weird!

Sometimes, one discovers strange solutions for problems …

For example this one (where the user had a different problem with the Sony DRU 510a): invalid field in parameter Nero 5 & 6 Sony DRU-510A - Club CDFreaks / MyCE - Knowledge is Power

… they ended up doing:

*The solution i have is this(it’s not permanent but it works):

Just turn off the combuter.
Then close the I/O switch.
Open it again

Everytime that i follow that steps i see that the problem "dissapears"and i can burn everything*

Thanks for your efforts so far. Apologies for the delay in replying - had to read the kids a bed time story!

I’ve just tried switching everything off, turning the drive on 1st then booting the machine. No difference. The BURN button still remains unaccessible.

What I hadn’t tried before was burning a CD. Tried that and that worked a treat! So seemingly its something to do with DVD. I also haven’t tried copying a DVD. I’m trying to burn an .ISO image to DVD and that’s whats not working. If you’ve got any other ideas that would be great and in the meantime I’ll try copying a DVD and see if that works.

Thanks again.

brynjellis wrote:
> Hehe, yes. I was going to add in the post that I’d tried another disk
> off the top of the brand new set of disks I bought this week.
> I’m confused. This drive worked on Ubuntu. Weird!

What are the kernel versions of the two systems? There could be a
driver change.

Hi, thanks for replying to my post. I can’t remember what my Ubuntu kernel version was I’m afraid - it was Version 9.04 of Ubuntu if that helps.

My current version on Opensuse is

Just to let you know, I’ve been able to write to a CD and I’ve just tried to copy a DVD and it’s recognised the DVD and is writing it to a temporary .iso file as we speak which is great. It didn’t recognise a DVD+RW (with data already on it) I put in 1st but it has recognised a DVD-R with data already on it. The test I guess will be when it prompts me to put in the disk I want to copy it to which is also a DVD-R.

I’ll let you know what happens.

OK, the result of the DVD copy is that it created the .iso by reading the DVD-R (wouldn’t recognise a DVD+RW) but still won’t copy that .iso to a new disk (DVD-R).

So it looks like it can read (albeit on DVD-R by the looks of it, but that’s fine) but not write.