SonicWALL netExtender issue with non-root account


I’m not sure if this is a SonicWALL or an openSUSE question, but I thought I would start here. I installed the SonicWALL netExtender client 6.0.731 x64 on my 12.2 install of openSUSE. It will work fine as long as I don’t let my PC sleep or hibernate, or log off. Upon resuming, I get the following message when attempting to create a netExtender session:

02/03/2013 02:13:34.477 [general fatal 1703] FATAL: You don’t have permission to read/execute ‘/etc/ppp/peers’
02/03/2013 02:13:34.477 [general error 1703] pppd permissions are invalid

An uninstall and reinstall will fix this. I’ve tried a few chmod ‘fixes’, but nothing seems to stick.

Any ideas?

Thanks in advance.

Here is the folder /etc/ppp info:

drwxr-x--- (750)  5 root dialout   4096 Jan 22 19:03 ppp

Unless you belong to the group dialout or root, you can not even see whats in the folder. Make yourself a member of dialout and see what happens. I have a bash script useful in determining permissions. I normally just run it as a standard user, but in the case of /etc/ppp, I had to run the script as root, but then I see I could just be in dialout instead of being root I guess.

S.A.F.P. - SUSE Automated File Permissions - Version 1.0.4:

Download the bash script as it will help you understand permissions a little better I think.

Thank You,

Thanks so much for your quick reply! I added myself to the dialout group and that solved the problem with access the ppp directory. I also installed SAFP; what a useful tool!!! Thanks again for all your help.

Yea! A success story is just what I like to hear before I go to bed at night. I was very happy to help and just let us know if you need any further assistance.

Thank You,


I spoke too soon! I used SAFP to verify the permissions on /etc/ppp:

drwxr-x— (750) 7 root dialout 4096 Feb 5 18:29 ppp

(I am a member of the dialout group, BTW)

I can run netExtender as root with no problem, but here’s what I get when I run it with my user account:

pppd: must be root to run pppd, since it is not setuid-root

I have tried the solutions I found online, which mostly involve running the following:

sudo chmod u+s /usr/sbin/pppd

I have run this command, logged off/on, etc., but this doesn’t help. The netExtender still errors out with the ‘setuid-root’ error.

Any clues on how to fix this?

Thanks again!

So I see that: /usr/sbin/pppd, is also owned by dialout

-rwxr-xr-x (755) 1 root dialout 366704 Jul 16  2012 /usr/sbin/pppd

You could try making yourself a member of the group root, which is not the same as being root. Its worth a try as it allows you to look at anything owned by root even though you can’t change it unless you are root. Beyond that you need to find out where every part of the program loads. I had an issue with VirtualBox many moons ago that was installed as root, which was wrong. By that I mean, config data was loaded into the root user area which will never work as a normal user. So, could something be loaded wrong here? I don’t know but you need to trace down every part of this program. Start by looking in YaST and the Files tab for the application.

Thank You,

On 2013-02-06 00:46, seuss91 wrote:
> Any clues on how to fix this?

Years ago, when I used wvdial to dial out, I had these in

#/usr/sbin/pppd         root:dialout    6754

/usr/bin/wvdial         root:dialout    4750

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)