Some programs don't run!

Hi i have kde4 in 11.1 and i have the BIG issue

i want to install a virtual machine software
so i tried virtual box ose (IT WON"T START!)
and i want to install a antivirus
i tried clam (can’t see it anywhere!)
i tried Klam (it start but scanning don’t work!)
i tried antivir (wont start!)

so i have no choice that i have to use avg crap edition (linux edition)
and i want to install my webcam which is a microdia u-cam and i select the right type of system type mine is (x86-64) and I keep getting error messeges!

why is this happening to me with software and why is it hard to run it and install it?

please help me with this issue please! im bagging you

thank you

Have you installed the hal update? The latest version is 0.5.12-10.12.1. I think this will solve the problem with VirtualBox not starting. If it doesn’t, try starting it as root.

Can’t help with the other things.

how do i install the hal update?

sorry i’m new to open suse

The hal update is available via YOU (YaST Online Update). Thats’t the small green icon in the lower right panel.

To determine what version of hal you have type this in a terminal:

rpm -qi hal

i have this version

liam@linux-skz8:~> rpm -qi hal
Name        : hal                          Relocations: (not relocatable)
Version     : 0.5.12                            Vendor: openSUSE
Release     : 10.12.1                       Build Date: Tue 20 Jan 2009 11:33:52 AM NST
Install Date: Wed 28 Jan 2009 09:45:42 PM NST      Build Host: albeniz
Group       : System/Daemons                Source RPM: hal-0.5.12-10.12.1.src.rpm
Size        : 1813252                          License: GPL v2 or later; AFL
Signature   : RSA/8, Tue 20 Jan 2009 11:34:10 AM NST, Key ID b88b2fd43dbdc284
Packager    :
URL         :
Summary     : Daemon for Collecting Hardware Information
Description :
HAL is a hardware abstraction layer and aims to provide a live list of
devices present in the system at any point in time. HAL tries to
understand both, physical devices (such as PCI and USB) and the device
classes (such as input, net, and block) physical devices have. Besides
it allows merging of information from device info files specific to a
device. HAL provides a API through D-BUS for querying devices and
notifying when things change. Finally, HAL provides some monitoring (in
an unintrusive way) of devices. For further information, please refer
to the  HAL specification.

    Danny Kukawka <>
    Kay Sievers <>
    Joe Shaw <>
    David Zeuthen <>
Distribution: openSUSE 11.1

help? anyone?

You have the latest version of hal so I guess that’s not the problem. Have you tried starting virtualbox as root?

no but i did with antivir because it shows up atuomacitly
but i’l try with virtual box

Woah, do not run as root! It’s really not necessary. How did you install Virtualbox? If you run from your terminal emulator like konsole it should output an error. Post it here. The usual problems are problems making the kernel module, not being a member of vboxusers and in the recent non ose build the execute bit is not set for the executable.

There is a README file in /usr/share/doc/packages/virtualbox-ose/README.SUSE that has info about running VirtualBox as normal user.

You can use YaST2 to add your user to vboxusers or run this command as root:

usermod -A vboxusers username

Replace ‘username’ with your user and logout/login. You should find the emulator listed in the kickoff menu under system > Emulator. It started as normal user for me this way.