Some openSUSE-12.3 experiences on different hardware

I installed the 32-bit openSUSE 12.3 from DVD onto my ancient custom PC with MSI motherboard, athlon-1100+ cpu, 2GB RAM and an ancient nvidia FX5200 graphic card. I played with RC1 and RC2 of 12.3 so I more or less knew what to expect. The nouveau driver does not work with this FX5200 ever since the start of the 3.7.x kernel so an install chosing the KMS setting was necessary. That resulted in an install with the VESA driver in use. Fortunately I was able to get the proprietary 173.14.36 nvidia driver to work after putting in a symbolic link and applying a patch to the driver (which I blogged about here on the 173.14.36 driver patch for openSUSE).

It took two attempts to setup my Network printer, as one of the HPLIP drivers for my HP All-In-One Photosmart Premium C309a is broken, and per Murphy’s Law I picked the broken one first. The network scanning function of that printer worked well the first install attempt.

Sound worked, albeit playing the higher definition videos with this old PC does not work well, even with the proprietary graphic driver.

Below is the inxi -F output from this pc

oldcpu@mini:~> inxi -F
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
System:    Host: mini.darmstadt Kernel: 3.7.10-1.1-default i686 (32 bit) 
           Desktop LXDE (Openbox 3.5.0) Distro: openSUSE 12.3 (i586) VERSION = 12.3 CODENAME = Dartmouth
Machine:   Mobo: N/A model: N/A Bios: N/A version: N/A date: N/A
CPU:       Single core AMD Athlon (-UP-) cache: 256 KB flags: (sse) clocked at 1149.968 MHz 
Graphics:  Card: NVIDIA NV34 [GeForce FX 5200] 
  1.13.2 drivers: nvidia (unloaded: fbdev,nv,vesa,nouveau) Resolution: 154x49 
Audio:     Card-1: Ensoniq 5880B [AudioPCI] driver: snd_ens1371 Sound: ALSA ver: k3.7.10-1.1-default
           Card-2: VIA VT8233/A/8235/8237 AC97 Audio Controller driver: snd_via82xx
Network:   Card-1: Atheros AR5212/AR5213 Wireless Network Adapter driver: ath5k 
           IF: wlan0 state: down mac: 00:11:95:91:76:f5
           Card-2: Realtek RTL-8139/8139C/8139C+ driver: 8139too 
           IF: eth0 state: unknown speed: 100 Mbps duplex: full mac: 00:50:fc:5f:ba:6d
Drives:    HDD Total Size: 484.0GB (1.1% used) 1: /dev/sda ST3320620A 320.1GB 
           2: /dev/sdb Maxtor_6Y160P0 163.9GB 
Partition: ID: / size: 25G used: 4.9G (21%) fs: ext4 ID: /home size: 28G used: 314M (2%) fs: ext4 
           ID: swap-1 size: 2.85GB used: 0.00GB (0%) fs: swap ID: swap-2 size: 1.04GB used: 0.00GB (0%) fs: swap 
Sensors:   Error: You do not have the sensors app installed.
Info:      Processes: 103 Uptime: 0:20 Memory: 384.6/2017.6MB Runlevel: ? Client: Shell inxi: 1.7.24

The above resolution is reported incorrectly. Actual resolution achieved with this NV34 (FX5200) graphic card is 1600x1200 with this FX5200 - which is correct. On this PC I have not yet installed the ‘mesa’ app/package necessary to get GLXgears / glxfino so that may be part of the reason why there was a bad resolution reported.

In summary , aside from the nouveau driver upstream problem, I note openSUSE-12.3 runs ok on this hardware and I’m happy thus far :slight_smile:

Next I installed the 64-bit openSUSE-12.3 GM from the DVD on my Dell Studio 1537 laptop (Core2 Duo P8400 CPU, w/4GB RAM and Radeon HD3450 graphics). Previous this laptop had openSUSE-12.2 with a KDE desktop, and I chose the same this time, keeping the same /home.

Installation was straightforward. I had the same network printer hiccup (it took two tries to get the right printer driver). Wireless also did not ‘just’ work and I had to go in to YaST Network Devices and then go back to the KDE desktop Network manager to get the wireless running.

But overall, all appears to be running well now. I have Skype, Virtual Box, Chrome browser, and also various 3rd party packman packaged apps installed.

Below is the output of “inxi -F” from this successful install.

System:    Host: dell.darmstadt Kernel: 3.7.10-1.1-desktop x86_64 (64 bit) 
           Desktop KDE 4.10.00 Distro: openSUSE 12.3 (x86_64) VERSION = 12.3 CODENAME = Dartmouth
Machine:   System: Dell (portable) product: Studio 1537 version: A09
           Mobo: Dell model: 0P132H version: A09 Bios: Dell version: A09 date: 05/27/2009
CPU:       Dual core Intel Core2 Duo CPU P8400 (-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) 
           Clock Speeds: 1: 2267.00 MHz 2: 800.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI RV620 [Mobility Radeon HD 3400 Series] 
           X.Org: 1.13.2 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1440x900@60.0hz 
           GLX Renderer: Gallium 0.4 on AMD RV620 GLX Version: 3.0 Mesa 9.0.2
Audio:     Card-1: Advanced Micro Devices [AMD] nee ATI RV620 HDMI Audio [Radeon HD 3400 Series] driver: snd_hda_intel
           Card-2: Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: k3.7.10-1.1-desktop
Network:   Card-1: Broadcom NetLink BCM5784M Gigabit Ethernet PCIe driver: tg3 
           IF: eth0 state: down speed: 4294967295 Mbps duplex: unknown mac: 00:21:70:85:8d:be
           Card-2: Intel Ultimate N WiFi Link 5300 driver: iwlwifi 
           IF: wlan0 state: up mac: 00:16:ea:ed:80:76
Drives:    HDD Total Size: 250.1GB (51.6% used) 1: /dev/sda ST9250421ASG 250.1GB 
Partition: ID: / size: 20G used: 6.3G (34%) fs: ext4 ID: /home size: 131G used: 114G (93%) fs: ext3 
           ID: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 49.0C mobo: 45.0C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 144 Uptime: 0:25 Memory: 518.8/3927.7MB Client: Shell inxi: 1.7.24 

This will likely be my last openSUSE install on this laptop (if all goes well) as my wife plans to give this laptop away to a friend of hers (who has a family) this summer, after I purchase an Ultrabook this spring.

I next installed the 64-bit openSUSE-12.3 GM from DVD (KDE desktop) on a test partition on my main PC (an Asus P6T Deluxe V2 with an Intel Core i7-920 , 6GB RAM, and GTX260 graphic card). Installation was fairly smooth. Sound worked. Graphics with the nouveau driver worked (with 1920x1200 nominal max resolution). Nouveau performance is good. This motherboard has 2 ethernet devices and neither was automatically configured during the install. I had to go to YaST after the install to do a very basic setup, after which I had internet access on the PC.

This time in setting up the Network printer, I managed to select the correct printer driver the first time. Network scanning worked. My Logitech C910 webcam worked (testing it with guvcview).

I stayed with the legacy grub on this install.

This is likely the last openSUSE-12.3 install I do for a while, until my wife gives me authorisation to put 12.3 on her PC. … In June this year I plan to fly to Canada to visit my mother, and when I do I plan to put openSUSE-12.3 on her PC (replacing the openSUSE-12.1 that is on her PC now).

oldcpu@corei7:~> inxi -F
System:    Host: corei7-920.darmstadt Kernel: 3.7.10-1.1-desktop x86_64 (64 bit) 
           Desktop KDE 4.10.00 Distro: openSUSE 12.3 (x86_64) VERSION = 12.3 CODENAME = Dartmouth
Machine:   Mobo: ASUSTeK model: P6T DELUXE V2 version: Rev 1.xx Bios: American Megatrends version: 1108 date: 09/21/2010
CPU:       Quad core Intel Core i7 CPU 920 (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) 
           Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 2668.00 MHz 5: 2668.00 MHz 6: 1600.00 MHz 7: 1600.00 MHz 8: 1600.00 MHz
Graphics:  Card: NVIDIA GT200 [GeForce GTX 260] 
           X.Org: 1.13.2 drivers: nouveau (unloaded: fbdev,nv,vesa) Resolution: 1920x1200@60.0hz 
           GLX Renderer: Gallium 0.4 on NVA0 GLX Version: 3.0 Mesa 9.0.2
Audio:     Card-1: Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel
           Card-2: Logitech HD Webcam C910 driver: USB Audio
           Sound: Advanced Linux Sound Architecture ver: k3.7.10-1.1-desktop
Network:   Card-1: Marvell 88E8056 PCI-E Gigabit Ethernet Controller driver: sky2 
           IF: eth1 state: down speed: 65535 Mbps duplex: unknown mac: 00:24:8c:7e:ee:38
           Card-2: Marvell 88E8056 PCI-E Gigabit Ethernet Controller driver: sky2 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:24:8c:7e:ee:39
Drives:    HDD Total Size: 1500.3GB (79.7% used) 1: /dev/sda ST31500341AS 1500.3GB 
Partition: ID: / size: 15G used: 6.6G (48%) fs: ext4 ID: /home size: 34G used: 290M (1%) fs: ext4 
           ID: swap-1 size: 6.82GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 50.0C mobo: 48.0C gpu: 0.0 
           Fan Speeds (in rpm): cpu: 1171 psu: 0 sys-1: 0 sys-2: 0 sys-3: 0 
Info:      Processes: 188 Uptime: 0:05 Memory: 506.7/5972.4MB Client: Shell inxi: 1.7.24

I’m still running the nouveau driver, and I have not decided if I will update to the propietary nvidia driver.

Again, overall openSUSE-12.3 is running well on this hardware.

Was the speaker volume muted (KMix) when you finished the install?

Mine was with RC1, and it seemed to come back again after I applied some package changes (packman IIRC) yesterday after bringing it from RC2 to final. Easily dealt with, but still a gremlin. :slight_smile:

Since S.u.S.E. 5.3, I’ve always waited a little before installing a new release, but this time I couldn’t resist the eye
candy of openSUSE 12.3 and starting downloading the ISO within the first minute of the official release time today. My
hardware is similar to yours (i7 Bloomfield, X58 chipset, Nvidia GPU using 1920x1200 resolution) and I also installed
the KDE version.

I noticed the installer has received specific attention from the moment those overlapping green wait bars appeared at
the bottom. And I really liked the dark colour theme. Apart from spending 4-5 minutes trying to find my Linux
partitions, the installation (from scratch, not upgrade) went very smoothly. I bit the bullet and opted for GRUB2 rather
than Legacy. Following my openSUSE 12.2 experience with GRUB2, I was expecting to discover rubbish resolutions for the
virtual consoles - happily my expectations were wrong.

After booting for the first time, `zypper up’ only wanted 3 packages. When I loaded Firefox, the mouse started to
stutter and then the system crashed requiring a hard restart. I guessed this was a nouveau driver issue, so I installed
Nvidia’s proprietry driver (310.40). After rebooting, the virtual consoles were at 800x600 resolutions as I experienced
with openSUSE 12.2’s GRUB2, but the consoles’ resolutions were easily changed within YaST’s bootloader configuration
tool to a sensible 1600x1200 (although I guess 1920x1200 is out of the question). Firefox worked fine when I next tested

Unsurpringingly, all my favorite console software (slrn, mutt, irssi, sc, cmus, lynx, etc…) installed fine and run
well under openSUSE 12.3. I’m about to play about with installing and running some X-reliant software, and test the
performance of the new kernel with low-level stuff, but so far I’ve been impressed. The desktop looks gorgeous and I
don’t where to start exploring this new KDE version.

So positives:

  1. Installation process the most polished I’ve seen from any Linux distro yet.
  2. GRUB2 TTY issues are (at least from my experience so far) resolved.
  3. I’ve noticed that openSUSE 12.3’s repos have been expanded with some very useful new inclusions.
  4. Desktop look gorgeous. The dark theme is so much more easy on the eye compared to the pale sickly green.

… the only negatives I can think of are:

  1. Some things that should installed routinely (e.g. pavucontrol) still are not.
  2. There seem to be issues with Firefox and the nouveau driver.
  3. I’m going to miss GRUB Legacy’s penguins around Christmas time.
  4. There’s still no background image on TTY1 - I imagine this is a plymouth vs bootsplash issue.

I think the openSUSE team have excelled themselves this time and are to be warmly congratulated by the community. I’ve
only scratched the surface of this release but I can already see a lot of intelligent work under the bonnet that’s made
things just so more convenient without having to stumble into brick walls. And the eye candy is just fabulous.
Usually I have an all-black desktop, but I might, just might, stick with default dark wallpaper with Geeko peering from
the vines…

Hi OldCPU,

Thanks for the posts, and for the great advice at and info on patching the Nvidia drivers for 3.7 and 3.8 kernels.

I’ve upgraded from 12.2 to 12.3 and am running into the following when patching the Nvidia installer:

./ --apply-patch patch_nvidia_310.19.run_for_3.7 

However running ./ results in:

ERROR: If you are using a Linux 2.4 kernel, please make sure
         you either have configured kernel sources matching your
         kernel or the correct set of kernel headers installed
         on your system.
         If you are using a Linux 2.6 kernel, please make sure
         you have configured kernel sources matching your kernel
         installed on your system. If you specified a separate
         output directory using either the "KBUILD_OUTPUT" or
         the "O" KBUILD parameter, make sure to specify this
         directory with the SYSOUT environment variable or with
         the equivalent nvidia-installer command line option.

         Depending on where and how the kernel sources (or the
         kernel headers) were installed, you may need to specify
         their location with the SYSSRC environment variable or
         the equivalent nvidia-installer command line option.

I’ve prepared the kernel sources with

cd /usr/src/linux
make cloneconfig 
make scripts
make prepare

And I’ve sym linked the version.h header

cd /lib/modules/3.7.10-1.1-desktop/build/include/
ln -s generated/uapi/linux

Kernels installed:

# rpm -qa | grep kernel

# rpm -qa | grep glibc

If I try to use an un-patched 310.40 it also fails, but if I specify the kernel source it at least build the module

./ --kernel-source-path=/usr/src/linux

But then fails with

-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU installed in this system is not supported by this NVIDIA Linux graphics driver release.
[42277.740034] nvidia: no symbol version for module_layout
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at

However, specifying the source path, with the patched version, it does not even build the module and fails as above.


Might you have any suggestions?

Thank you,
Lews Therin

Fortunately sound ‘just worked’ . Even on my PC with 2 sound devices, it worked fine and I was able to switch between the two device easily for each application, using pavucontrol.

In truth I am the same way. While I did put openSUSE-12.3 on the main partition on my Dell Studio laptop, … it was only on that PC. On my other two installs (my main PC and my sandbox PC) I put openSUSE-12.3 on a test partition. I am running openSUSE-12.1 on both of those PCs, and before May this year I plan to update their main partitions to either 12.2 or 12.3.

Thats an interesting observation. On my Dell Studio laptop (250GB drive) and my Sandbox PC (two hard drives, one being 500GB and the other 350GB) finding the Linux partitions was relatively fast (maybe 1 minute max). But on my Main PC, with a 1.5 TB drive, it took over 20 minutes of just sitting there . If it was not for the fact I saw similar behaviour on 12.2 (all milestones/RC/GM version) and now 12.2 (all milestones, RCs and now GM version) I would have thought the install failed. But no failure - just lots of patience needed.

I put grub2 on my Dell Studio laptop, and legacy grub on my Sandbox and Main PCs.

Virtual consoles ? I’ don’t undertand what you mean.

I note nouveau driver does not work with the almost ancient NV34 (FX5200) on my Sandbox PC, but that it works superbly on my Main PCs nVidia GTX260 graphics. I have not tried the properietary driver on my GTX260 hardware. What method did you employ to update to the proprietary nvidia graphic driver ?

I usually have a white/grey desktop, but I too am tempted by the dark wall paper implementation.

I’m wondering if you need to put in place a symbolic link to solve this.

It’s black, aka the graveyard theme. You must love consoles. Leaving aside your dislike of green, why do you think that scientific instrument panels, for many decades, have been presented in easy-on-the-eye neutral colours? Where users are in front of them for many hours daily. They are more restful on the eye.

Never mine eye-candy, think eye-strain. Green screens are better for your eyes. :slight_smile:

Well, yes my sound just worked after clicking off the mute. Pavucontrol wouldn’t have helped that. For one sound chip to a single stereo speaker set, KMix/Phonon works perfectly well :slight_smile:

Haven’t seen this mute issue for many releases on this notebook. It used to be a bug around the very early 11.x series. Oh well, perhaps it won’t return again.

]Well, yes my sound just worked after clicking off the mute.

Ahhh …

Consused I must say you are an advanced user who has NOT lost touch with their ‘inner newb’, and you know better than I what can be frustrating for some. If my volume was muted on boot I would not think twice about unmuting it, as to me its intutively obvious - ie I’ve lost touch. It quite possible in 12.2 or 12.3 milestone, beta or release candidate versions I needed to unmute upon boot, but I simply would not make note of it … < ergo unless I specifically look for such a setting, I would never remember it … >

On 2013-03-13, consused <> wrote:
> flymail;2534563 Wrote:
>> 4. Desktop look gorgeous. The dark theme is so much more easy on the
>> eye compared to the pale sickly green.
> It’s black, aka the graveyard theme. You must love consoles. Leaving
> aside your dislike of green,

I never said I dislike green! The verticle green stripes themes of 11.4 were quite attractive I thought. But it’s the
pale lime hues of 12.1 and 12.2 that I dislike.

> why do you think that scientific instrument
> panels, for many decades, have been presented in easy-on-the-eye neutral
> colours?

Well, since my profession is a scientist, I can tell you are just plain wrong :). Most CRT displays and CROs in labs in
the 1970s and 1980s were monochrome (and my lab still has some equipment left from those days!), typically with a green
or orange foreground and a black(ish) background. Scientific instruments in those days had LED displays to show
numerical information, typically with red LEDs and black backgrounds.

> Where users are in front of them for many hours daily.
> more restful on the eye.

Anaemically pale lime green is not a neutral colour. Nor is pink :). The greens in 11.4 were however much more neutral.

> Never mine eye-candy, think eye-strain. Green screens are better for
> your eyes. :slight_smile:

I find strain comes from a lack of contrast, and find contrast is best served with a dark background. I guess it’s just
a matter of personal preference :).

Hi OldCPU,

That might be, though I’m a bit perplexed as all the posts I see show this is typically solved by linking:

cd /lib/modules/`uname -r`/build/include/
ln -s generated/uapi/linux 

Any ideas on what other sym link may be needed?

Thank you,
Lews Therin

I have only done this with the legacy 173.14.36 driver and you are trying with a different driver. I am guessing by your quote that you applied the simlink you quote, and then attempted to build the driver WITH the patch, and it failed ?

I have seen reference to another / different simlink in post#22 here:

That thread that I quote also has other suggestions in addition to that of post#22.

Ahh … I just noticed in the DETAILs of you post. Is that not the WRONG patch ? Is there a reason why are you using that version ?

Does not openSUSE-12.3 have a 3.8 kernel (and not a 3.7 kernel) ?

And in my blog comment where I reference lwfinger’s page, is not the patch patch_nvidia_310.19.run_for_3.8 ?

What am I missing ?

My mistake in my previous post. You have the correct patch. openSUSE-12.3 has the 3.7 and not 3.8 (its late and I’m tired - I know - poor excuse).

:smiley: Well, with the new blackboard theme, and the default thin panel, the mute sign on the speaker icon just doesn’t show up well, so didn’t see it until I needed sound. A quick unmute. It used to irritate new and old users alike. It shouldn’t happen anyway, and those days should be long gone. Definitely not there on previous 12.x, and hopefully just a hangover from pre-release here.

I dislike lime green and 12.2 was not lime green here, even with backlight at 100 percent and it has a darker but subtle pattern. 11.4 was very different, a darker shade nearer to a viridian green. I found 12.2 to be the more restful background.

I have spent most of my working life surrounded by good quality screens. Did I originally mention screens of any kind? No, but I was referring to instrument panelling, even desktop PC’s were usually a neutral colour. It’s the backgrounds, the big areas that need to be neutral and obviously with a decent enough contrast to the foreground colour, or yes that will also cause strain. It’s also true for the computer screen. My notebook is black, with 11.3 that’s too much black. Maybe it’s better against a silver/metallic coloured notebook.

I meant 12.3 of course. That’s twice now for the finger trouble in one night. Definitely too much bl… :X

I’ve upgraded a bunch of different boxes having an assorted hardware in them and I’ve had several failures - most of the boxes in question have been 12.1 or 12.2 ones, removed repos, cleaned, zypper dup’d (twice) to make sure everything went alright and ALL the failed ones have had the same issue, initrd build has failed to contain the proper drivers for the hardware.

For some reason the rebuilding has “forgotten” some chipset drivers although the previous ones have had no issues. It’s a really nasty problem and one that’s taken some manual fixing :frowning:

Also Grub2 seems to have some issues, it doesn’t cleanly migrate all the old information but retains several kernel lines that no longer exist - and has them as default. Not a big one that but if you remotely upgrade the server, you’ll end up with a non-booting system, which is bad.