Solved: Tumbleweed, K3b, DVDs and Transcode


I have a message from K3B when it starts a DVD rip job:

K3b uses Transcode to rip video DVDs. Please make sure it is installed.

I can’t find the appropriate RPM. What shall I install, from where?


Solved: temporarily attach Packman for openSUSE 11.4. It’s in there but not in PackmanForTumbleweed

What repo did your K3B install from?

transcode is in packman.

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram

You started a new thread to answer that question? :slight_smile: Swerdna just asked that in Tumbleweed forum.

Edit: Oh it got moved to Tumbleweed!

From Packman 11.4 ( and the rip worked.

But just now, strangely coincidental, when I run “zypper dup -D” I se that zypper wants to upgrade k3b and k3b-codecs to PackmanTumbleweed, but not transcode. I’m going to do that and see if the rip continues to work

I merged the two threads (not without a bit of moderator finger trouble along the way) but hopefully it now ended up all in Tumbleweed.

Bit of confusion guys? I started it in the wrong forum ---- smack!
Thanks for the merge oldcpu.

At least I learned one thing: Tumbleweed users have to retain their 11.4 Packman and also have to attach The Tumbleweed version of Packman, concurrently. Or did Packman packagers make a mistake and accidentally leave transcode out of Tumbleweed version of Packman? I better look into that.

My posting was in the context of seeing swerdna’s moved op in Tumbleweed forum and Martin’s (I assume using nntp) as an op stranded in Multimedia. :smiley:

I suspect the latter possibility. BTW transcode isn’t a package dependency for K3B in any case.

On standard 11.4 here, K3B is in Packman-essentials but “transcode” is in Packman-multimedia. Since Packman-Tumbleweed is equivalent to Packman-essentials, transcode is missing for Tumbleweed!

I can’t figure out the packman policy. I’ll let it slide for now.

Sorry, I shouldn’t have said “latter possibility” in my previous post, since it’s not missing by accident. Although IMO a somewhat short-sighted decision on 11.4 standard to separate “transcode” in packman-multimedia from “K3B” in packman-essentials. That automatically ruled it out of packman-tumbleweed for the reason I gave (and stated in the wiki).

That introduces a flaw into repos for Tumbleweed, not a big one because transcode doesn’t vanish entirely. But newbie users would have a problem because transcode isn’t available at all via PackmanTumbleweed and we tell ppl to turn off the 11.4 Tumbleweed…a flaw IMHO.

Well on standard 11.4 I tried to exist with just packman-essentials, but had to add packman-multimedia for a handful (<5) of packages. The extra included “libdvdplay0” which IIRC is listed in the multimedia Howto. I wonder if Packman views DVD functions as non-essential?

From a user perspective and Tumbleweed, I agree it is a flaw.

IMHO a normal user of 11.4 should just attach the top level Packman. I can’t see any advantage for them (and that includes me) in attaching selected sub-repos.

Same for TumbleweedPackman (in principle – I know there aren’t any sub-repos ATM).

I really only need multimedia packages from Packman on 11.4, no others. Having Packman-essentials means that when I use the package switcher by repo (Yast), only those essential packages get switched and updated. I can do the few from Packman-multimedia individually. The only user advantage claimed for the sub-repos was manageability. That also covers the situation experienced here, where “essentials” are frequently updated but packages from “multimedia” are not.

Same for TumbleweedPackman (in principle – I know there aren’t any sub-repos ATM).

And also here with my preferred use of multimedia sub-repos, but Packman-tumbleweed is the same as Packman-essentials (the minimal package collection). That means I will at some point need to add Packman-multimedia (unsupported on two counts). :slight_smile:

I updated to Tumbleweed today and noticed that K3b codecs just dont work (empty list under plugins along with the usual K3b warnings about various codecs missing),even if I have K3b-codecs from Packman Tumbleweed repository,but then I enabled 11.4 Packman repository and downgraded K3b and K3b-codecs to that version and now everything works.Strange that version from Packman Tumbleweed didnt work for some reason.