[SOLVED] Garbled Low freq voice in Skype

On Friday night last week, from here in Europe I contacted my mother in Canada, with us both using a video connection with Skype on 64-bit openSUSE-11.3 KDE-4.4.4 installs. I’ve successfully had ‘video chats’ with her on Skype many times. But this one was different, her voice came across in a garbled Low freq voice, almost like Darth Vader with a cold. Her voice coming over the Internet from Canada to Europe was not understandable.

She could hear my voice fine.

We terminated the call and chatted on a regular voice phone. She noted her niece had also complained on the same day, about her voice sounding garbled in a low frequency. So I concluded there was something wrong with Skype or openSUSE on her PC.

I access her PC remotely (for maintenance) a continent away using ssh, vnc, and nx. But its difficult to tune audio, because I am much too far away to hear the audio on her PC. So she needs to be sitting by the PC acting as my ears, when I work on it.

I surfed the web for an answer, but nothing really useful came up. The Skype folks claimed any problem had to be an Operating System (OS) or mixer problem. But I checked the OS and mixer thoroughly, and I was confident I had it correct.

So on Sunday, with me connected to her PC via vnc, I had my mother record her voice on her Linux PC with the command:

arecord -f cd test.wav 

and then with me connected to her PC via vnc I remotely helped her play the file ‘test.wav’ back with:

mplayer test.wav 

My mother advised me her voice sounded fine. At that point I concluded the problem had to be with Skype and not with the mixer nor with openSUSE. I had previous checked the Skype settings and I could find nothing wrong that could be configured with a menu in Skype.

So while connected to her PC via vnc, I changed the directory ~/.Skype on her home partition to ~/.Skype-old and I also de-installed Skype. Then I re-installed Skype for her, and we tried once again to chat a continent away using Skype.

This time her voice was fine.

So somehow something got corrupted in her Skype. … I have no idea what it was, … its possible she changed some Skype setting that I could not locate. … Anyway, no matter, its fixed now, although the solution (to remove the ~/.Skype directory, and re-install Skype) was rather dramatic. If there is a next time (when this problem re-occurs), I may only remove the ~/.Skype directory and see if that is sufficient.

Good solution.

Had the same problem and removing the .Skype library solved it.
I also unchecked the “let Skype set the mixer levels automatically” option in the audio options after removing the .Skype library.

I don’t know if the last step is necessary or not.

Thanks again,

I had a problem with skype with a library but now it is ok. It is not run.