SOLVED can't accept nvidia eula

I must be doing something wrong, but trying to update via command line (sudo zypper dup) shows I have 4 packages to update: nvidia-computeG05 nvidia-gfxG05-kmp-default nvidia-glG05 x11-video-nvidiaG05. When I try to accept the eula, I scroll to the bottom of the agreement where there is the prompt: Do you agree with the terms of the license? [yes/no] (no): . Answering with either ‘y’ or ‘yes’ results in the eula being re-displayed, not actually accepting. So, there is no way to proceed with the update. Am I doing something wrong?

I tried using the yast update tool, but it does not even show an update. (if I change the category here from ‘needed patches’ to ’ all patches’ I see that it is set to system_snappy, and there are 8 other possible toggles that all say the same thing: Test-update for Opensuse Tumbleweed.)

EDIT: IDK, i tried again, and this time entering ‘y’ instead of ‘yes’ worked. Maybe I did not try that before? Anyway, sorry, all good.

Only use the command line and zypper dup for Tumbleweed, no other tools :wink:

You should be able to just press q to get to the end of the eula, then enter yes <press return>.

Else you could try;

zypper -vvv --auto-agree-with-licenses dup


zypper -vvv -l dup

The vvv adds verbosity to see what is happening.

Thanks as always, Malcolm!