software update

I recently installed 12.2 from livecd and ran the software update program. It
wanted to install about 360 MB of software which would take over an hour or
so. I noticed one of the packages was integer linear programming! Why do
I need that?? Plus alot of other stuff I don’t want or need (Bluetooth)
I read a post about zypper patch and Yast online update. Are these different
from the software update program? Searched on my system for zypper
but there were no results. Any tips would be appreciated.

I believe yast online update is the same as running zypper patch. I usually just use the software management module to run an update (similar to zypper up). You can review the updates and deselect or uninstall what you don’t want (I actually do this during the installation since I use net install or DVD). You can also set ‘Ignore recommended packages for already installed packages’ which will prevent some dependencies. The downside is this might be something you actually want or expect will not get selected. Though it is up to your preference really.

Thanks Nightwishfan !

I used Yast, software management and it does allow modifying the selection.
I still ended up with alot of extra stuff I didn’t know I “wanted”, like a new kernel!
Had to modify /etc/grub.d/40_custom in Mint before I could boot opensuse.
The lpsolve package was added for Libreoffice calc. It’s been a while since I
used opensuse, so I have to get used to it again.
thanks again,

PLease be more precise. What do you mean with “the software update program”. while this expression tell what you think that program should do, we still do not know which program you used (nor what you exactly did).
We hate vagueries because they often lead to people assuming what you did and that assumption is often wrong.

The standard way to update the software packages is YaST > Software and then either Online Upddtt or Software management. From the command line you can use zypper (zypper patch and/or zypper up, according to need).

I clicked applications - system tools and the app is named software update. The icon has
boxes with an circular arrow.
I’m using 12.2 gnome from a livecd install.
After trying to use that program, I started Yast - software management
and it complained that PackageKit was still running! I had to stop it with
kill -9 pid. Also, when trying to use Yast - software management, the
program crashed, seg fault. Not sure what was going on. Eventually,
it worked, I guess. Tried to login a few minutes ago and couldn’t, but
succeeded just now. Not sure why?

I recommend you purge all of the packagekit and just use yast. Also, what is actually wrong? You are talking about segfaults and logins, I am lost. I can only fix one thing at a time. What is your goal, to do system updates? If you do not mind command line just run zypper up as root. If you want graphically I can help there as well, but I need to know what you are up to at the moment.

That program is apper. It is not very popular among many open SUSE users and seems to be not yet fully developed. As nightwishfan mentioned you can delete apper and all stuff with packagekit without consideration. Yast2 and zypper don’t need it, they use libzypp.

On 2013-01-03 01:26, zerum wrote:
> reddogg;2515102 Wrote:
>> I clicked applications - system tools and the app is named software
>> update. The icon has boxes with an circular arrow.
> That program is apper.

No, it is the gnome variant, it is indeed called “software update”.

Apper is the application officially preferred by the devs.

Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Apper is a notifier and updater for KDE that uses PackageKit (a package management API used on Gnome/KDE etc.), whereas the OP now claims to be using Gnome.

BTW, you don’t know how many openSUSE’rs are using it, any more than I do. I’ve used Apper for all regular updates from all my enabled repos on 12.2, and it hasn’t thrown up any issues including no conflicts with any package dependencies. That tells me openSUSE devs have fixed the problems with Apper/PackageKit since 12.1 release, where I didn’t use Apper (KDE only) to update anything.

Well, I recently installed the livecd 12.2 gnome and thought I should check for updates. The seg fault
occured when I was using Yast software management, this was after trying to use the other program.
I think I was deleting some of the package updates it proposed on the proposed action or
confirmation screen. I can’t remember exactly. the login failure occured when I was trying
to get exact info for vcvv about which program I actually used and was having problems with.
I’m not sure why it’s working now, but I haven’t had the login problem again, so far.
I’m thinking about trying the KDE version. Gnome3 is certainly different!

I have encountered this before only in the GTK yast. In my current install it has not happened but it used to be quite common. If it happens often the fix is to install the qt version of yast and remove gtk one (it will not install kde or etc, its very lightweight).

I’m not sure why it’s working now, but I haven’t had the login problem again, so far.

Ok, good. If you encounter them again I would start a separate thread only about that issue.

A simple way to update when using the gtk yast is shown in the below. When you have updates it will show them in an updates section in the bottom left below edit repositories. Then you click either only upgrade patches, or upgrade all (which will update unofficial packages you have added too). Nice huh. :slight_smile:
SUSE Paste

Thanks again! I didn’t know about qt Yast, that you could install that minimally. Cool! Also,thanks for the screen shot.
I think I need to study the setup guide and get up to speed with this stuff. I don’t want to burden people with dumb questions.
Thanks for your patience and help!