Software Management App Broken

The yast gui software managment program has broken on my leap15.1 machine. MATE desktop is used. After putting ROOT PW, into Software Management, I get messages below. I did not do anything abnormal with SW Manager in my last uses of it that I can recall. The error messages appear if I try to use SW Manager directly from the desktop menu or whether I open Yast then try to open SW Manager

"Internal error. Please report a bug report with logs.
Run save_y2logs to get complete logs.

Caller: /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require’

Details: Failed to load Module ‘PackagesUI’ due to: cannot load such file – cgi/core "

I have no knowledge of what any of this is trying to tell me. I need someone to provide advice.

Reboot didn’t fix problem. zypper still works file, I just downloaded updates and a new kernel and re booted without problem. I think problem is just with the Software Management Gui process.

I would remove and reinstall Software Management app using zypper but I do not recall the name of the process or whether there are more processes in software management. that would need to be deleted and reinstalled.

Perhaps there is a fix from above error messages.

Thanks for any assistance, Tom Kosvic

Can you share your configured repos?

zypper lr -d

Please enclose the output within CODE tags. (Refer to the ‘#’ button in the forum editor.)

linux-SUSE15:/home/tom # zypper lr -d
#  | Alias                    | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
---+--------------------------+-----------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
 1 | brave-browser            | brave-browser               | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://brave-browser-rpm-release.s3.brave.com/x86_64/                  |        
 2 | download.nvidia.com-leap | nVidia Graphics Drivers     | No      | ----      | ----    |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.1                          |        
 3 | google-chrome            | google-chrome               | No      | ----      | ----    |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                     |        
 4 | openSUSE_Leap_15.1       | science - leap 15.1         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/science/openSUSE_Leap_15.1/  |        
 5 | openSUSE_Leap_15.1_1     | graphics - leap 15.1        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.1/ |        
 6 | openSUSE_Leap_15.1_2     | games - leap 13             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/games/openSUSE_Leap_15.1/    |        
 7 | opensuse-guide.org-repo  | Libdvdcss Repository        | No      | ----      | ----    |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                      |        
 8 | packman.inode.at-suse    | Packman Repository          | No      | ----      | ----    |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.1/                        |        
 9 | repo-non-oss             | Non-OSS Repository          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/       |        
10 | repo-oss                 | Main Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/           |        
11 | repo-update              | Main Update Repository      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss                       |        
12 | repo-update-non-oss      | Update Repository (Non-Oss) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/                  |        

here is my listing. I made no recent changes to my repository list.

Thanks for any insights into this

This is about YaST > Software Manager. Do other YaST modules work? (no need to try them all, just a few).
And within the YaST > Software group. there are more. I assume Software Manager breaks, the same with Online Update and Repository Management?

yast Software repossitories works. Online Update is broken. I can’t copy/paste error message but error message says:

"patch: openSUSE -2020-545-1.noarch conflicts with libvlc5.x86_64<3.0.9.2-lp151.6.6.1 provided by libvlc5-3.0.7.1-pm151.6.5.11.x86_64

Option 1
following actions will be done (typed; not from a cut/paste)
install libvlc5-3.0.9.2-lp…with vendor change
http://packman.links2linux.de -> openSUSE
install libvlccore9-3.0.9.2-lp151…with vendor change
http://packman.links2linux.de -> openSUSE
8more

Option 2
do not install patch:openSUSE-2020-545-1-noarch"

I think I will take option one and change vendor back to openSUSE but I will wait to hear if you see anything else.
Random tests show other yast modules working

Is this the cause of Software Management issue?

thanks, tom kosvic

That is just a “nornal” way to tell you, well, what the message says. Something that you should take a decisiion on. That is not a complete brak down as you report above.

But it shows that there is something in your repos and what is installed from which one that is a bit glitchy.

When you change those packages to openSUSE, it could be that your multi-media, or other things you need Packman for will be broken. So you could do that, but I then would in any case do the “switch to Packman” again.

But I doubt that is the cause of your primary problem.

Can you provide the output from:

zypper dup -D --allow-vendor-change

As before, use code tags.

This won’t actually change anything on your system. It will just tell you what changes “zypper” thinks are needed. It might give some insight into what has gone wrong.

this is interesting. I went and took the vendor change option recommended by online update. It reinstalled vlc files from openSUSE instead of vlc repo along with a security update. After that online update went into regular Software Management app window. This functioned normally so problem is not with Software Management but just getting it loaded.

I tried Software Management yast app ifrom gnome, gnome classic, and plasma desktops and got same error message I posted in original post. So it is not a MATE issue.

Problem with Software Management still exists as you suspected. and the vendor change did not fix it. I found I can get SW Management running through online update app. I found problem exists on all desktops.

What files or packages containing SW Management can I delete and reinstall.? I can get on to package manager through online update so I can manipulate packages easier than with zypper.

Thanks again

Run the command that nrickert provided, and post here with the output.

Also best NOT to us the VLC repo unless you experiment. Get VLC from packman for largest codac support.

results from zypper dup -D --allow-vendor-change:

Retrieving repository 'graphics - leap 15.1' metadata ..........................................................................................................................................[done]
Building repository 'graphics - leap 15.1' cache ...............................................................................................................................................[done]
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...

The following 10 NEW packages are going to be installed:
  bleachbit-lang libgts-0_7-5 libmysofa0 libOpenCL1 libsane1 libxine2-pulse openal-soft-data openal-soft-makemhr openal-soft-tools openSUSE-release-ftp

The following 6 packages are going to be REMOVED:
  libavcodec56 libavutil54 libswresample1 libwxcode_gtk2u_wxsqlite3-3_0-0 openal-soft wxsqlite3-devel

The following 62 packages are going to be upgraded:
  blas-devel gnuchess graphviz graphviz-gd graphviz-gnome graphviz-plugins-core ImageMagick ImageMagick-config-7-SUSE lapack-devel libamd2 libbabl-0_1-0 libblas3 libcamd2 libccolamd2 libcholmod3
  libcolamd2 libdjvulibre21 libgd3 libgexiv2-2 libgmp10 libgphoto2-6 libgphoto2-6-lang libgraphviz6 libimagequant0 libjbig2 libjpeg8 libjsoncpp19 liblapack3 libmetis5 libopenal1
  libopenblas_pthreads0 libopenblas_pthreads-devel libopenjp2-7 libopenjpeg1 libOpenSceneGraph158 libOpenSceneGraph-devel libOpenThreads21 libOpenThreads-devel libpcre2-8-0 libqqwing2 libSDL-1_2-0
  libSDL2-2_0-0 libSDL2-devel libSDL_gfx15 libSDL_image-1_2-0 libSDL_net-1_2-0 libSDL_sound-1_0-1 libsuitesparseconfig5 libtiff5 libtiff-devel libumfpack5 libwebpdemux2 openal-soft-devel
  openblas-devel openblas-devel-headers OpenSceneGraph OpenSceneGraph-plugins patterns-games-games perl-PerlMagick pngquant sane-backends sane-backends-autoconfig

The following pattern is going to be upgraded:
  games

The following 29 packages are going to be downgraded:
  bleachbit libavcodec57 libavcodec58 libavdevice57 libavdevice58 libavfilter6 libavfilter7 libavformat57 libavformat58 libavresample3 libavresample4 libavutil55 libavutil56 libgl2ps1 libid3tag0
  libmpeg2convert0 libpoppler-qt5-1 libpostproc54 libpostproc55 libsox3 libswresample2 libswresample3 libswscale4 libswscale5 libvcdinfo0 libxine2 libxine2-jack sox vcdimager

The following 91 packages are going to change vendor:
  blas-devel                  openSUSE -> obs://build.opensuse.org/science                         
  bleachbit                   obs://build.opensuse.org/home:andrew_z -> openSUSE                   
  gnuchess                    openSUSE -> obs://build.opensuse.org/games                           
  graphviz                    openSUSE -> obs://build.opensuse.org/graphics                        
  graphviz-gd                 openSUSE -> obs://build.opensuse.org/graphics                        
  graphviz-gnome              openSUSE -> obs://build.opensuse.org/graphics                        
  graphviz-plugins-core       openSUSE -> obs://build.opensuse.org/graphics                        
  ImageMagick                 openSUSE -> obs://build.opensuse.org/graphics                        
  ImageMagick-config-7-SUSE   openSUSE -> obs://build.opensuse.org/graphics                        
  lapack-devel                openSUSE -> obs://build.opensuse.org/science                         
  libamd2                     openSUSE -> obs://build.opensuse.org/science                         
  libavcodec57                http://packman.links2linux.de -> openSUSE                            
  libavcodec58                http://packman.links2linux.de -> openSUSE                            
  libavdevice57               http://packman.links2linux.de -> openSUSE                            
  libavdevice58               http://packman.links2linux.de -> openSUSE                            
  libavfilter6                http://packman.links2linux.de -> openSUSE                            
  libavfilter7                http://packman.links2linux.de -> openSUSE                            
  libavformat57               http://packman.links2linux.de -> openSUSE                            
  libavformat58               http://packman.links2linux.de -> openSUSE                            
  libavresample3              http://packman.links2linux.de -> openSUSE                            
  libavresample4              http://packman.links2linux.de -> openSUSE                            
  libavutil55                 http://packman.links2linux.de -> openSUSE                            
  libavutil56                 http://packman.links2linux.de -> openSUSE                            
  libbabl-0_1-0               openSUSE -> obs://build.opensuse.org/graphics                        
  libblas3                    openSUSE -> obs://build.opensuse.org/science                         
  libcamd2                    openSUSE -> obs://build.opensuse.org/science                         
  libccolamd2                 openSUSE -> obs://build.opensuse.org/science                         
  libcholmod3                 openSUSE -> obs://build.opensuse.org/science                         
  libcolamd2                  openSUSE -> obs://build.opensuse.org/science                         
  libdjvulibre21              openSUSE -> obs://build.opensuse.org/graphics                        
  libgd3                      openSUSE -> obs://build.opensuse.org/graphics                        
  libgexiv2-2                 openSUSE -> obs://build.opensuse.org/graphics                        
  libgl2ps1                   obs://build.opensuse.org/graphics -> obs://build.opensuse.org/science
  libgmp10                    openSUSE -> obs://build.opensuse.org/science                         
  libgphoto2-6                openSUSE -> obs://build.opensuse.org/graphics                        
  libgphoto2-6-lang           openSUSE -> obs://build.opensuse.org/graphics                        
  libgraphviz6                openSUSE -> obs://build.opensuse.org/graphics                        
  libid3tag0                  VideoLAN Project (http://www.videolan.org) -> openSUSE               
  libimagequant0              openSUSE -> obs://build.opensuse.org/graphics                        
  libjbig2                    openSUSE -> obs://build.opensuse.org/graphics                        
  libjpeg8                    openSUSE -> obs://build.opensuse.org/graphics                        
  libjsoncpp19                openSUSE -> obs://build.opensuse.org/games                           
  liblapack3                  openSUSE -> obs://build.opensuse.org/science                         
  libmetis5                   openSUSE -> obs://build.opensuse.org/science                         
  libmpeg2convert0            VideoLAN Project (http://www.videolan.org) -> openSUSE               
  libopenal1                  openSUSE -> obs://build.opensuse.org/games                           
  libopenblas_pthreads0       openSUSE -> obs://build.opensuse.org/science                         
  libopenblas_pthreads-devel  openSUSE -> obs://build.opensuse.org/science                         
  libopenjp2-7                openSUSE -> obs://build.opensuse.org/graphics                        
  libopenjpeg1                openSUSE -> obs://build.opensuse.org/graphics                        
  libOpenSceneGraph158        obs://build.opensuse.org/science -> obs://build.opensuse.org/games   
  libOpenSceneGraph-devel     obs://build.opensuse.org/science -> obs://build.opensuse.org/games   
  libOpenThreads21            obs://build.opensuse.org/science -> obs://build.opensuse.org/games   
  libOpenThreads-devel        obs://build.opensuse.org/science -> obs://build.opensuse.org/games   
  libpcre2-8-0                openSUSE -> obs://build.opensuse.org/science                         
  libpoppler-qt5-1            obs://build.opensuse.org/graphics -> openSUSE                        
  libpostproc54               http://packman.links2linux.de -> openSUSE                            
  libpostproc55               http://packman.links2linux.de -> openSUSE                            
  libqqwing2                  openSUSE -> obs://build.opensuse.org/games                           
  libSDL-1_2-0                openSUSE -> obs://build.opensuse.org/games                           
  libSDL2-2_0-0               openSUSE -> obs://build.opensuse.org/games                           
  libSDL2-devel               openSUSE -> obs://build.opensuse.org/games                           
  libSDL_gfx15                openSUSE -> obs://build.opensuse.org/games                           
  libSDL_image-1_2-0          openSUSE -> obs://build.opensuse.org/games                           
  libSDL_net-1_2-0            openSUSE -> obs://build.opensuse.org/games                           
  libSDL_sound-1_0-1          openSUSE -> obs://build.opensuse.org/games                           
  libsox3                     http://packman.links2linux.de -> openSUSE                            
  libsuitesparseconfig5       openSUSE -> obs://build.opensuse.org/science                         
  libswresample2              http://packman.links2linux.de -> openSUSE                            
  libswresample3              http://packman.links2linux.de -> openSUSE                            
  libswscale4                 http://packman.links2linux.de -> openSUSE                            
  libswscale5                 http://packman.links2linux.de -> openSUSE                            
  libtiff5                    openSUSE -> obs://build.opensuse.org/graphics                        
  libtiff-devel               openSUSE -> obs://build.opensuse.org/graphics                        
  libumfpack5                 openSUSE -> obs://build.opensuse.org/science                         
  libvcdinfo0                 VideoLAN Project (http://www.videolan.org) -> openSUSE               
  libwebpdemux2               openSUSE -> obs://build.opensuse.org/graphics                        
  libxine2                    http://packman.links2linux.de -> openSUSE                            
  libxine2-jack               http://packman.links2linux.de -> openSUSE                            
  openal-soft-devel           openSUSE -> obs://build.opensuse.org/games                           
  openblas-devel              openSUSE -> obs://build.opensuse.org/science                         
  openblas-devel-headers      openSUSE -> obs://build.opensuse.org/science                         
  OpenSceneGraph              obs://build.opensuse.org/science -> obs://build.opensuse.org/games   
  OpenSceneGraph-plugins      obs://build.opensuse.org/science -> obs://build.opensuse.org/games   
  patterns-games-games        openSUSE -> obs://build.opensuse.org/games                           
  perl-PerlMagick             openSUSE -> obs://build.opensuse.org/graphics                        
  pngquant                    openSUSE -> obs://build.opensuse.org/graphics                        
  sane-backends               openSUSE -> obs://build.opensuse.org/graphics                        
  sane-backends-autoconfig    openSUSE -> obs://build.opensuse.org/graphics                        
  sox                         http://packman.links2linux.de -> openSUSE                            
  vcdimager                   VideoLAN Project (http://www.videolan.org) -> openSUSE               

The following pattern is going to change vendor:
  games  openSUSE -> obs://build.opensuse.org/games

62 packages to upgrade, 29 to downgrade, 10 new, 6 to remove, 91  to change vendor.
Overall download size: 41.9 MiB. Already cached: 0 B. After the operation, 26.7 MiB will be freed.
Continue? [y/n/v/...? shows all options] (y): 

Maybe tgere’s some clue there, but
I didnt make any changes with vlc repos for a month or so

Maybe there is. But I’m not seeing it.

Yes, “zypper” would like to change some of your packages. I was hoping to see a package that is related to Yast. But if there is such a package, I’m not noticing it.

I’m now thinking that your Yast problem is in a configuration setting somewhere. But I’m not an expert on that.

You saw that Yast online update worked. Well, it gave a conflict message, but that’s normal. It did not give the problem you had with Software Management. So I don’t think that problem is related to a conflicting package.

Any issues reported via the following?

rpm -V yast2 yast2-packager

rpm -V yast2 yast2-packager as root runs but returns no messages. Just moves to a new terminal prompt.

Would like to get this fixed but I will just leave it broken because I can get into Software Management through
Online Update. And zypper works as far as I can tell. It take a little longer but it works fine when I get into SMgmt.

Any idea what the original error messages refer to? I didn’t know ruby code was involved in yast programming.
Any idea off what packages I could reinstall?

thanks for all your efforts.

All, the Software Management is now working . I install the most recent set of updates a few minutes ago and rebooted and after these updates SWMgmt is working as before. I have no idea what did it but it now works as it should.

Thanks, all

Tom Kosvic

Ok, it was just worth checking for any inconsistencies.

I didn’t know ruby code was involved in yast programming.

YaST was rewritten in Ruby several years back…
https://yast.opensuse.org/documentation
https://www.phoronix.com/scan.php?page=news_item&px=MTM4NTI

Good to know. Thanks for the update. :slight_smile:

I’ve had some experience myself with breaking YaST2 inadverdantly while installing custom versions of certain Ruby Gems as root (which you either should not do with openSUSE, or use a Ruby version manager like rvm).
Shortly after breaking YaST, I figured out how to reverse the damage I inflicted on the system. See:

https://forums.opensuse.org/showthread.php/538587-YaSt2-Software-Management-internal-error-ReadRepositories-undefined-method-uniq!?p=2923012#post2923012
(Thread »YaSt2 Software Management internal error ReadRepositories undefined method `uniq!'«)

You live, you learn.