Slowroll new install - KDE updater showing 624 updates - YaST shows none

Hi. I installed Slowroll yesterday from the Tumbleweed ISO directory shown on the openSUSE web page for Slowroll, by disabling the Tumbleweed repos after the install and adding the three Slowroll repos per the directions on the same page.

Yesterday after the first boot, I ran YaST and it showed there were 32 or 33 updates, which updated without error. Today, what appears to be the KDE software updater, displayed a notification that there were 624 updates available. I ran YaST again, which showed no updates. When I selected YaST to update everything unconditionally (2,144 updates) before cancelling, I noticed for some of the version numbers marked in red, the installed version was newer than the ‘available’ version displayed. I don’t know if that is the result of the original install of Tumbleweed and before switching it to Slowroll.

I then took a screenshot of the YaST screen showing the Tumbleweed repos (in case I need to add them back in the future), then deleted them, leaving the Slowroll repos enabled with autoupdate. YaST still shows no updates.

I then rebooted the system and the KDE notification of the 624 updates went away. That particular setting is set to check daily.

Upon running YaST again after all this, it still shows no new updates, but the above referenced issue of the red version numbers newer packages installed vs available, on an unconditional update, remains.

Did deleting the Tumbleweed repos and updating the remaining repos, fix this problem?

As for the red version numbers showing a newer version installed than what’s ‘available’, I assume that would correct itself once another new version of the packages in question, is released, with the newer version being available.

Thank you.

1 Like

I think you are referring to this page:
openSUSE:Slowroll

Notice that it says:

Using Yast for this is just a mistake. The KDE updater is reporting what you would get with zypper dup

2 Likes

Thank you for the reply.

That was my bad. Having used SuSE in the past (first ever Linux distro I used was SUSE Linux Personal 8.2), I am used to using YaST to update.

I ran zypper dup to bring everything to Slowroll, but upon a reboot, when I launched my web browser, Vivaldi, there was no visible user interface. Just a title bar and a white screen, no menus, no text, no fonts.

I went into YaST, deleted the Slowroll repos, added Tumbleweed’s back in and ran zypper dup again. It upgraded close to 700 packages and upon a reboot and launch of Vivaldi, the user interface was restored. So I gather the downgrade to Slowroll caused something (a package or packages?) to make the user interface display blank.

I actually like the way zypper works, so I’ve decided to keep the system at Tumbleweed and use zypper dup to upgrade it from now on.

While you were doing that, I went ahead and installed Slowroll here (in a virtual machine).

I like it.

But I think I see where you ran into the problems mentioned in your first post in this thread. There’s an option during install, to use the online repos. I think you went with the default, which is to use them.

I chose not to use them. And the reason is because the online repos would have been the Tumbleweed repos rather than the slowroll repos. (The web page probably should mention that).

So I think your original install had many packages that were newer than what is in the slowroll repos, and those would then need to be downgraded to match. That’s why you saw so many updates and downgrades.

After install, I ran “zypper dup” and it updated 130 packages. Some of those were packages that were probably recommended by the install but not on the install iso (such as LibreOffice).

It seems to be working well. But I have not installed Vivaldi, so I might have run into the same problems if I tried that.

To eliminate the issue I had with the repos, the devs may want to consider releasing an ISO image that will install the Slowroll repos by default, rather than Tumbleweed’s.

But I agree, the web page should mention the repo issue (defaults).

1 Like

This project startet only some days ago and is in status experimental. Expecting a perfect distribution after that short time is…
But you may consider to work together with the devs and contribute with usefull ideas and help…

1 Like

@hui openSUSE has since updated the Slowroll page to reflect not starting the network during install, to avoid the Tumbleweed repos.

I erased Debian 12 from my desktop and installed Tumbleweed.

As I had Tumbleweed installed on two external USB SSD’s, I decided to switch one of them to Slowroll. Followed instructions on the Slowroll page to remove the existing repos/add the Slowroll repos and used zypper dup, which downgraded 119 packages, reinstalled five (including grub) and installed two new (including a new kernel).

The KDE About this System screen, now references Slowroll.

So far, so good and I wish openSUSE the best with Slowroll. Looking forwarding to it coming out of Experimental status to become a regular offering. :+1: