Slow video playing, videocard problem?

Hi everyone. I have a good CPU (Core 2 Duo E4500 2.20GHz) and 6gb RAM (do not ask my, why ))), but the only slow thing is my videocard: it`s GeForce 8500 GT with passive cooling. So in most cases I have no problems with video, 720p mkv movies are played fast with no problems. But sometimes on 1080p hdtv or 1280 H264 I get really slow playing. After some cheating with SMPlayer configuration I get it played “not bad” (still no good), and I found that my cpu is loaded about 30% at max by xorg and sometimes by smplayer. Does it means, that my problem is in videocard, or I can tweak it more to make it play ok? I am using OpenSUSE 11.1, manually compiled drivers from NVIDIA.

Try using VDPAU as discribed in this post. Your card should support this and it should enable you to play HD without a problem.

And that CPU isn’t that good… :stuck_out_tongue:
Did you try to overclock it? I got my E4300 running at 3Ghz instead of it’s normal 1.8Ghz but just adding a better cooler.

Thanks for the answer. Is it the same thing as selecting “vdpau” in output instead of “xv” or “gl”? If so - its already done, but result is not perfect, as I mentioned above. Sometimes frames are dropped. May be I need to avoid of using NTFS-3G partiton to store my video? Any other suggestions? I really hope it can be fixed )) P.S. I didnt have overclocked it because I am a silence freak )) I got the biggest and coolest towers from scythe and I am happy )), because I love music listening and I hate that “bzzzzzzzzzzz” )))
My opinion about CPU is based on WinXP experience. It wasnt a problem to start that movie under XP, but I dont like to work under it, since I moved on Linux (not only suse).

Yeah, native Linux partitions would probably be better but I do not know if this is the problem. Can’t test it since I have no way of outputting Full-HD content on my small little 17" monitor :wink:

If you’ve already done the VDPAU thing I’m fresh out of ideas.

Still thanks for trying ). I`ll try to copy that to the linux partition and try again.

Maybe try playing the video with VLC player? I do know some videos play better than others and busy scenes can result in choppy playback.

And my fan’s less noisy than the intel one… :stuck_out_tongue: No need to make you’re pc any louder. Just faster!

you also need to select the proper decoder. If you have H.264 video in that mkv, use mplayer -vc ffh264vdpau file.mkv

mplayer -vc help | grep vdpau

the above command to see all vdpau ddecoders

Hmmmm… Interesting, but from Linux partition it is played faster. I have 2 suggestions:

  1. My 1tb NTFS is almost full, so file can be just hardly fragmented.
  2. NTFS-3G is not so fast as they talk about it ))
    But the copy speed was excellent, it took about 2 minutes to copy 9gb file (as KDE says).

I have a problem with VLC, its failed to play that movie, failed to play some others, I dont know, how to solve it. After some of updates it even doesnt play ".ape" (monkey audio). It just exits with "Segmentation error" (hope this translation is correct, originaly its on native language). Reinstallation didn`t helps.

VLC is a terrible player and often very buggy, I recommend using something else

Thanks for the idea about proper decoder. I have just checked it from output: it takes h.264 version automatically, and its correct. But I have remembered your solution for future.

I don’t quite get what you mean by “it takes h264 version automatically”. Note that there are two ways in mplayer to play H.264 video

  1. standard way without acceleration/vdpau: mplayer file.mkv which will automatically use the ffh264 decoder. This is often very slow for HD 720p/i or 1080p/i content

  2. accelerated vdpau way: mplayer -vc ffh264vdpau file.mkv will do all the decoding on the GPU thus offloading your CPUs - works great for HD content

I am using SMPlayer, and I am not a console “fanatic” (ok, i like to work in console, but it seems a little freaky for me to use console icq, console media players and so on (i know, that mplayer will play it in a window :)), so I checked vdpau output in it`s configuration and started it from console to get some output. I found that it uses ffh264 for my movie, and (I hope) it means it plays movie as you described.
Am I right?

no, it does not play movies with acceleration if it uses ffh264, it needs to use ffh264vdpau - which part do you not understand?

  1. ffh264 -> no acceleration
  2. ffh264vdpau -> GPU acceleration

btw, you can add -vc ffh264vdpau in smplayer’s configuration -> Advanced -> Options for MPlayer tab

Ok, I get it, but I cant see any difference here: it plays "not bad" with vdpau output and with vdpau output + -vc ffh264vdpau. I cant beleve that SMPlayer is not wise enough to set this automaticaly. Hope, where will be the day, when Linux will be more comfortable for multimedia works than Windows