slow to load and boot, slow initrd

I am running 15.2 on an MSI 970 gaming motherboard with an AMD Phenom™ II X4 955 Processor and an nVidia GM107 [GeForce GTX 750 Ti] graphics card. It has 32gb of RAM. I also have 4 RAIDed hard drives partitioned for my system.

Recently I have noticed that when I reboot, it goes really really slow. Once it hits the grub screen (which takes maybe 3 minutes, but used to take only about 30 seconds or less), it may hang on loading initrd for 7 or 8 minutes.

To clarify on loading grub, when it loads, I see the little “Welcome to Grub” box on the upper left of my screen right away, but it hangs there with just that and a blank screen for about 3 minutes before it fully loads grub. Then after selecting the appropriate OS, it takes 7 or 8 minutes while it says it is loading the initial ramdisk.

However, once my system is up and running, everything runs fine. No issues really with speed when it comes to operating my system.

I am not sure where to start troubleshooting this. I suspect it has something to do with getting the initial boot code from my hard drive, and then loading initrd, but I don’t know for sure. It seems like if speed was an issue with getting information from the hard drive with initrd, then speed would affect my system performance once it is up and running. But everything seems to run normal once I am up and running.

Press esc while exiting to view the Terminal log and see what is hanging.

Any BIOS update recently? GRUB is using BIOS services to access disks, so if it suddenly became slow, something changed in BIOS.

Just rebooted again to test it…

The hang is happening right after the first load of the kernel, during the loading of initrd, so the terminal log hasn’t started yet at that point. When I tried to hit esc, nothing happens at that point. After initrd is loaded and the terminal log starts, I can hit esc and see what the terminal log is indicating, but by that time, whatever was causing the system to hang has already passed.

It did load a little faster this time, but still not fast enough compared to the past. It took 4 full minutes when I timed it from the point at which I selected the appropriate OS in grub until the start of the terminal log and loading of the OS. After that it took about 90 seconds to get to the display manager while it loaded the rest of the OS.

No, haven’t updated BIOS in a very long time.

grub2 update probably? Something has changed, it could be BIOS, it could be grub2 or it could simply be slowly deteriorating HDD that is less obvious when system is loaded (it also depends on disk layout; /boot is almost never touched during normal system run).

Better check your RAID - that is a symptom of a dead or dying raid drive.

Slow to load kernel and initrd started for me on several PCs around the time I was forced to switch to 64bit in order to keep using non-rolling releases of openSUSE, and other distros had also begun ceasing to provide 32bit x86 arches. This is where I wrote about it, as it was (and is) not limited to openSUSE.

Thank you, that was it. I have been running on a degraded RAID. Not sure what caused the event, but I think it was a power outage about a month ago. I should have checked that at the first.

Re-syncing my RAID partitions now, hopefully this will get everything running smoothly again.