Skype in 11.3


I’m trying to get Skype working, but the terminal printout indicates that I need (It was missing something before that one, but I found it. Can’t remember what it was.)

However, I can’t find it in YaST, despite having OSS, Non-OSS, Update and Packman repos installed.

So…what should I do? Anyone, suggestions please?

what does:

zypper wp

show in the terminal?

Also are you using a 64 bit system? I got skype working on my 64 bit openSUSE 11.3 by installing the 32 bit libraries for QT

Try reading this thread.

Thanks! Got it solved. I just went from one package to the next and it worked. Installing the 32-bit versions didn’t interfere with any of my 64-bit packages. Glad about that, 'cause I hate deinstalling stuff when I don’t know what else depends on it.

~@linux:~> zypper wp
Loading repository data...
Reading installed packages...
S | Name         | Type    | Version   | Arch   | Repository             
i | libqt4       | package | 4.6.3-1.5 | x86_64 | OSS                    
i | libqt4       | package | 4.6.3-1.5 | x86_64 | openSUSE-11.3 11.3-1.82
v | libqt4       | package | 4.6.3-1.5 | i586   | OSS                    
  | libqt4-32bit | package | 4.6.3-1.5 | x86_64 | OSS                    
  | libqt4-32bit | package | 4.6.3-1.5 | x86_64 | openSUSE-11.3 11.3-1.82

Thanks to you, too!

That 64 bit Skype works and is simple to install. But it crashes when I start a conference call. Anybody got any ideas about that?

Use the 32 bit version. just be sure you have the 32bit versions of the libraries.


Also upgraded from 64-bit 11.2 to 64-bit 11.3 and Skype did not work anymore. Googled it (a seg fault) and found this blog post. This fixed the problem for me:
zypper in libasound2-32bit xorg-x11-libXv-32bit xorg-x11-libs-32bit libqt4-32bit libqt4-x11-32bit libpng12-0-32bit

Let’s establish this now: yes, I am a noob. :slight_smile: My question, however, is this. If it takes the 32-bit libraries to make Skype work, why not just the 32-bit build of openSUSE?