skylake audio - not working

In an attempt to get sound working on an ASUS UX305C I cannot get past

“An error occurred during the installation of Sunrise Point-LP HD Audio”

The kernel module snd-soc-skl for sound support could not be loaded. This could be caused by incorrect module parameters, including invalid IO or IRQ parameters"

Which I understand is only a standard error message.

I’m not sure how to progress partly because I’m not sure where everything is with Skylake (articles on internet suggest Linux is still catching up)

However, I am running Tumbleweed updated to 29.03.2017


systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor 
   Active: active (exited) since Wed 2017-03-29 14:57:11 BST; 45min ago
     Docs: man:systemd-modules-load.service(8)
 Main PID: 386 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/systemd-modules-load.service

Mar 29 14:57:11 linux-tpra systemd[1]: Started Load Kernel Modules.

im on ASUS UX305CA (note the A) and my sound works out of the box with no setup.

sudo lspci | grep -i audio
00:1f.3 **Audio** device: Intel Corporation Sunrise Point-LP HD **Audio** (rev 21)

you say in your “attempt” you cannot get “past”. what is the attempt?

module snd-soc-skl does not show in lsmod

I dont have the expertise to fix your system but I have same?/similar system if you need info.

Grateful for any help you can give.

Curiously we seem to have the same model: In full glory it’s a ASUS Zenbook UX305CA-FB005T

I have tried to use YaST sound card set-up. That is what gives the error message

ive never used yast audio, and a review shows an entry for sunrise point and ‘not configured’. curiosly not even “play test sound” from yast menu works.
i checked the systemd service you showed. I get just the same.
have you tried multiple sources + test sounds? have you checked the kde sounds and video options (there are a lot)
I think yast audio is a red herring, and without further info I would assume your problem could be anywhere in the audio stack.

Your advice is simultaneously encouraging and confusing. You have encountered exactly the same issues however I do not have a working sound system. Or perhaps I don’t know that I do.

I will try a few things but would be grateful for further advice if needed.

Yes, it is… went through trouble shooting guide - sound now works

Thank you

My sound is also not working with the same symptoms. You found a solution, but it isn’t specific enough for me to follow that path.

Could you give me a hint where exactly to look?

Start here…