Sisfb framebuffer problem

Hi guys and thanks in advance
I have just upgraded to 11.3 and work in icewm (I have kde apps installed but no other desktops).

When I boot up the computer it gives me this console error message:

kernel: [time] sisfb: Mode 'none' not supported anymore. Using default.
kernel: [time] sisfb: Fatal error: Unable to reserve 16MB framebuffer memory
kernel: [time] sisfb: Is there another framebuffer driver active?

Apart from that I’m not exactly sure what the problem is. The computer isn’t displaying immediate symptoms to me. I checked the hardware sticky and when I have a few hours I can work through

but I don’t have that kind of time at the moment, so I wanted to check that that was the route I should be going down before I did.
I googled this stuff but everything seems to start from a knowledge base above mine and leaves me clueless.
Any help in figuring out where I go from here would be great.
Thanks again.

It suggests that another frambuffer fbdev (or vesafb) are active concurrently. It might be possible to pass a grub kernel boot parameter as outlined here:

I don’t have this graphics hardware, so I can’t really offer any further help with this.

Another thread I found:

vesafb conflicts with sisfb

Thanks, that sounds like a reasonable interpretation. I’ll check it out.

Sorry but I can’t really make any headway with those threads. I’m not at their level.
Any one else?

Have tried taking out vesa=… line in bootup. Tried without it, =normal nomodeset.

The error changes to

kernel: [time] sisfb: Mode ‘none’ not supported anymore. Using default.
kernel: [time] Console: switching to mono frame buffer device 100x37

I can’t offer as much help with this as I’d like. Does this affect your desktop performance? If not, I wouldn’t worry about it.

All I know about sis/sisfb has come mostly from googling:

sis(4): SiS/XGI video driver - Linux man page

Framebuffer - Gentoo Linux Wiki

It appears that to get sisfb support with KMS, the kernel needs to be built with the other framebuffer support disabled. (I don’t think you want to go down that route though - not a task for a new user).

The ‘nomodeset’ option can be used to disable KMS). Then it is also possible to specify the desired framebuffer with a grub boot option (as part of the kernel boot entries in /boot/grub/menu.lst) to set the framebuffer, display mode, refresh, and reserved memory (based on your card’s memory) like this


Thanks, I’ll try adding something along those lines.
It’s not the most drastic problem because it does run ok, just have to close an error window each boot.