sis191 not working

Having installed Suse 11.1 amd64, everything went well. The only problem is, the eth0 is not working, however, it is being recognized !! When i try to ping another pc, the error is network unreachable :\ In the network setup, the MAC is recognized, everything looks fine. The router has been adjusted to accept the gigabyte Ethernet card. If i use Windowzz OS, it works fine. Any help greatly appreciated :wink:

Hello SteffJay and welcome to the forum :wink:

“Not working” makes it difficult to debug your problem. We need some information, to guess what went wrong. Can you please post the output of the following commands entered in a console (su to root first):

prompt> ifconfig

prompt> route -n

prompt> lspci -nn | grep Ethernet

prompt> lsmod | grep sis

Hello Vodoo. Thank you very much for your speedy reply. :wink: Ok,

response from = ipconfig: bash: ipconfig: command not found

response from route -n = Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 0 0 0 eth1 U 0 0 0 eth1 U 0 0 0 lo UG 0 0 0 eth1

Response from lspci -nn | grep Ethernet = 00:04.0 Ethernet controller [0200]: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter [1039:0191] (rev 01)

and response from lsmod | grep sis = sis190 19788 0
mii 6024 3 asix,usbnet,sis190
sata_sis 6524 3
pata_sis 14012 1 sata_sis
libata 183376 5 ata_generic,pata_marvell,sata_sis,pata_sis,ahci

I hope this helps :expressionless:

Hello again

That was ifconfig (not ipconfig). Can you please try that one again?

Ok… Here you go:

eth0 Link encap:Ethernet HWaddr 00:0A:E4:86:7D:52
RX packets:18 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1685 (1.6 Kb) TX bytes:0 (0.0 b)
Interrupt:19 Base address:0xdead

eth1 Link encap:Ethernet HWaddr 00:80:C8:3B:16:90
inet addr: Bcast: Mask:
inet6 addr: fe80::280:c8ff:fe3b:1690/64 Scope:Link
RX packets:2761054 errors:0 dropped:0 overruns:0 frame:0
TX packets:2834341 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:170930538 (163.0 Mb) TX bytes:1530370016 (1459.4 Mb)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:72 errors:0 dropped:0 overruns:0 frame:0
TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5048 (4.9 Kb) TX bytes:5048 (4.9 Kb)

pan0 Link encap:Ethernet HWaddr C6:FC:38:48:FB:08
inet6 addr: fe80::c4fc:38ff:fe48:fb08/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:532 (532.0 b)

How strange!

It appears that you have 2 ethernet cards. eth1 seems to work (is that a sis191 too? ). eth0 is not configured. It has not even been assigned an IP number and there is no routing for eth0. So far eth0 cannot work. What happens when you go to Yast → Network Devices and configure eth0 ? Are you using DHCP or fixed IP numbers? What’s connected to eth0? Is this pointing to the internal or external network?

I am having to use a D-Link USB Ethernet device (eth1) to get on the net. However, this is not mine (i borrowed it) LOL. As for Yast / network devices; =

191 Gigabit Ethernet Adapter (Not connected)
MAC : 00:0a:e4:86:7d:52
• Device Name: eth0
• Started automatically at boot
• IP address assigned using DHCP

Got it!

Your USB Ethernet device is connected to your Modem/Router and gets an IP address via DHCP. As long as eth1 is connected you can’t configure eth0 for the same network. I suggest you try the following:

  1. Disconnect eth1 (temporarily) and connect eth0 to the modem/router.

  2. Try to configure eth0 again with yast. There is a slight chance it will work, but probably not. But it’s worth a try. If it does not work, then

  3. Reboot with eth0 connected. Then become root in a console and type:

prompt> dmesg | grep -i "00:04.0"

prompt> lspci -nn | grep -i bridge

prompt> uname -r

prompt> modprobe sis190
  1. Save the output of the above commands, re-install eth1 and post what you saw.

Reason: There have been some bugs in the sis190 driver. We want to see any error messages there might be from the kernel.

Hi Vodoo. I tried every which way i could, still no go. Here is the readout you have requested:

linux-ufm3:/home/server # dmesg | grep -i “00:04.0”

PCI: 0000:00:04.0 reg 10 32bit mmio: [fbffc000, fbffc07f]
PCI: 0000:00:04.0 reg 14 io port: [ff00, ff7f]
pci 0000:00:04.0: supports D1
pci 0000:00:04.0: supports D2
pci 0000:00:04.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:04.0: PME# disabled
sis190 0000:00:04.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
sis190 0000:00:04.0: setting latency timer to 64
0000:00:04.0: Read MAC address from EEPROM
0000:00:04.0: Unknown PHY transceiver at address 0.
0000:00:04.0: Using transceiver at address 1 as default.
0000:00:04.0: SiS 191 PCI Gigabit Ethernet adapter at ffffc2000033e000 (IRQ: 19), 00:0a:e4:86:7d:52

linux-ufm3:/home/server # lspci -nn | grep -i bridge

00:00.0 Host bridge [0600]: Silicon Integrated Systems [SiS] 761/M761 Host [1039:0761] (rev 02)
00:01.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] SG86C202 [1039:0002]
00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS966 [MuTIOL Media IO] [1039:0966] (rev 59)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
00:1f.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] PCI-to-PCI bridge [1039:0004]

linux-ufm3:/home/server # uname -r

linux-ufm3:/home/server # modprobe sis190

(nothing returned)

I hope this helps… :wink:

Possibly the sis190 driver is (still) broken in kernel

Have a look at these:

Bug 10994 - sis191 unknown PHY (004d:d021)
Bug 11073 - SiS 190/191 on ASUS P5SD2-VM dont detect link status / dont send traffic

Your kernel ( has NOT yet the patch required to make it work. The difference between yours and the latest kernel is:

me@host:~> diff sis190.c /usr/src/linux/drivers/net/sis190.c
>       { "Atheros PHY AR8012",   { 0x004d, 0xd020 }, LAN, 0 },

Probably you have to upgrade your kernel from the update repo and try again. There will still remain a bug that disconnecting the cable is not detected. Sorry, but at this point the end of my wisdom is reached.

I shall check them out vodoo, thanks for your input, very much appreciated. I hope i can get it to work.

Hi SteffJay

Did updating the kernel solve the problem with the sis190 driver? This would be good to know for others on this forum.

I have not tried it as i do not have a clue how to use this Yam thing or the syntax to upgrade it… :frowning:


I have this problem too. I didn’t know this until 2 days…
I tried to find a solution to this and got this:

go to and search for “sis-” (without ") you probably go find something like sis-*-default // openSUSE-11.1 Update

I don’t tested this yet because i’m running Windows now and going to see if openSUSE 11.2-M8 DVD have the same .exe in openSUSE 11.1 DVD.
I think the RPM works on Floppy/CDRW/USB or Windows Partition (Windows/C/Folder)

Sorry my English… Artea

It works! After I install the sis-default rpm, i went to Network Settings for reconf and worked… Type ‘rcnetwork status’ or ‘ifconfig’ or ‘ping <ip>’ on terminal and see the output… Just check Firefox!

Hi, i have similar problem.

I’ve just installed openSUSE 11.2 - 32bit.

While it was in Network Configurations (in the system installation) I unplugged the network cable because the installation was taking too long to end. Some error occurred.

After openSUSE installation, the internet browsing was not working so well. Using Mozilla, Google works fine, but every other site do not. HehhehEhe

I though reinstalling the system would solve the problem, but them i found these forum and this other page here:
How To Create The Sis191 Gigabit Ethernet Driver On Linux 2.6 | HowtoForge - Linux Howtos and Tutorials
(The how-to at “HowtoForge”, let’s say, is not for me. = ) HOUAhOUAHOauh)

go to and search for “sis-” (without ") you probably go find something like sis-*-default // openSUSE-11.1 Update

When I go there and search I cannot find the sis-*-default

i’ve had this problem too. fixed it by changing the MTU using

 sudo ifconfig eth0 mtu 1400 

although i need to input that everytime i log in. i’m still finding a permanent solution for it.


On my Acer SA90 I couldn’t get the sis190 to configure but I tried the suggestion by Badyorn and then tried configuring and the lan is now connecting.

In su:
ifconfig eth0 mtu 1400

Unfortunately the Wake on Lan doesn’t work, but I don’t think it worked before Suse.

Thanks to all who posted here as I now have a working openSuse installation.