shutdown does not power off

I installed openSuse 12.2 on a hp pavilion product name p6-2027de equipped with an AMD A6-3600 processor. Bios: HOL_706
I did the last online update via yast yesterday. The bootloader is grub2 integration the EFI partition.

The system does not power off when doing a shutdown (using the graphical interface and on the command line as well). A restart works properly. Booting into recovery mode via grub2 Advanced options … no success when shutting down.
Booting a knoppix live CD (7.0.3) and issueing a shutdown from there, powers off the machine.

I tested the 12.1 RC 2 in the past showing the same symptoms.
I did not test a previous version(11.4) of openSuSEtoo much because of graphic drives were not working as expected.

Did anybody made similar experiences ? On a similar PC ?
I tried: acpi=off … apm=power-off (picked up form knoppix’s /proc/cmdline … no success
Any suggestions ?

in yast - system - /etc/sysconfig Editor is


set to all?

Changed setting in /etc/sysconfig Editor

After restarting the system and testing a shutdown the system(hitting the F2 key) shows the same symtoms:
harddisk spins down, display remains active showing the shutdonw messages (this time the last line shows “System halted” wereas it showed “Power down” without the setting described above.
no keyboard action possible, i have to use the power button to turn off the system

Any other suggestions ?

What kernel have you installed?

Last year the ability to power-off was lost so used the following script,
it was placed in /home/<user_name>/bin/ directory, made executable, and called hhip,
this makes it executable from any terminal or the ‘Run command’ drop down box, with cmd hhip
however the root password is asked for before execution

# lost ability of normal power-down
# 120819 16:51

kdesu -c 'halt -hip'

This is the output from uname -a
Linux sixpack 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) x86_64 x86_64 x86_64 GNU/Linux

When using the scritp zo shutdown it ends up as described before.
Last message that can be seen on the display is: …Power Down

the only kernel i used in that series was kernel-desktop-3.4.6-2.9.1.x86_64 (31-Jul-2012),
a jump was then made to kernel-desktop-3.4.6-5.1.x86_64 (01-Aug-2012)
so you are using a kernel i’ve had no experience with

however there are two other areas where you can effect the logoff process

  1. -system settings --session manager —general, —default leave options, --on login


  1. -system settings --login screen —shut down
    my setting here are
    -local: everybody
    -remote: nobody
    and under —miscellaneous select the boot manager in use

if none of the above help, the only other suggestion is to upgrade to a newer kernel

Does HALT=“poweroff” in /etc/sysconfig/shutdown make any difference?
I’ve seen a bios that will never shutdown with a default “auto” setting.

For general interest purposes related to the thread’s subject matter – as per the release notes, be advised that:

5.4. systemd: System Shutdown

To halt and poweroff the system when using systemd, issue halt -p or shutdown -h now on the command-line or use the shutdown button provided by your desktop environment.

Note: A plain halt will not shutdown the system properly.

I update to lastest kernel version via Online update and tried the settings described for /etc/sysconfig/… still the same situation.
Shuting down from the command line does not power off … neither shutdown -h nor halt -p. I tried init 0 …

Is anybody running opensuse on a similar computer ?

I don’t have a similar system but I have similar problem.
This is not an update, it’s a installation from KDE live CD.

On 01/06/2013 02:46 PM, gerbosan wrote:
> I don’t have a similar system but I have similar problem.
> This is not an update, it’s a installation from KDE live CD.

-=WELCOME=- new poster!!

it is much better (in these openSUSE forums) to originate a new
thread…in it give us the specifics of your operating system, version,
desktop environment and version (if applicable), your hardware and the
symptoms as you observe them…

and, if this is your first day in Linux or 20th year, that is important
for the helper to know so the level of detail of the answer might be
closer to what you need.

and, then be a little patient…we have volunteer user helpers all
around the earth…at any time most may be asleep of tending to that
thing called ‘life’…


I don’t have a similar system, but a Laptop HP 6730s, and until
a upgrade from 12.1 to 12.2 I have the same problem.

uname -a
Linux 3.4.11-2.16-desktop #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux

In /etc/sysconfig/shutdown :

I give up!

Updated today to KDE4.10 on laptop and pc

After install finished via yast, normal reboot/ power off did not work

In terminal, cmd as root ‘reboot’ or ‘poweroff’ did

Linux 3.7.6-2-desktop #1 SMP PREEMPT Tue Feb 5 15:27:05 UTC 2013 (d5cefdd) x86_64 GNU/Linux