Shutdown Dialog

When I hit ctrl-alt-del, I get a dialog presenting several options; I can Logout, Turn Off Computer or Restart Computer. Normally, the Restart Computer option has a drop-down listing the boot option I want when the machine restarts - Windows, Linux, and so on.

These options have disappeared. The moment I click on the Restart button, I go into a 30-second countdown to a complete reboot, without being able to choose which OS I want to boot into.

The only thing I have changed was switching the Updater Applet to use the Zypp backend instead of Packagekit. I had been getting updates manually prior to this, because the applet would never check for them. Immediately following this change, the boot options disappeared from the dialog.

I’m thinking these issues are not related, but who knows? Where can I configure the Restart dialog, or what resource file does it use to determine what boot options to use?

You don’t say which desktop you are using. These facilities are still available in KDE3 but are yet to be implemented in KDE4.

I use KDE-3.5.10 so I have not noticed this. Is this really the case?

… anyway, this can be done by using “grubonce” from the command line, and even creating an icon/script from one’s desktop.

There is a wiki here (but unfortunately has server problems today)

There was a heated discussion with a Gnome user, some time back, who was very perturbed wrt gnome functionality and this feature. Here is a link to that thread in case there is anything there that you might find of use: Why is GNOME missing features? - openSUSE Forums Users can get “heated” during technical discussions, and hopefully the less than polite posts in that thread will not put you off, … there is some useful technical information buried there.

I’ve used grubonce a number of times, when remotely maintaining my mother’s PC (where her PC is located in a different continent from where I live).

john hudson adjusted his/her AFDB on Tuesday 12 May 2009 07:26 to write:

> You don’t say which desktop you are using. These facilities are still
> available in KDE3 but are yet to be implemented in KDE4.

They work fine for me on:

K Desktop Environment
Version 4.2.3 (KDE 4.2.3) “release 116”

To the OP, have you tried a different theme?

Has anything changed in the login manager?

You can also have a look in Yast>System>sysconfig
editor>Desktop>Displaymanager_shutdown and others to see if anything has
changed, make sure that the System/Security/Permissions/PERMISSION_SECURITY
are set to your requirement.



Nullus in verba
Nil illigitimi carborundum

I’m using KDE 4.1. The option to boot into the OS of my choice has been there since installation; it suddenly disappeared.

It is, however, now back again. When I checked “Configure Desktop,” under shutdown options the boot manager was set to “None.” When I switched it back to “Grub,” I got my OS selections back.

I have been running into many problems like this with KDE 4; it seems as though the configuration files get stomped on, either by an external process or by one another. It’s like trying to smooth a bubble out from underneath a sheet of wallpaper; you work it for a while, and it just appears again somewhere else.

Problem solved - for now. Who knows what else the configuration program managed to trash while fixing this problem?

P.S. I would have replied sooner, but the website has been down.

There is a good consensus that KDE 4.2 works much better than 4.1. I’d consider upgrading.

Been burned too many times by immature releases. Far too often, the new version is just a different collection of bugs, not an improvement.

For now, problem solved, assuming KDE doesn’t cruise across it’s own tow line again.

Then the general consensus that 4.2.* is leagues ahead of 4.1.* must be a load of old Salty’s tales.
Time to weigh anchor and cruise ahead man, get 4.2

Exactly the same thing was said about 4.1 vs. 3.5.

And I see people are already beginning to say exactly the same thing now regarding 4.3 vs. 4.2.

The whole idea of “consensus” is antithetical to the open source philosophy. And I very much doubt that it even exists in this case.

I’ve got work to do. Chasing the shiny is a waste of time for me. If you enjoy spending endless hours trying to make your work environment do simple tasks that professional OSs and desktops do right out of the box, feel free. I don’t have time.

I’ll conclude by noting that no one has come up with any answer to my original question here; I cobbled together an ad hoc solution on my own that doesn’t explain the underlying problem that actually caused this difficulty, meaning whatever it was is still lurking out there waiting to happen again. This sort of thing does not bode well for the future of Linux. People have lives, and they would rather spend them getting things done instead of frittering them away swatting bugs.

Its quite possible the answer is not known by anyone who has read this thread. Intermittent/random problems are always very very difficult to track down.

You could try raising a bug report: Submitting Bug Reports - openSUSE but given the problem has not reappeared will IMHO make it difficult to sort. It might be best to raise the bug report next time you spot the problem, and also provide an indication as to what were the last KDE updates you performed … maybe that will provide some clues.