Shutdown Bottom - set time for shut down automatically


if I click on the shutdown bottom (in my lower panel) I get an new window to choose if I really want to shut down or restart or suspend or hibernate. Under that alternatives there is an text that says: “…] The system will automatically shut down in 60 seconds.”

Why is the text “60” not running down like a countdown?

Can I set another (shorter) time for the automatic shutdown (10 seconds)? If so, where?

Or shut I just make another bottom to shut down immediately?

(Hope this is the right sub forum.)

Greetings pistazienfresser

I use (normally) OpenSuse/SUSE Linux
Release 11.1
Kernel Linux
Gnome 2.24.1

Sorry the countdown goes first in steps of 10 seconds - I was not patient enough.

But changing/shortening the time for the automatic shutdown would still be an lovely feature to me.


Linux is a multi-user OS. It takes this time to warn other users on the system, give the opportunity to shut down apps and sessions properly. AFAIK shutdown first looks for logged in users, if none performs the shutdown procedure instantly. If, for example, you are logged in in the console (Ctrl-Alt-F1) and on a desktop (Ctrl-Alt-F7), and you tell the system to shutdown from the desktop login, after 60 secs the system will tell you there’s a user logged in on the console, giving you the opportunity to force the logout of that user, and continue shutdown procedure, or to cancel the shutdown. This will allow you to first stop/save anything the user in the console was doing.
I’ve searched the /etc/sysconfigeditor in Yast to see if I could find an option to set this variable of 60 secs. No luck so far. On my laptop I just hit the power button, shutdown menu comes up, shut down, done. Does not use the 60 secs, unless I’m logged in on the console or a second desktop session.

pistazienfresser wrote:
> But changing/shortening the time for the automatic shutdown would still
> be an lovely feature to me.

i’ve never seen a countdown to shut down associated with any button
on any Linux desktop, ever…

did this strange thing “just start” or did it come immediately after
your FIRST install of openSUSE 11.1 on that box (and, why are you
using 11.1 and not 11.2??)

  1. did you get your install image from ? (then where?)
  2. did you check the md5sum of the downloaded iso?
  3. burn the disk as slow as you can?
  4. use good media?
  5. do this before install attempt?

if you answered “no” (or “don’t know”) to any of those then see the
following cites, and if we can help further, please ask because we
want you to be successful:

did you install anything after the initial install to ‘customize’
your desktop? what?

does the countdown go away if you turn off desktop effects?


Change Shutdown/Restart countdown timer? - Ubuntu Forums

Thanks a lot.

The real power bottom on my laptop works at once but when restarting I get some funny text about ICElisteners or something like that.

As I am sometimes a bit confused what I really want to do or have
a time to think again is the right thing for me.
But I think I need not 60 seconds for this.
Maybe I try to make my own bottom with the shutdown command from the console and 5 or 10 seconds.
But giving the bottom the root privilege/power or include it in a special group may be needed.

What do you think about it?


pistazienfresser wrote:
> ???
> ‘Change Shutdown/Restart countdown timer? - Ubuntu Forums’
> (

ok, so…what is your point? maybe that i don’t know everything there
is to know in Linuxland ??

hey, you ain’t telling me nothing new…i’ve only been around Linux
since about '98 and only using it only since about 2001/2/3 so i well
aware there are LOTS of folks that know stuff i don’t have a clue on…

evidently if you (as a Gnome user) and all the folks at BrownTown know
about it, then it must be Gnome thing, huh?

i used Gnome for a while…on Red Hat and something else…i
forget…if it had a shutdown timer i do not remember it…but, i’m
pretty sure if it did i may have often popped a term and su’ed in a
shutdown -h now


pistazienfresser wrote:
> The real power bottom on my laptop works at once but when restarting I
> get some funny text about ICElisteners or something like that.

using the real power button on your laptop is not a good choice (it is
a RUDE kill and cuts power with files open…don’t do it…

you could make a script like this:

# use to shutdown my laptop, safely

shutdown -h now

name it (say) ‘shut’, make it executable and place it in your path…

then you could call up a run command with Alt+F2, type in

gnomesu shut

it would ask for root password and then shutdown…

well, thats kinda complicated and too much typing every time…lets
see what the real gurus say…


Just click the count down button and it will start the shutdown/logoff/restart sequence immediately.

Thanks, really, that’s something like the way I thought of. In my Gnome there is an opportunity to add an “Coustom Application Lancher”.

If I replace “now” with a given time (I thought of 5 sec) it would be something like I wished for. But if I could not stop it at all (maybe I am a bit microsofted?), I would prefer the way my added “shutdown” botton in the gnome panel works now - clicking two times to shutdown all the laptop or click once and let it running 60 sec more…