Shaky screen graphics

I recently installed the latest opensuse 11.1 and updated it. I have just finished successfully installed ATI’s drivers for my Radeon 4850 via the .run file and some suggestions I saw on this forum. There is a problem however, my screen is shaky. As soon as the graphics drivers kick I can tell the difference. Even right at the user select screen things look funky. For one thing the screen size is off, it doesn’t fill up the whole screen like it did before the driver installation. I don’t know if its a super fast flicker or what the deal is, but the graphics on screen look like they are wiggling or shaking slightly.

Did the “aticonfig --initial” so something to my monitor settings in xorg.conf? I didn’t want to look around and experiment to much, because I didn’t want to damage my monitor.

My monitor is an Acer p244w 24’ 1080p 16:9 LCD. It was in the monitor list in the yast display configuration thing.

Any suggestions? Things to look for try etc.

Will this problem hurt my monitor???

It won’t damage your monitor by playing. Did you run sax2 in single user non graphic mode after the install?
I found this fixed most of my problems.
Also, the ati repo should have the latest files.

I did what you suggested and that helped, sort of. Sax2 set my resolution at 1280x1024 by default. That fixes my shaky screen problem and everything seems to work fine, even hardware acceleration. But whenever I change the resolution to 1080p I get the shaky screen. I even tried 1650x1050 but when I clicked the test button, I got a black screen with artifacts on it. My PC became frozen and I couldn’t alt+ctrl+F1 or anything like that. Another noggin scratcher is that when I’m logging into my user account and KDE is loading, my screen blinks black several times, but when I log in as root it doesn’t blink!

It’s all so confusing :frowning:

I guess I just have one simple question. How do I specify what refresh rates to use for a particular resolution? All I can figure out how to specify the overall maximum and minimum refresh rates.

I found out that it is definitively the refresh rates that are the problem. In Vista when I’m using 1080p my monitor’s horizontal and vertical refresh rates are 67x60. When I try to run 1080p in Linux, the rates are 28x50. In the sax2 settings for my monitor all the information is correct, but the correct frequencies are not being applied to 1080p. 1650x1050 works perfectly though.

You may already know this, but have you looked at the file /var/log/Xorg.0.log to see what happened when your graphics driver was being loaded at startup. It can contain a lot of useful information for trouble shooting. There is an explanation of the message markers (ie the information source of each msg) at the top of the file. You can see what settings were detected from your monitor, what settings were used from xorg.conf, and which modelines for different resolutions and refresh rates were selected/rejected.

Valid modelines for required resolutions can be copied from that file and placed in xorg.conf (Modes section) to achieve the desired refresh rates, if they are not already available via the desktop’s control centre utilities. You would also need to add any new resolutions to the Screen section in xorg.conf. Make sure that any modelines added in that way are for refresh rates supported by your monitor, or you might damage it:O!

You can also edit the range values in the Monitor section of the config.sys, to limit refresh rates available to the system.

If you have any further questions on the above, please include a copy of the relevant lines from xorg.conf and/or Xorg.0.log in the post:).

Here is my xorg.conf and here is my Xorg.1.log and here’s my monitors specs.

I greatly appreciate the help thus far. All this Xorg stuff is greek to me, I’m afraid of hurting my monitor so I don’t want to experiment too much. Sorry about the sendspace links, but I cant attach files here.

I have a similar problem here with the login screen and upon loading the session. The user selection splash is somehow scrambled and before loading the actual session, it puts up a screen with lots of strange graphics, that might be in some cache somewhere.

I am using a NVIDIA Geforce9800 GTX, openSuse11.1 (64bit) and dual screening on an Asus VH222 with 1920×1080 and a Sony 19" (don’t know the model now) with 1280x1024.

Also it seems like Xinerame of Sax2 doesn’t work…because upon test dual screen shows up, but after restarting the x.server everything is like before.

The only error I have (in Xorg.0.log) is on loading non existing fonts in /usr/share/fonts …

Basically everything works after configuration with the NVIDIA X configuration tool, but I still have this very ugly screen scrambling upon login.

Thanks for any help.


Your files downloaded ok and were readable, thanks for that. Don’t be put off by the apparent complexity on first sight - it looks more difficult than it is;). From your Xorg.1.log, I see this piece of information:

(II) Setting vga for screen 0.
(**) RADEONHD(0): Depth 24, (--) framebuffer bpp 32
(**) RADEONHD(0): Selected ShadowFB.
(II) RADEONHD(0): Unknown card detected: 0x9442:0x1002:0x0502.
	If - and only if - your card does not work or does not work optimally
	please contact [email][/email] to help rectify this.
	Use the subject: 0x9442:0x1002:0x0502: <name of board>
	and *please* describe the problems you are seeing
	in your message.
(--) RADEONHD(0): Detected an RV770 on an unidentified card
(II) RADEONHD(0): Mapped IO @ 0xfe8f0000 to 0x7fb6afb84000 (size 0x00010000)
(II) RADEONHD(0): PCIE Card Detected
(II) RADEONHD(0): Getting BIOS copy from legacy VBIOS location
	SubsystemVendorID: 0x1002 SubsystemID: 0x0502
	IOBaseAddress: 0xb000
	Filename: B3B50102.103
	BIOS Bootup Message: 
Wekiva RV770 B50102 Board

You should follow that up using the link given there. If you then get a response there, it may be useful to others if you could post back here with the outcome or any useful advice.

Also note the following warning messages scattered throughout the log (extra lines to help you locate them):

(II) Loading /usr/lib64/xorg/modules/updates//extensions/
(II) Module glx: vendor="X.Org Foundation"
	compiled for 7.4.0, module version = 1.0.0
(==) AIGLX disabled
(WW) fglrx: Force AIGLX enabled
(II) Loading extension GLX
(II) RADEONHD(0): AtomBIOS requests 20kB of VRAM scratch space
(II) RADEONHD(0): AtomBIOS VRAM scratch base: 0x7ffec
(WW) RADEONHD(0): rhdAtomAllocateFbScratch: FW FB scratch area not located at the end of VRAM. Scratch End: 0x84fec VRAM End: 0x10000000
(WW) RADEONHD(0): RHDCSInit: No CS for R600 and up yet.
(==) RADEONHD(0): Backing store disabled
(==) RADEONHD(0): Silken mouse enabled

As I personally don’t have a radeonhd card, I cannot help much further with it, but there are others here who do. Anyway I hope this helped to move you a step nearer a solution;).

If you you don’t see a response for your particular card soon, I suggest you start a brand new thread explaining your problem. Sorry I don’t have that card, but NVIDIA cards seem to be popular with openSUSE and users in this forum:).

Just noticed a possible problem with the Modeline in your xorg.conf

Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1920x1080" 138 1920 1968 2000 2080 1080 1083 1088 1110 -hsync -vsync

It probably should contain:

  Modeline 	"1920x1080" 138.50 1920 1968 2000 2080 1080 1083 1088 1110 -hsync -vsync

Copy xorg.conf to your home directory for backup in case you make errors. Then edit xorg.conf (as root) and change the 138 to 138.50 as above. Restart your system. Tell us what happens:).

Sadly that did nothing. I did notice something new however. In my monitors menu it will tell you what the input information is the resolution sync etc. When I’m running 1650x1050 the monitor says that, but when I run 1920x1080 it says that the input signal is 1920x540…

There seems to be something wrong with the format of the Modeline in the xorg.conf you provided. Did you generate the Modeline or copy it from somewhere?

Edit it again to make sure that there is only one real blank character between Modeline and “1920x1080” (and no tabs anywhere) as in:

Section "Modes"
  Identifier   "Modes[0]"
  Modeline "1920x1080" 138.50 1920 1968 2000 2080 1080 1083 1088 1110 -hsync -vsync

Don’t rerun Sax2, because it will redo the xorg.conf and overwrite it if you save any changes.

BTW do you really need all those resolutions on the Modes lines in the Screen section of xorg.conf. I only ever have two or three so it is easier to read and change. You can delete the unwanted ones - for starters nobody uses anything below 1024x768 these days.

After edit, restart the system.

You should also try commenting out the modeline and restarting as before. Do this even if Sax2 generated it;).

#  Modeline "1920x1080" 138.50 1920 1968 2000 2080 1080 1083 1088 1110 -hsync -vsync

I ran an unsupported (by openSUSE) video chip for ages with four Sax2-generated but completely unusable modelines, initially commented out and then removed.

Xorg will use built-in modelines that meet the parameters given in the xorg.conf (see Monitor and Screen sections), but some may not display properly on the monitor. You may get a range of resolutions at different refresh rates for each. You can then manipulate that range through the config.sys, and then select/change resolutions at different vertical refresh rates using the desktop utilities.

Apologies for repeating stuff you may know, but I found this area of linux to be a time-consuming PITA until I focused on how the various elements interact and why different resolutions can appear at boot time, xorg start, and desktop start. It’s also easy to forget to change dependent parameters in the config.sys, and then wonder why the last change had no effect - a quite common problem:.