Severe Problems with Radeon R7 260X and xorg Drivers

My Radeon 5770 died so I purchased a Radeon R7 260X and immediately started having problems in openSUSE 13.1 x64 with the latest xorg repo added. The monitor would go black at random, trying to get to a console wouldn’t work, and ctrl+alt+backspace or ctrl+alt+del did nothing, which meant I had to cut the power to the machine. I tried reinstalling the entire OS and had the same problems with the xorg drivers which came off the DVD and tried the ones which came through the SUSE update repos. When running a 3D application as a test, the whole computer crashed upon trying to exit the window. When reinstalling the OS from the DVD, small artifacts followed the mouse pointer around the entire time in YaST. Is this card not supported?

It turns out that other people are having problems with Radeon R7 260X cards due to a firmware bug causing black screens, and more than one brand is mentioned as having this problem. A black screen is the first thing that went wrong when I booted up my machine with the new card installed. The below thread possibly provides some answers to the problems I was having, but I am still at a loss for why my whole system locked up after trying to exit a 3D application, and this was reproducible every time. Unless there is some other reason as far as xorg not playing nice with the Radeon R7 260X, I wouldn’t recommend buying this card unless it comes with the updated firmware or you are technically competent enough to update it yourself (considering you may have to flash a different vendor’s firmware onto the card), and even then, I read a few accounts of people continuing to get black screens. However, I wouldn’t take that as proof that the problem was indeed not fixed.


supported cards are listed in the file /var/log/Xorg.0.log on your pc

the AMD Radeon™ R7 Series Graphics do not appear to be there

the card is support by the proprietry driver,

AMD Catalyst Packages
Name AMD Catalyst™ 14.4 Proprietary Linux x86 Display Driver
File Size 117 MB
Revision Number 14.4
Release Date 23May2014
Download Link

can only suggest you give it a try