Settings for laptop monitor with external VGA display - Opensuse 11.3-Gnome

Hi to everyone!
I’d like to solve a little problem that I have connecting my notebook with an external VGA monitor.
Everything seems to work fine, but when I close the laptop monitor, also the external monitor shuts down.
I’ve tried to find different energy-saving setting for laptop display and external monitor. with no luck…
My video card is an ATI Radeon Xpress 200M. On the ATI website there is no catalist control center for linux. (It would be very useful). So, for now, I can only use the display options on the panel.
Please, note that I use Opensuse 11.3 with Gnome.
I accept all of your suggest!

I don’t know about GNOME but in KDE in the Power Management settings we can can tell it so when the laptop lid is closed to do nothing (don’t turn off screen/sleep/etc…) - I would assume there would be something similar in the GNOME power management settings. AFAIK this will leave both screens (laptop and external monitor on). If you wanted to still turn off the laptop screen when the lid is closed but leave the external monitor on I wouldn’t know how to do that.

I’ve solved my problem. Referring on this website, open terminal and past those two instructions, sudo is not necessary:

gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_ac “nothing”

gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_battery “nothing”

Now, going on energy saving settings It’s possible to set “Do nothing” when the lid is closed. Now, closing the lid, the laptop monitor shuts down an the external vga screen not, as I dreamt!

You can use the gconf-editor to do the same thing… Did you try the
Gnome power management settings to do the same thing?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3:02, 2 users, load average: 2.42, 0.66, 0.35
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.26

Yes, I do, but in power manager setting there were no “do nothing” option, after putting those two commands n the terminal the “do nothing” option appeared.

Now it works fine, so I can say that the problem is solved!