Setting up vsftpd?

Hi, I want to share some files on the LAN with a windows user, so I thought ftp would be easiest.

I downloaded vsftpd and system-config-vsftpd, so that I could set it up in an UI.

But how do I start it?

Getting this error.

linux-vu9d:/home/lasse # system-config-vsftpd
/usr/lib/python2.6/site-packages/gtk-2.0/gtk/ GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)
/usr/share/system-config-vsftpd/ GtkWarning: cannot open display:
gnome.init(“system-config-vsftpd”, “1.0”)

Have a read here


That is commandline, I really wanted to go graphical…

I get into trouble with the guide there when I have to edit vsftpd.conf, I can’t get the rights to edit it.


How do I open it? I tried via terminal.

linux-vu9d:/home/lasse # kdesu kwrite /etc/vsftpd.conf
kdesu: cannot connect to X server

Went over to proftpd as I have used that before, however, I get the same message there when I try to edit a file.

I know this may be a dumb question but can we confirm that X up and running on the machine?

The reason I ask is that I’ve run into this type of message before but usually only when either I’m at run level 3 (i.e., no X running) or when I’m ssh’ed into another machine and forgot to pass the -X flag to ssh when I connected. The -X tells ssh to forward X connections to my local machine.

lasse@linux-vu9d:/etc> startx
xauth: creating new authority file /home/lasse/.serverauth.19479

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

Used kdesu kwrite instead. No issues at the moment :slight_smile:

Humm, any thing interesting (errors, warnings?) in /var/log/Xorg.0.log?

Nope, but please see.

How do I know if I have the correct videodrivers? - Page 2 - openSUSE Forums

They might be related?

Getting it again now :S

linux-vu9d:/home/lasse # kdesu kwrite /etc/shells
kdesu: cannot connect to X server

lasse@linux-vu9d:~> xhost +
access control disabled, clients can connect from any host
lasse@linux-vu9d:~> kdesu kwrite /etc/proftpd.conf

Then it works!

Try su then kwrite /etc/vsftpd.conf


linux-vu9d:/home/lasse # kdesu kwrite /etc/vsftpd.conf
kdesu: cannot connect to X server


Never had so many issues installing a simple ftp server, this is brainbreaking.

Wuhu, I got it working now, the local test atleast :slight_smile:

lasse@linux-vu9d:~> kdesu kwrite /etc/vsftpd.chroot_list
lasse@linux-vu9d:~> ftp localhost
Trying ::1...
ftp: connect to address ::1: Connection refused
Connected to localhost.
220 Welcome to the s3maphor3 FTP service
Name (localhost:lasse): ftpadmin
331 Please specify the password.
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.

Great all you have to is check with a ftp client filezilla is really good


Trying to figure out how to chmod the /srv/ftp so I also have the read/write access.

And also trying to figure out how to set up logs. My friend (on a LAN) can’t connect, and I can’t see any logs.

I activated logging via the graphical administrator tool and they should have been put in /var/log/, but they’re not present.

If you set it up as in the guide you should be able to get access:
vsftpd on Suse Linux pro

create a FTP user group

groupadd ftp-users

make the new FTP root dir accessible for ftp-users

chmod 750 /srv/ftp
chown root:ftp-users /srv/ftp

add new ftpadmin user to group and set its home dir to the FTP root

useradd -g ftp-users -d /srv/ftp ftpadmin

set password of new ftpadmin user

passwd ftpadmin

give read/write access to the FTP root dir

chmod 770 /srv/ftp

I see how the access is given to user “ftpadmin” but what do I need to edit in order for user “lasse” to get same access?

Ok the easiest way is to create a user lasse in a console as su:
useradd -r lasse then
passwd lasse

Now go to kicker > applications > system > file manager > file manager - super user mode
Brows to /srv/ftp and right click on folder and choose properties > permissions > advanced > add entry > named user and select lasse ftom the list

ps Heter lasse Lars :wink:

Just changed it to Read and write for “Other people” the last of the three entry thingies there are.