Setting UP Sendmail

I am having problems getting sendmail working. I just want to be able to send out e-mails from programs like Asterisk and PHP scripts. I don’t want to set up a full e-mail server.

So far all the searches I have brought up tell me it is hard but not how to do it.

Help please


You should not need to do anything to be able to send mails outside - as long as postfix is up and running.

Thread moved to Network/Internet

make sure postfix is enabled.

turn it on now:

(as root)
/etc/init.d/postfix start

make it turn on persistently:

(as root)
chkconfig postfix on

You should be able to route mail through localhost to your destination. Just tell your php scripts that your mail relay is at localhost (

Note: Keep in mind - many email servers will check for PTR records to ensure mail is not spoofed. PTR’s are basically reverse DNS. If I receive an email from w.x.y.z from, I can do a lookup on w.x.y.z to ensure it is really It cuts down on quite a bit of spamming and the like.

I thought outgoing should work, unfortunatly it is not.

I looked in the log file and get this if I try to send from the command line:

sendmail <where email is my email address>

test message<cr>

I get this in var/log/mail

Jul 10 13:44:07 phone postfix/pickup[5184]: E519D14000182: uid=0 from=<root>
Jul 10 13:44:07 phone postfix/cleanup[5524]: E519D14000182: message-id=<>
Jul 10 13:44:07 phone postfix/qmgr[5185]: E519D14000182: from=<>, size=284, nrcpt=1 (queue active)
Jul 10 13:44:18 phone postfix/smtp[5501]: E519D14000182: to=<>, relay=none, delay=16, delays=6.1/0/10/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for type=MX: Host not found, try again)

I have tried this with 3 different email accounts from 3 different providers and get the same in the log file.

I get the same error if I try to send a voicemail attachment from Asterisk which is my final goal. Asterisk uses “sendmail -t” on the command line though.

I have only been playing with Suse for about 2 months now and it is most of my Linux experience so please don’t assume too much.

Again thanks

Found the problem. My DNS was only set to the local router and when I added some real DNS server IPs to resolve.conf it started to work.

thanks for the responses