Setting up secondary hard drive

New linux/opensuse user.

I recently installed opensuse and wanted to add my secondary hard drive. I found the YaST Partitioner tool and wanted to use that. I have tried formatting as btrfs, xfs and ext4, i have tried different mount locations as well as the option “mount by user” in fstab option.

Nothing worked. The disk was mounted but i couldn’t use it. I found out that i can only write files to the drive if i open Dolphin in Super User Mode. But other applications could not write anything on the disk, i tried saving a libreoffie writer doc to it and always get error “Error saving the document Untitled 1: /home/xfs/Untitled 1.odt does not exist.”

What am i missing here, how am i supposed to use my other hard drive? I tried ubuntu before opensuse and have managed to set up my desk there. The application wasn’t YaST, but it looked very similar. Was i just lucky to have set it up that easily over there?

Maybe you forgot to set the ownership and permissions for the directory that is the mount point correct?
Like for every other directory/file they block or allow access.

And allow me to say: Welcome to the openSUSE forums.

Something important here. when you say things like “the disk is mounted”, always also show things. E.g., whenI want to show that something on sda is mounted:

henk@boven:~> mount | grep sda
/dev/sda3 on / type ext4 (rw,relatime)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0002,dmask=0002,allow_utime=0020,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
/dev/sda4 on /home type ext4 (rw,relatime)

Thank you very much for your help. It was indeed the issue of ownership.

I have managed to solve it by opening dolphin in super user mode and then changing permissions for the drive in question.

Is there any way i could make this default in yast for future partitions?

Also forgot to add this:
sudo mount | grep /dev/sda1
/dev/sda1 on /home/newt type xfs (rw,relatime,attr2,inode64,logbufs=8,logbsize=32k,noquota)

Fine it works now.

Remark that you did NOT change permissions for the “drive” (a MS windows term for disk I assume). nit fot the partition, but for the mount point. As I said above, ownership and permissions are crucial for each and every directory/file on the system. On them almost all security is based. You must really understand how this works to understand much about how Unix/Linux works at all.

I guess that YaST uses root:root and something like rwxr-xr-x as defaults. You can not change that default, or even the setting. You must always set it yourself (I prefer using chown and chmod), which will force you to really thinks about what they should be in every particular.

You to want to use the file system as a data space for the home directory of user newt. When that is the case, you would give it the ownership and permissions of a user’s home directory, which is most newt:users rwxr-xr-x (thi is no law, e.g. another group mat be applicable).

But when you want that file system e.g. for a databse or a large web server, or …, you probably would mount on another place and set the onership different.

YaST conforms to the Linux Standard – which reflects the UNIX® Standard –

  • Users (human) are just that – human users …
  • The (Linux/UNIX®) system as such, permits (human) users to use the machine but, in general, users can only
    use the machine – they are not allowed to meddle with system activities and, possibly, break the system – that’s the reason why, there’s a special class of users who are the system administrators …*=2]Please do not be fooled by, the openSUSE installation question related to the 1st user to be defined on the system – “Use this Password for System Administrator” – this only means that, the user “root” has (initially) the same password as that of the initial (normal) user …
  • This is the strict separation of system and users which is a feature of systems based on UNIX® – Linux, MacOS, BSD, Android, etc., etc. …

I understand. I guess I just used the wrong tool here. If YaST isn’t what i need for this task, what else can i use? Preferably something with a GUI…

Also the “solution” that i found, is that a good way to do this? Am I going to have some issues later on?
I am mainly going to use this disk for images, movies, videos and for my steam library, my games should be on it.

There is nothing wrong with using YaST for this. The only thing is that you may need to change ownership/permissions for the mount point. I wouldn’t stop using YaST for partitioning, creating file systems, creating mount points, creating fstab entries, only because of that tiny step to do yourself. Of course you can stop using YaST for this and doing it all with commands: fdisk/gdisk, mkfs, mkdir -p, vi /etc/fstab, but using YaST is for me a great help not to forget a lot of details.

Main thing is, regardless if you use YaST, commands or other tools, that you understand what the tools do and why these things should be done. Some basic knowledge about the single Unix/Linux directory tree and how to how to build it, and of course file ownership and permissions is always needed when one wants to manage a Unix/Linux system. Knowing the root password brings reponsabilities. :slight_smile:

As far as openSUSE is concerned, no, there is no other tool.

  • If your search for Linux System Management, there may well be a System Administration product out there which allows default values to be defined for common System Management tasks but, it’ll probably only be available with a service contract and time-limited licence …

[HR][/HR]Looking at your expectations, I suspect that, you need to be made aware of a simple UNIX® fact – all users, including the user “root” and the system administrators and, most of the system as such, only “see” and use files, including special files of the class “directories” –

  • Nobody, except for some very specific Kernel I/O routines, ever “sees” a physical storage device – such as a disk drive …
  • Everything is a file.
    ” – Including the I/O streams programmers use as part of the applications they write; – this extends to the fact that, the I/O stream of a physical network port is a file … - And, the file tree begins at the top-level directory “/” – everything else is in sub-directories within the top-level directory.
    *=2]Yes, System Administrators can, if the really want to, place files which are not directories in the top-level directory but, this practice has been moved to the history books; – current, modern, systems such as openSUSE only have directories located in the top-level directory.
    *=2]The system’s users have never been allowed to place files of what ever form in the top-level directory.
  • Within the top-level directory, you’ll notice some directories which are not pointing to locations on physical devices – some contain files which aren’t located in the system’s memory – the content of the files located in directories such as ‘/proc/’, ‘/run/’ and, ‘/sys/’ and, some of the files in ‘/dev’, is in general generated by the Kernel when the specific file is accessed …