Setting screen size after intalling LEAP 15.3

I’ve just upgraded to LEAP 15.3, having previously been on LEAP 15.0 for too long.

I had my screen size set correctly under 15.0 but now everything displayed is too large. “1680x1050” is the actual size of my monitor but xdpyinfo gives the size as “1024x768”.

I’m using an NVidia card.

How do I set the internal representation of my screen size to its actual size?

Assuming that you have got the package x11-video-nvidiaG04 (or higher) you should have got “nvidia-settings”. Just type it into KDE starter, it should be presented just after entering “nv…”.

I don’t want to sound stupid, but where do I find the KDE starter?

Sorry, I’m not always familiar with the correct terms. Not sure if that’s the correct name. I’d just call it the “start menu” it’s what you get when hitting the “meta” key or as it used to be “alt+F1”.

Thanks.

I looked at system settings in which there is an option to configure the monitor, but it only displays an option of 800x600. I need to configure my screen at 1680x1050.

Is this what you’re talking about?

No, there should be an application called “nvidia-settings”. You should find it by clicking on the gecko and entering “nv…” into the search field.

I don’t understand what you mean by “the gecko”.

Sorry. Here, it’s the icon at the bottom left corner:https://susepaste.org/39208207

If you use only the software that comes from openSUSE standard repos, it should “just work”, depending on the age of your card. If it’s too new, support in FOSS drivers may not have arrived yet. “Just work” in this case means support and employ your display’s native resolution with no effort on your part.

One fly in the above ointment is that sometimes this support is absent in the installation system. This is commonly worked around by a command line parameter “nomodeset”. When employed for installation, it is usually inherited by the installed system, and must be removed from the bootloader (Grub2’s /boot/grub2/grub.cfg and /etc/default/grub) for the FOSS drivers to be employed.

The other fly in the ointment is if NVidia’s proprietary drivers were ever installed prior to the upgrade. For successful upgrades to occur, it is highly recommended to remove all non-standard repos before beginning the upgrade process. This includes NVidia drivers. When these drivers are left in place during upgrade, their configuration files are left behind to interfere with FOSS driver automagic. If NVidia’s drivers are to be again installed, their installation program should reconfigure their use to whatever extent necessary, but possibly may not eliminate any left behind.

So the questions become:

  • Which model Nvidia do you have?]Did you use NVidia’s proprietary drivers in the past?]Did you remove them prior to upgrading?]Is your model supported by any currently available NVidia drivers for 15.3?]Do you wish to emply NVidia’s proprietary drivers?
inxi -Gxx

will report your model and its device ID needed to ensure selection of appropriate way forward.

I saw and read the old thread after posting here previously. (EE) open /dev/dri/card0: No such file or directory, a serious problem, shows up in the susepasted log. The driver that actually loaded as a result is the FBDEV driver, good mainly for crudely accessing a GUI in a low resolution mode, making configuration repairs, and using package management. The log also suggests you have used the proprietary NVidia driver in the past, thus to use it in 15.3 it needs to either be purged and installed anew, or upgraded, if that’s supported for the installed version of your GPU.

Provide your /var/log/Xorg.0.log from actual boot.

inxi -Gxx 
**Graphics:** 
  **Device-1:** NVIDIA GM204 [GeForce GTX 980] **driver:** N/A  
  **bus ID:** 03:00.0 **chip ID:** 10de:13c0  
  **Display:** x11 **server:** X.Org 1.20.3 **compositor:** kwin_x11  
  **driver:** nouveau **FAILED:** nvidia  
  **unloaded:** fbdev,modesetting,vesa **alternate:** nv  
  **resolution:** 800x600~75Hz **s-dpi:** 96  
  **OpenGL:** **renderer:** N/A **v:** N/A **direct render:** N/A  
[1]+  Killed                  nvidia-settings

I notice it says " driver: nouveau FAILED". Does this mean, as arvidjaar suggested, that I need to delete and reinstall the driver? If so, what’s the procedure these days?

I rebooted in order to provide this and I’m back in CLI.

The bootlog is at https://susepaste.org/91268630 and https://paste.opensuse.org/91268630.

I’ve got the graphical interface back by removing the xorg.conf that was created as a result of me running, I think, nvidia-xconfig, as requested when I tried using the nvidia-settings from the KDE menu.

The bootlog for the current session is at https://susepaste.org/76927804 and https://paste.opensuse.org/76927804.

It’s not matching the uploaded log, which says both nouveau and nvidia display drivers failed, but the fbdev did load. Likely this is a result of the ancient broken inxi provided by the Leap repos. Before using inxi again, please upgrade it:

sudo inxi -U

A required kernel device driver did fail to load, resulting in the N/A. “driver: nouveau” go together, and “FAILED: nvidia” go togther, indicating X wanted to use them. Due to the kernel device driver failure neither could be used. The kernel can only use one GPU driver per GPU, in your case either nouveau, or the one provided by an NVidia driver package.

If you want to use the FOSS drivers, nouveau for kernel module (provided with kernel package), and modesetting (not separately provided) or nouveau (from package xf86-video-nouveau) for display driver, then all traces of NVidia’s proprietary drivers must be purged. Look for blacklisted nouveau in /etc/modprobe.d/. If you find it, remove it. If any NVidia rpms remain installed, they need to be removed, and any other changes required according to the instructions provided to install them. If there are files remaining in /etc/X11/xorg.conf.d/ that the NVidia installer put there, remove them.

If you wish to use NVidia’s drivers, follow the installation/upgrade instructions provided with them.

Xorg.log, not bootlog.

First, you still have broken nVidia driver installation


    52.515] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the

    52.515] (EE) NVIDIA:     system's kernel log for additional error messages and

    52.515] (EE) NVIDIA:     consult the NVIDIA README for details. 


And nouveau is blacklisted by previous nVidia driver installation


    52.639] (EE) [drm] Failed to open DRM device for pci:0000:03:00.0: -19

    52.639] (EE) open /dev/dri/card0: No such file or directory

    52.639] (WW) Falling back to old probe method for modesetting

    52.639] (EE) open /dev/dri/card0: No such file or directory


I would completely remove nVidia drivers, reboot and then reinstall nVidia drivers again.

I’d love to use the drivers supplied by the openSUSE upgrade, as recommended. Previously it was recommended that I manually install nVidia drivers, but I thought I’d lost them ages ago.

I looked for blacklisting of nouveau in /etc/microprobe.d/ but could find a trace of it, but arvidjaar tells me it’s blacklisted. So where should I look to remove it?

I’ve not downloaded nVidia rpms in years, though it has been upgraded automagically from time to time. I doubt whether there’s an uninstalled rpm lying around, but advice on how to check would help.

How would I distinguish files in /etc/X11/xorg.conf.d/ that nVidia put there from others?

And finally, how do I force an install of the nVidia driver from the repository?

This directory does not exist and never existed.

So where should I look to remove it?

/etc/modprobe.d

grep -r nouveau /etc/modprobe.d

and make sure to recreate initrd after removing blacklist (mkinitrd). Blacklist file should be removed on driver removal, but it may stick around.

I’ve not downloaded nVidia rpms in years

In one of your threads you quite clearly listed nVidia repository.

How would I distinguish files in /etc/X11/xorg.conf.d/ that nVidia put there from others?

nVidia does not put anything there. Xorg works wit autodetection for years. Anything in /etc/X11/xorg.conf.d is exception, not a rule.

And finally, how do I force an install of the nVidia driver from the repository?

Post output of

rpm -qa \*nvidia\*
zypper lr -d

Apologies for the typo and thanks for the detailed advice. I looked in /etc/modprobe.d, not microprobe. The grep found the blacklisting. I’ll remove it.

Here’s the output from the rpm search. How do I find the folders?

rpm -qa \*nvidia\* 
nvidia-glG04-390.147-lp153.11.1.x86_64 
nvidia-computeG04-390.147-lp153.11.1.x86_64 
nvidia-texture-tools-2.1.2-bp153.1.1.x86_64 
x11-video-nvidiaG04-390.147-lp153.11.1.x86_64 
kernel-firmware-nvidia-20210208-2.4.noarch 
nvidia-gfxG04-kmp-default-390.147_k5.3.18_57-lp153.11.1.x86_64

Does “modprobe nvidia” work? Do you get any error from this command?

From you previous journalctl output you appear to have bumblebee. Do you have the second video card? If not why you installed bumblebee?

Feb 20 18:15:46 Adele systemd-udevd[540]:  /usr/lib/udev/rules.d/99-bumblebee-nvidia-dev.rules:10 Invalid value  "/bin/bash -c '/bin/mknod -m 666 /dev/nvidia-uvm c $(grep nvidia-uvm  /proc/devices | cut -d \  -f 1) 0;'" for RUN (char 51: invalid  substitution type), ignoring, but please fix it.