Session restore broken after Plasma upgrade

After the recent Plasma update desktop sessions are not restored on login. This is the case across several machines and accounts. Changing from automatic to manual session save makes no difference. The first login after the upgrade had the various applications (eg Konsole, Dolphin, Kwrite, Okular) restarted but all the instances were restarted fresh (ie, the tabs, files or directories that had been open in those applications were not restored). Subsequent logout/login lost all the applications still open at logout too but, most bizarrely, launched Konversation which is an application that I don’t think that I have used in 20 years of running openSUSE.
Since it seems that nobody else has posted on this issue here or elsewhere (at least that’s what a search showed) I assume the issue must be something specific to my setup.
Any suggestions as to where I should start looking in order to remedy this would be appreciated.

@grailawes:

First, welcome to the openSUSE Forums.


You could take a look in the KDE Discuss Forum – there are KDE developers present in that Forum – https://discuss.kde.org/

Thanks for the welcome and the suggestion. There is a similar matter raised by an Ubuntu user on the KDE forum so I’ll join that thread. I’ll leave this thread open just in case…

I have the same problem on Tumbleweed.
Restore session no longer works properly.
Use 4 desktops and nothing comes back correctly.
By the way, Firefox also does not want to restore the session.

Curiouser and curiouser. So far when I launch Firefox it does restore all the windows and tabs but maybe that will break on the next login too. By the way the thread on the KDE forum is Konsole don't remember session after upgrade to Plasma 6 - #6 by grailawes - Help - KDE Discuss if it helps.

Is this on Plasma 5 or 6??? X or Wayland???

A forum search throws following result. It is already reported at bugzilla…

X11 (not Wayland) and Plasma 5 (5.27.9-bp155.2.6.1 to be specific)

Thanks for reference to the bug report. It describes my situation. I look forward to a bugfix being pushed out (he says optimistically).

Hi,
I’ve got the same problem on Tumbleweed, Plasma 6, X11
Thunderbird and Firefox windows are restored, but Dolphin and Konsole windows are not.
Tried to switch to ‘manual save session’ (and back to autosave on exit), but no joy…

Start a new thread, this one is about Leap 15.5 and that has Plasma5 where TW has Plasma6. So definitely not the same issue. Same symptoms maybe, but not same software, not same issue.

Looks to me this is a common problem in the end.

Check the link to the Bugzilla bug.

After a number of logout-login’s it seems that the update distributed late last week solves this problem on Leap 15.5/KDE plasma-workspace 5.27.9.

I confirm, the issue is solved on the latest update.

Discourse federation when

Well, the good times lasted a week. This broke again today. Very frustrating.
It seems that the bug report (mentioned by marel) has been reopened so maybe it will be fixed again.