Services manager - Firebird

Why there is no(services manager) firebird? Ok, “service firebird start/restart” etc.
but earlier, services manager(Yast)have had an option to enable or disable services
(e.g. firebird, postgresql).
Thank you very much

p.s. openSuse 13.1 Gnome 32bit

Earlier? YaST’s Services Manager is a completely new module in 13.1.
Are you speaking of the old runlevel module? You shouldn’t use that as it didn’t even fully work on 12.3 anymore.

Or do you mean on 13.1 already with “earlier”?

Yes, the Services Manager module should show firebird and postgresql.
But those only have old-style sysvinit scripts, and there was a bug in the version shipped on 13.1 that it wouldn’t show those unless they were already running.
So have you installed all updates?

firebird might still be there, the problem I’ve found with Services manager is that it’s easy to miss/overlook or the service.

IMO, it’s easier to just use the command line nowadays

Checking current status

systemctl status firebird

And, if you want firebird to startup automatically on boot (as a service)

systemctl enable firebird

Disabling only requires substituting “disable” for enable above.

If you have a terminal open, isn’t that faster than clicking through YAST and then searching through the Services Manager?


Thanks a lot, guys!

p.s. systemctl status firebird, works good
with: systemctl enable firebird
I’ve got a message:
firebird.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig firebird on
The unit files have no [Install] section. They are not meant to be enabled
using systemctl.
Possible reasons for having this kind of units are:

  1. A unit may be statically enabled by being symlinked from another unit’s
    .wants/ or .requires/ directory.
  2. A unit’s purpose may be to act as a helper for some other unit which has
    a requirement dependency on it.
  3. A unit may be started when needed via activation (socket, path, timer,
    D-Bus, udev, scripted systemctl call, …).

chkconfig -s firebird on
works good! :wink:
chkconfig -help
chkconfig -A|–allservices (together with -l: show all services)
chkconfig -t|–terse [names] (shows the links)
chkconfig -e|–edit [names] (configure services)
chkconfig -s|–set [name state]… (configure services)
chkconfig -l|–list --deps] [names] (shows the links)
chkconfig -c|–check name [state] (check state)
chkconfig -a|–add [names] (runs insserv)
chkconfig -d|–del [names] (runs insserv -r)
chkconfig -h|–help (print usage)
chkconfig -f|–force … (call insserv with -f)

    chkconfig [name]             same as chkconfig -t
    chkconfig name state...      same as chkconfig -s name state
    chkconfig --root=<root> ...  use <root> as the root file system

You can ignore that message.
That’s just a flaw in systemd’s legacy support, but it’s just a cosmetical issue.
It does in fact work, only that message is shown by mistake.

I think it’s already fixed, though the fix is not yet available for 13.1.

Thank you very much, wolfi323](
Best regards!