See 3DS on network

Hi all,
probably i could find some advices in other topics, but i don’t know what i really need for my problem. I have connected my 3DS nintendo to the home router and i have to move files to it. The problem is that i can’t see the device on network from linux, in particular this is what i read when i click on “Rete Windows” (i think i have to click that, am i wrong?)

What i have to do?

Thanks to all and sorry for bad english :slight_smile:

Based on the following (Use Google Translate if you need to)

The Nintendo 3DS is likely serving CIFS/SAMBA shares.

This means that you have to follow the instructions on the page, but set up your Workgroup name appropriately (probably not HOME).
On openSUSE, you configure this (or view) in YaST > Network Settings > DNS tab

Once your workgroup settings match (and one or both machines are rebooted as may be needed), your openSUSE File Manager (Dolphin? PCManFM?) should be able to see the 3DS file share.


Thanks Tsu for the reply.rotfl! I just don’t understand what page are you talking about… can you link the istructions page to install and configure Samba please?

Looks like the link didn’t get into my last post


Hello Tsu. I have seen the link, thanks, but i alredy know the steps i have to do with the nintendo and with a Windows PC. My real problem is how to configure samba to see the computer/devices connected to my network…

If the 3DS is serving CIFS,
Then you should only need

Same Workgroup name
Same SAMBA version (If you can’t configure your 3DS to support v2, then you may need to configure your clients to support v1)

When these settings are same on both client and server, you should be able to see the server from the client using your file manager.


Ok thanks, this evening i’ll try it and i’ll let you know :wink:

I have created a samba server (named marcosuse), but when i try to enter in by nautilus, a message appear and nothing happen, even after many minutes… The message is: "opening marcosuse.local (smb)…

Edit: even if i try to enter the “windows network” the problem is the same, it load with “opening smb:///” but nothing happen…

You have to provide details, more detail means others will have better understanding of your situation.

It’s my understanding that the 3DS normally provides the file sharing.
If that’s true, then these last couple posts are a new, completely separate effort.

So, first the basics…

Post the following…
Your Workgroup name which should be the same for every machine in your LAN, the 3DS, the openSUSE you tried to connect to the 3DS, and the new samba server you’re setting up.

The smb.conf of the new samba server you’re setting up.

I don’t know if there are any file sharing settings on the 3DS, but if there are any those might be helpful.

The <exact> commands you are using when connecting to or mounting a file share <and the results>, in CODE tags. Be sure to identify the machine you’re running those commands on (the server should be identified in your command).

And, always make sure there is a file in the file share.
Connecting to an empty Share can be unpredictable, and easy to interpret the results incorrectly.


Ok, so i try to give all you ask:

First, these are the images about the samba server configuration:

The name of the LAN group is WORKGROUP, on server samba and even on 3DS. The 3DS settings are:

There aren’t other things to set on 3DS…

The smb.conf is:

# smb.conf is the main Samba configuration file. You find a full commented# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
    workgroup = WORKGROUP
    passdb backend = tdbsam
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = No
    add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain logons = No
    domain master = No
    security = user
    wins support = No
    ldap admin dn = 
    usershare max shares = 100
    wins server = 
    comment = Home Directories
    valid users = %S, %D%w%S
    browseable = No
    read only = No
    inherit acls = Yes
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

## Share disabled by YaST
# [netlogon]

And the commands i give to start and stop samba server are:

rcnmb start && rcsmb start


rcnmb start && rcsmb stop

like superuser.

If you need something else just ask :expressionless:

No one knows what to do?

Why are you setting up a SAMBA server? It might be helpful, but is it in any way directly related to your 3DS?
AFAIK the 3DS should be a CIFS Server, not client so setting up another server is… well, I don’t know why you’re doing that.

Although those commands might work to start/stop your samba server on an older system, if you’re running those on an openSUSE, they may or may not work… We use systemd commands (typically systemctl). I assume you’re not running those commands on your 3DS, but you should clarify.

On your openSUSE client (not server),
Have you verified your workgroup/domain name is set correctly in YaST > Network Settings?


Sorry for all tsu, but it’s too late. I liked Opensuse, but i removed it to replace it with Ubuntu 17.10, that is more useful for many aspects (in this case, the net is alredy configured and you can see all devices you want like windows).

Have a nice day and thanks for all.