Seagate USB3 portable confuses Gparted


I bought a Seagate USB3 portable storage drive from ebay. It arrived with an NTFS filesystem. I mounted it as sdc1 and tried to look at it with Gparted. Gparted interface whirled its wheels for a while and could not complete its normal scan of devices. Clearly it was confused by the plug-in seagate drive.

Gparted stopped trying to scan and asked this of me:

john@leap422:~> su -c gparted
libparted : 3.1

/dev/sdc contains GPT signatures, indicating that it has a GPT table.  However, it does not have a valid fake msdos partition table, as it should.  Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables.  Or perhaps you deleted the GPT table, and are now using an msdos partition table.  Is this a GPT partition table?

** (gpartedbin:4862): WARNING **: Invalid borders specified for theme pixmap:
borders don't fit within the image

In addition I was asked by the software to respond “yes” or “no” to the question “Is this a GPT partition table?”.

I’m being very careful because a prior USB3 drive from ebay a week earlier became irrevocably broken after I tried to do stuff with it.

What is the answer I should give the question, and why?

I think Gparted is a bit to careful here.

A GPT partiion tabel has “unused” space at the beginning of the same size as an MBR partition table. This enables to put a “fake” MBR partition table there that equals as much as possible the partitioning as defined by the GPT table. Which in your case is easy enough because just one partition that covers all can be easily expressed in an MBR table (except may be that the size could be larger then an MBR table can accommodate).

This feature has two functions.

  1. managing the GPT partitions disk with an MBR partition tool by accident will overwrite a part of the disk that contains no GPT information (will work weather or not MBR information is stored in the “unused space”).
  2. it could be that the MBR information is interpreted by GPT unaware software and that it does provide useful information, sort of fall-back.

In any case it offers a sort of backward compatibility. But IMHO it is no must to have it filled in. In fact, a GTP partitioning with e.g. 10 partitions can not be mirroreed in MBR information because in MBR that would need an extended partition which isn’t there.

So I doubt about the “as it should” from Gparted. I thus think you can confirm it is GPT (when you are certain it is).

In any case, to see what is there, you could first try with our old and very trusted tool: fdisk -l.

I have several Seagate USB3 externals, no problems with them at all.

Plugged them in, launched GParted, cleared all current partitioning, created new partition tables, created partitions I wanted and formatted with ext4.

Note that I used MBR partition tables, but could just as easily have used GPT partitioning.

Also note: I did not buy mine from ebay, bought from computer stores at great sale prices.

I have been using Seagate externals – earlier ones as well as these USB3 versions – for a few years now without any problems.

Hope this information helps you.

Thanks for the suggestions guys. The supplier is well respected (Officeworks Australia 7000 employees). The device is Seagate. It should work.

The Gparted in my Leap 42.2 sees this device as dead empty and with no partition at all. I got a bit suspicious and booted Knoppix. (which has Gparted). The Knoppix Gparted sees the Seagate as perfectly normal.

When I run this command it mounts just fine:

mount -t ntfs-3g /dev/sdc1 /mnt/sdc1

I think the Gparted in Leap has not caught up with modern technology and is getting its shoelaces in a knot.

Sorry folks, false alarm.