i activated sddm in run levels
and in with sysconfig editor to sddm

when i start the computer i get a green animated screen then a black screen

then with ctrl-alt backspace backspace sddm starts

so what else has to be done to let sddm start normal ???

latest tumbleweed and frameworks5 from repository
nvidia driver 346.72 installed

If you do the latter, the former is not necessary.

It’s actually display-manager.service that evaluates /etc/sysconfig/displaymanager and runs the corresponding DM.

And actually, enabling sddm.service can cause problems, maybe even the one you describe.
So enable display-manager.service again, this should automatically disable sddm.service I think, if not disable that manually.