Scrolling behaviour - no reverse scrolling, scrolling fast

I just converted from Leap 42.1 to Tumbleweed and now notice that in the touchpad configuration utility that the reverse scrolling option no longer works. I also notice that the scrolling is very fast and there seems to be no way to slow it down.

I have a Synaptics touchpad v7.4 in a Toshiba Satellite A660 laptop. openSUSE 20160329, Kernel 4.5.0-2-default.

This has been discussed before in a few threads, seems xf86-input-libinput needs installing;

Thanks but adding xf86-input-libinput makes no difference (KDE). Using the old kernel from Leap 42.1 (where scrolling was perfect) makes no difference either.

I correct myself! I just rebooted another time after fiddling again with the touchpad settings and now reverse scrolling works and scrolling speed is back to normal! However, now when I go into the touchpad settings many of the options are greyed out. Scrolling speed and direction now cannot be configured at all through the KDE Touchpad GUI.

This seems to have been fixed in the latest 20160408 KDE 5.6.1 . I also removed xf86-input-libinput as KDE seems to work better without it.

Maybe I am wrong but the speed translation is very unusual. Please suggest something.

Alvin Parker