Screen turns off after x minutes in opensuse 12.2, could be overheating issue?

Hi,

I got a problem when I installed 12.2 yesterday. The installer kept turning off the screen and the fan on the PSU sounds like the computer is ready to restart. If I paused for a couple of minutes and left the computer off, then tried again, I got a bit further and so on. Finally I got it installed but when booting off the hard drive I get the exact same problem.
I’m saying it could be an overheating issue because of this.

It seems strange though, because opensuse 12.1 ran perfectly on the same machine until yesterday. I also have Windows on a separate hard drive and I can’t detect any problems with it. Only problem is in the 12.2 kernel I presume.

I use nolocalapic boot flag to even get it running. Had to use it on 12.1 as well but had no problems with it.

Anyone had similar issues?

Cheers

please do not double post.

instead of making the same post in a different forum, why not go back to
your first post and tell us something about your hardware (since we
can’t guess what you have! i wonder what your hardware is that causes
you to have to use nolocalapic)…

and, be sure and tell us what graphics hardware you have and what
happens if you do not use nolocalapic but instead use

Code:

nomodeset
or if you select to boot Failsafe…does it also cause “the fan on the
PSU sounds like the computer is ready to restart.” and, please explain
what that sounds like…that is, is it very loud, or very quiet (i
don’t know what that ready to restart sounds like on your machine)


dd

More descriptions:

I’m running an old Fujitsu Esprimo P1500.
Intel Core 2 Quad Q8300 / 2.5 GHz
4GB DDR2 SDRAM
PCI Express x16 / NVIDIA GeForce GT 220
Mainboard chipset NVIDIA MCP73PV

Safe mode does not work, same goes for Nomodeset. All boot options except No local apic result in a system hang right after the green installer progress bar. (i.e. I don’t even get to the X-screen or console installation if running in text mode). But when this hang occurs the screen is still alive.

The original cause of using No local apic was that I could not get the kernel to recognize more than one core. But if I remember correctly I didn’t have to run the 12.1 installer in No local apic mode.

The PSU fan is running on almost maximum rpm’s when the crash occurm, but does not wind down like after a normal boot. Screen goes black and Ctrl+Alt+Del does not work. I’ve tried all different screen modes and kernel switches I can think of but it crashes nontheless.
Currently writing this from my Windows partition on the same computer, which works fine.

Cheers,

i’m probably not the one who is gonna solve this for you [so i hope a
video guru jumps in here]…but, if it were my machine i would:

if that guide doesn’t get you to a smile then i have no idea how to get
you there…so, follow it carefully and completely…

note, Fujitsu is fairly well know to make/sell hardware efficiently
tuned to run the Windows version the machine was shipped with, and
nothing else…

on the other hand: you bring up the possibility of heat being the
problem, and that just might be the problem [but i guess since it would
with 12.1 it might be a kernel problem]–when was the last time you
unplugged everything, opened the case and removed all the chicken bones,
rats nests and dust? carefully!! some folks buy cans of compressed air
designed for blowing out computer cases, take the machine outside and
blast away…personally i use a vacuum cleaner with a plastic fitting
on the end of the hose [don’t stick any metal in there] and suck the
dust out of the case, the cup heat sink and the power supply unit

good luck…let us know how you get along…(you may have to use 12.1 or
a different distro…or even Windows. if one wants to have Linux, one
should buy hardware known to work well with Linux)


dd http://tinyurl.com/DD-Caveat

Hello again,

A little update. I tried installing Opensuse 12.1 and to my surprise the exact same problem occured. I tried figuring out what had changed on my system since my previous installation. I picked out the graphics cart and vacuumed it properly, the removed the HDMI cable from the back. And voilà, now it’s up and running again.

Don’t know which of these things did the trick but there werent much dust in the fan at all. So I guess it was the HDMI all along.

thanks dd for the extensive reply

On 09/08/2012 12:26 AM, mvoni99 wrote:
> thanks dd for the extensive reply

welcome, and let me add that a long time ago (oh, maybe 15 years) an
old gray haired guy with a LOT of experience caring for big IBM main
frame computers told me:

Always suspect the cables first.

and from experience i know that often just unplugging and replugging all
the cables ‘fixes’ problems…


dd