Screen blanking

I updated the version of Suse I have on my home theater to 11.4 and now I have an odd problem. The screen will go blank. All black like the monitor was shut down. The first thing I thought of was the screen saver or power management but that is all disabled according to the control center. Now I have no idea.

This is a home theater it is VERY annoying to have the screen go blank in the middle of a movie or TV show. I suspect it has something to do with the screen saver because all I have to do is move the pointer or hit the space bar and it comes back. But as I said the screen saver is supposed to be turned off. So how does suse control the screen saver? Is there a file somewhere that I can checkout?


kde or gnome?

  1. Follow any desktop-specific advice that Carl (or others) provide.

  2. What does this return?

xset q |grep DPMS

If DPMS is enabled, you can disable it with

xset s noblank -dpms

Reminded me of this old thread.

Thanks for the help. It is Gnome, I should have included that.

I did the xset stuff to turn off dpms. Now I don’t get a blank screen I get a screen that has a BIG** X** in the middle and a background that is some sort of pattern. So it looks like X is doing this but why and how?

Thanks for the help.I was unaware that the modern x server did things like screen saver stuff.

I checked xset -q and now dpms is off but it still blanks the screen with the monster X from Xorg.

checked xset -q and now dpms is off but it still blanks the screen with the monster X from Xorg.

Try this instead

xset s off -dpms

(It should disable the screen saver completely).

Well the use of xset s off -dpms does seem to work. Now how do I get it into xorg so I don’t have to always type in xset? I have another system that has a slow mouse pointer and I use xset to speed it up but I have to type it in every time I log in. I have tried to put the command it a script but it doesn’t get run from a script. Any ideas?

I did try following the ideas here:

However, I FINALLY fixed the problem by generating an xorg.conf file and adding some lines to it. I followed the steps here to generate the xorg.conf file:

How to create xorg.conf in Ubuntu 9.10 -

And then in the Monitor section of the xorg.conf file add this line:

Option “DPMS”

And in the ServerLayout section add these lines:

Option “BlankTime” “0”
Option “StandbyTime” “0”
Option “SuspendTime” “0”
Option “OffTime” “0”

I made these changes to all three machines and the monitors have been on for a couple hours now.

But it didn’t work. I suspect it has to do with the settings for xorg.config being broken out into separate files in /etx/X11/xorg.conf.d But I even tried to make entries into those files. That didn’t work either.

I’ll keep searching for an answer but it seems that changing the behavior of X has gotten much harder then having an Xorg.config file.

Oh one other thing. This use of a hard coded screen saver seems to be a new thing. Someone thought “Hey we should hard code in a screen saver. So what if it’s hasn’t been needed for the last decade.” Nobody has a monitor that will burn in any more. When was the last time you saw a burned in monitor? I saw on on an ATM about a decade ago. Even my seventy five year old mother has an LCD monitor. But the folks at X just had to write this in.

Follow the advice here:

[SOLVED] Need script to autostart xset -dpms Kubuntu 10.04](

IIRC, for Gnome/KDE there is also


Unfortunately it didn’t work in the .config/autostart directory. I made a .kde/Autostart and copied the script into it and will see what happens. And yes it has execute permissions. I am going to make another script for both those locations that will write to a file in my home directory that will tell me what is happening. I will report back when I have more info.

argon99, what kind of Video chipset do you have? Have you tried adding in the nomodeset kernel startup command just before you press the enter key to select your normal openSUSE startup line in your grub menu? I have see such a problem caused by the default video driver which is using Kernel Mode Setting.

Thank You,

Unfortunately it didn’t work in the .config/autostart directory. I made a .kde/Autostart

For kde4 that should be ~/.kde4/Autostart