Samsung M2875FW MFP wireless scanner connection

Hi Folks,
I cannot seem to figure out how to connect to my older Samsung Express M2875FW wirelessly in TW (I also experienced this with OS15.3???)
I have installed the ULD, but the associated driver entry indicates that xerox_mfp driver (
I am able to connect by USB, but I want a wifi/home_network connection for a remote machine.
I am able to connect wirelessly in opensuse 42.1
I found a related post (https://forums.opensuse.org/showthread.php/535280-Driver-for-Scanner-Samsung-Xpress-M2675F-M267X) and numerous other suggestions online, but none of the seemed to help me.
I have added my username to the LP group.
Running “scanimage -L” wakes up the MFP, but doesn’t detect the scanner capability.
Running smfpnetdiscovery yeilds:

network socket://192.168.0.21 "Samsung M267x 287x Series" "Samsung M267x 287x Series on 192.168.0.21" "MFG:Samsung;CMD:PCL6,URF,FAX,FW
V,PIC,DCU,EXT;MDL:M267x 287x Series;CLS:PRINTER;CID:SA_PCL6_BW;MODE:FAX3,SCN,SPL3,R000105;" 
network ipp://192.168.0.21 "Samsung M267x 287x Series" "Samsung M267x 287x Series on 192.168.0.21" "MFG:Samsung;CMD:PCL6,URF,FAX,FWV,P
IC,DCU,EXT;MDL:M267x 287x Series;CLS:PRINTER;CID:SA_PCL6_BW;MODE:FAX3,SCN,SPL3,R000105;" 
network socket://[fe80::215:99ff:fecc:592d%enp0s20u2u4] "Samsung M267x 287x Series" "Samsung M267x 287x Series on fe80::215:99ff:fecc:
592d%enp0s20u2u4" "MFG:Samsung;CMD:PCL6,URF,FAX,FWV,PIC,DCU,EXT;MDL:M267x 287x Series;CLS:PRINTER;CID:SA_PCL6_BW;MODE:FAX3,SCN,SPL3,R0
00105;"

so it seems to be detected(???) but I haven’t figured out a way to access it by a scanner front-end (xsane, skanlite wake up the MFP but don’t detect the scanner.)
BTW…I can print with this device wirelessly.
Any suggestions?
Thanks for any help!
Brad

Is it found using scanimage?

scanimage -L

If not, stop the firewall temporarily, and run the command again.

For permanent configuration, add the IP address of the scanner to /etc/sane.d/xerox_mfp.conf

# Samsung M2875FW
tcp 192.168.0.21

I have been doing some online searching for information and some fiddling in the interim. Unfortunately, I was not rigorous or orderly in my fiddling, so I dont’ really know what it was that got things going.
However, with the firewall active, ‘scanimage -L’ returns:

device `xerox_mfp:tcp 192.168.0.21' is a Samsung M267x 287x Series multi-function peripheral

while with the firewall inactive, ‘scanimage -L’ returns a bit more information:

device `airscan:w1:Samsung M267x 287x Series (SEC001599CC592D)' is a WSD Samsung M267x 287x Series (SEC001599CC592D) ip=169.255.0.1, 1
92.168.0.21

I had added the ‘tcp xxx.xxx.xxx.xxx’ to the xerox_mfp.conf file before, but I had not commented out the USB connection information. I commented that line out for the current tests, if that matters at all.

I probably have several sane-related packages installed now that are unnecessary. I will have to trace-back to see which packages are necessary. e.g. I suspect that AirSane and hplip-sane are not necessary, but sane-airscan probably is – although not really knowing what I’m doing means this is just a colossal WAG.
Thanks for your suggestions!
Cheers,
Brad

That looks as expected. Can you not scan with scanimage or simple-scan?

scanimage > out.pnm

while with the firewall inactive, ‘scanimage -L’ returns a bit more information:

device `airscan:w1:Samsung M267x 287x Series (SEC001599CC592D)' is a WSD Samsung M267x 287x Series (SEC001599CC592D) ip=169.255.0.1, 1
92.168.0.21

This means that the device is capable of supporting airscan (universal backend for “driverless” document scanning. I would give that a go. (AFAIU, port 3702 (UDP) needs to be open for discovery via IP multicast to work.)

I had added the ‘tcp xxx.xxx.xxx.xxx’ to the xerox_mfp.conf file before, but I had not commented out the USB connection information. I commented that line out for the current tests, if that matters at all.

It shouldn’t be necessary to comment out the USB entry/entries.

I probably have several sane-related packages installed now that are unnecessary. I will have to trace-back to see which packages are necessary. e.g. I suspect that AirSane and hplip-sane are not necessary, but sane-airscan probably is – although not really knowing what I’m doing means this is just a colossal WAG.
Thanks for your suggestions!
Cheers,
Brad

Yes, sane-airscan will be needed if you want to use the “driverless” option.

Things are indeed working now and I can scan via skanlite and xsane.
Thanks for your help @deano_ferrari!
Cheers.

Good result! :slight_smile:

Hi deano_ferrari,
Any thoughts on what has changed from opensuse 43 to 15 or TW that has lead to the sane driver for the Samsung M267x M287x driver not being supported?
Not knowing anything about driver programming, it nevertheless seems like it should be a straightforward change given that so many of the other, even older, drivers have made the transition.
All the best,
Brad

Are you referring to the sane xerox_mfp driver? Are you using airscan or the xerox driver for scanning now?

I was just curious about what has changed…
In earlier versions of opensuse (e.g. pre 15) I was able to use the ULD install-scanner.sh script to successfully install the M267x 287x scanner; it showed up as an smfp device that identifies my scanner correctly with connections via IP address (as well as by an octal/hex value). I suspect this was pre airscan as that package is not loaded on the older system.
In any event, the ULD install-scanner.sh route does not seem to work for me with TW and results in an smfp scanner entry with an identification value of “No scanner recognized by this driver”.
Also, after entering the IP address of the mfp in xerox_mfp.conf, that driver seems to correctly identify the scanner, although the driver list in yast says that xerox_mfp does not support this device, so I suspect that it is not being used.
However, now it appears that the “driverless?” airscan route seems to work, which is a bonus!
Thanks for all of your help.
Cheers.
Brad

There seems to be an issue with the firewall and detecting the scanner via airscan, whether as root or as a user. I’m not sure, but it seems that I have to detect the scanner first with the firewall deactivated, then the scanner recognition persists…

Logout/login.
As root (a similar result happens as user):

scanimage -L

    No scanners were identified. If you were expecting something different....

xsane does not detect any scanners and fails to launch.

When the firewall is inactive,

scanimage -L

 device `airscan:w1:Samsung M267x 287x Series (SEC001599CC592D)' is a WSD Samsung M267x 287x Series (SEC001599CC592D) ip=169.255.0.1, 192.168.0.21

xsane launches and performs as expected.

Logout/login.
Launch xsane; no devices are available.
As user,

scanimage -L
No scanners were identified. If you were expecting something different,…
xsane does not detect any scanners and fails to launch.

Deactivate firewall.
As user,

scanimage -L
device `airscan:w1:Samsung M267x 287x Series (SEC001599CC592D)’ is a WSD Samsung M267x 287x Series (SEC001599CC592D) ip=169.255.0.1, 192.168.0.21
xsane launches and performs as expected.

Reactive firewall
As user,
xsane launches and performs as expected.
Rescan for devices
> scanimage -L
device `airscan:w1:Samsung M267x 287x Series (SEC001599CC592D)’ is a WSD Samsung M267x 287x Series (SEC001599CC592D) ip=169.255.0.1, 192.168.0.21
xsane still launches and performs as expected.

I have opened port 3702 (UDP) for home, trusted, work as suggested previously. Is there another firewall setting I should be allowing?
Cheers,
Brad

I have opened port 3702 (UDP) for home, trusted, work as suggested previously. Is there another firewall setting I should be allowing?
Cheers,
Brad

Best just to show us which zone the active interface is assigned to.

sudo firewall-cmd --get-active-zones

Sorry about that:


# firewall-cmd --get-active-zones 
docker 
  interfaces: docker0 
public 
  interfaces: enp0s20u2u4 

Your ethernet interface is assigned to the public zone…

https://firewalld.org/documentation/man-pages/firewalld.zones.html

Please show

sudo firewall-cmd --list-all --zone=public
 # firewall-cmd --list-all --zone=public  
public (active) 
  target: default 
  icmp-block-inversion: no 
  interfaces: enp0s20u2u4 
  sources:  
  services: dhcpv6-client 
  ports: 22161/udp
  protocols:  
  forward: yes 
  masquerade: no 
  forward-ports:  
  source-ports:  
  icmp-blocks:  
  rich rules: 

Hmmm. I just accepted the default firewall settings.
I assume that I should change my default zone to a trusted zone or add port 3702 (UDP) to public (or would opening that port be unwise?)
Cheers.

Ultimately it doesn’t matter which zone you select (firewalld offers a variety zones each with a configuration for their assumed general intention). You then further configure according to your own needs (balancing security with convenience etc). I assume that the computer is behind your router’s inbuilt firewall in any case.