SAMBA help required

hello everyone ,

i have recently made the switch to Opensuse 13.1 from Ubuntu, can’t say its the smoothest transition but i guess its worth it , ran in to troubles with SAMBA sharing ,
i have managed to configure SAMBA with YAst2 , below is the testparm output :

eddy@linux-6kqn:~> testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Can't find include file /etc/samba/dhcp.conf
Processing section "[homes]"
Processing section "[profiles]"
Processing section "[users]"
Processing section "[groups]"
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Press enter to see a dump of your service definitions

        map to guest = Bad User
        printcap name = cups
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        logon path = \\%L\profiles\.msprofile
        logon drive = P:
        logon home = \\%L\%U\.9xprofile
        domain master = No
        idmap config * : backend = tdb
        cups options = raw

        comment = Home Directories
        valid users = %S, %D%w%S
        read only = No
        inherit acls = Yes
        browseable = No

        comment = Network Profiles Service
        path = %H
        read only = No
        create mask = 0600
        directory mask = 0700
        store dos attributes = Yes

        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/

        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes

        comment = All Printers
        path = /var/tmp
        create mask = 0600
        printable = Yes
        print ok = Yes
        browseable = No

        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin, root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

and i also went on to YAST 2 and verified the firewall settings Opened up all the SAMBA related ports , and also configured the BROADCAST option in firewall for SAMBA Browsing ,

The issue is i can see my windows 7 computer’s shares from OpenSUSE 13.1 , but the windows 7 computer cant see the shared files on OpenSUSE 13.1 , i dont know how to figure this out , any ocnstructive help is much appreciated . cheers

ok guys , been waiting for help i got restless and give it another go to get a handle on the situation , looking at the testparm output i realised it said
/etc/samba/dhcp.conf not found , i manually created an empty file in the said directory,

plus in the Yast2>SambaServer>Identity>WINS

in this section i sleceted WINS server support and Retrieve WINS server via DHCP

Apparently that fixed the issue partially , i was able to see my Opensuse 13.1 form my windows 7 machine , now i added a linux user in to the samba user group so that i will be able to log in from windows 7 machine in to the opensuse

eddy@linux-6kqn:~> su
linux-6kqn:/home/eddy # groupadd smbgroup
linux-6kqn:/home/eddy # usermod -a -G smbgroup eddy
linux-6kqn:/home/eddy # smbpasswd -a eddy
New SMB password:
Retype new SMB password:
Added user eddy.

after that i m able to browse the user eddy whole home directory from windows machine , not sure if its a good safe practice or not

if anyone can guide me in sharing specific directories form my home directory , please feel free to help .


after restarting opensuse 13.1 , samba sharing stopped working , systemctl gave this output

linux-6kqn:/home/eddy # systemctl status smb.service
smb.service - Samba SMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled)
   Active: failed (Result: resources) since Sun 2014-01-19 12:25:30 PKT; 10s ago
  Process: 2328 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)

Jan 19 12:25:30 smbd[2328]: [2014/01/19 12:25:30.340148,  0] ../...)
Jan 19 12:25:30 smbd[2328]: standard input is not a socket, assu...n
Jan 19 12:25:30 smbd[2329]: [2014/01/19 12:25:30.342814,  0] ../...)
Jan 19 12:25:30 smbd[2329]: ERROR: can't open /var/run/samba/smb...y
Jan 19 12:25:30 systemd[1]: PID file /run/samba/ not rea....
Jan 19 12:25:30 systemd[1]: Failed to start Samba SMB Daemon.
Jan 19 12:25:30 systemd[1]: Unit smb.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
linux-6kqn:/home/eddy # systemctl status nmb.service
nmb.service - Samba NMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled)
   Active: failed (Result: timeout) since Sun 2014-01-19 11:57:10 PKT; 29min ago

Jan 19 11:55:40 linux-6kqn systemd[1]: Starting Samba NMB Daemon...
Jan 19 11:55:41 systemd[1]: PID file /run/samba/ not rea....
Jan 19 11:57:10 systemd[1]: nmb.service operation timed out. Ter....
Jan 19 11:57:10 systemd[1]: Failed to start Samba NMB Daemon.
Jan 19 11:57:10 systemd[1]: Unit nmb.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.

apparently the smb and nmb services are not enabled i , tried enabling them through YAST and also from runing

systemctl enable smb.service
systemctl enable nmb.service 

but no luck ,

was very happy to see a polished interface of Opensuse , but really loosing my nerves with the fact the LVM enncryption didnt worked with opensuse 13.1 and also now SAMBA is not working

any ideas ??

Could be apparmor

Thnx budd , it was apparmor indeed

changed the permissions in to complain instead of enforce as explained in the thread and everything worked again , but really this samba thing made me pull my hair whatever is left of them , :slight_smile:

It’s a pain